MaidSafe Dev Update - March 2, 2017 - Test 12c


#101

Somebody problems like “white screen browser” ?
I only can load a few times a page when I open the browser … after then only whitescreen on reload or new tab on all pages.
Reboot beaker works but after few pages same issue again. I had this problem some test back also?


#102

Has anyone seen this talk?

https://www.destroyallsoftware.com/talks/the-birth-and-death-of-javascript

I don’t really understand it, but it says that JS might be replaced by languages that get compiled inside the browser, in the future? Something like: all languages will be compiled into JS (alm.js) in the future so you can use better languages (C, Python etc) in your web browser? Am I understanding this right? I thought the main appeal of JS was its ubiquity, and how it kind of creates a universal programming language (rise of node.js)? Wouldnt this defeat that purpose? Also…

is the metal I/O that Maidsafe keeps talking about a tool to use Apple’s Metal programming language (in rust)?

Just trying to understand a bit more out there. He spoke about it about 3/4 of the way thru his talk.

Hopefully someone can give me a little insight here :slight_smile:


#103

It worked for me on Windows. I haven’t checked Linux, but running a vault there too. Will check later there , not home right now. Never had any problems with the audio file.

  1. mrt 2017 19:40 door safenetwork@discoursemail.com:

#104

I cannot get the browser to open anything, at all.


#105

I tried again as I had Alpha running previously and perhaps clashing on port at least; and now everything but the video on safe://cheburashka.movie/ works fine…


#106

My Vault on AWS still going strong without any issues.

Re. safe://cheburashka.movie/ I am able to load the audio but not the video.


#107

I’ve done some tests with the mp4 you uploaded.

On Windows 10:

  • Clearing the cache in the Beaker browser:
  • menu View-> Hard Reload (Clear Cache)
  • restart browser
  • typed url safe://cheburashka.movie/Cheburashka.mp4
    ->This sometimes seems to work immidiately, sometimes after a refresh or pushing multiple times on the play/pause button.

On Linux Mint 18.1, after doing the same, it doesn’t work.
But, with ‘safe video as…’ (‘right mouse button’-menu of ‘play/pause’ movie button) and maybe a refresh, it also works…

It also always works on Linux locally in the Beaker browser: e.g. url file:///tmp/Cheburashka.mp4.

I’v no idea what is happening here, but someone else hopefully does.


#108

I have found that when converting video files to mp4 unless you specify mp3 audio the video will have these issues. There are typically multiple audio codecs for mp4 video.
Not certain this is the case here, but I think it is a good place to start.


#109

Kinda off topic, but yeah, I love that video.

He’s not entirely serious obviously, but not entirely joking either.

The appeal of JS definitely is it’s ubiquity, but you have to draw a distinction between JS the language and JS the platform. Programmers always want to use the latest and greatest languages, but they also want a robust ecosystem and tools that come with a mature platform. So JS and Java both have great platforms, even though they aren’t great languages in and of themselves.

Anyways, the mio rust crate isn’t related to that Apple thing. Rust is a great language, but it’s immature as a platform, so it’s hard to find good libraries that do what you need.


#110

Yes I am sure I chose MP3 when converting the video. It actually worked fine on earlier tests. I did have to change the HTML to make it work on beaker, but the video file didn’t change.

Okay so I just checked on my laptop running Linux Mint (Ubuntu), and it’s not working there either. It’s working on the Windows machine I am on now. Strange thing is that @draw his site does work on my laptop with Linux.

I can download the movie on the laptop via ‘Save as’ as well.

Perhaps the Linux version of the browser is different from the Windows version?


#111

This is it, I too have mp4 video play on linux via SAFE browser. To me it indicates that your file is corrupt somehow. Perhaps convert it again at a slower speed if you have the option and upload a fresh copy.
Worth a try.


#112

Corrupt file, edit the video again


#113

Perhaps the file is corrupt, but to me it doesn’t make sense since it was working fine before I’m confident I’ve seen it work in Firefox on Linux in previous tests. Also the file plays fine on Windows and on Linux (not in the browser) after downloading it.

But alright let’s not put too much more effort in it. If the file is busted somehow I’m sure we won’t hear any more about this in the future. If not then future tests will provide the same results with other files.


#114

Do you run safe://dir.yvette/ ? Got a thankscoin address? I will send you some. This is an awesome site, so important.

If you want me to send YOU some thanks coin sign up for your wallet at safe://safewallet.wow/ and post the public key. Also get thankscoin by going to safe://safefaucet.wow/


#115

Thanks. I’m not familiar with thankscoin but willing to give it a go.
=> https://thankscoin.org/b8ef836fcf2e7f0db59700bbd404ed33bdb98f29/5a238724

If you want to throw other BTC/MAID or random Omni/Counterparty assets at me, you can use
=> 1LBiz6c1S7V3BTMHXWnUwcEqspBS8Y6SeV

:thumbsup:


#116

It seems that there may be two different things called thankscoin. I was talking about the one from safewallet.wow. I think they’re different unless safefaucet.wow actually gives this other thankscoin.org token.


#117

I think @waynenilsen speak about the thankscoin of @bochaco in safe://safewallet.wow/, not the thankscoin from thankscoin.org.

@waynenilsen, for the moment, you can send thanskcoin to other wallet in the same account but not to other user. The API 0.6 does not let owner change of SD so, for now, it is not possible to send thankscoin to another user.


#119

You can actually transfer them to a wallet of a different account, only thing is that when the ThanksCoins are on the other account you won’t be able to transfer them anymore, this is the detailed explanation.


#120

Thanks Gabriel.
When do you think it will be possible to send thankscoins between different accounts?

Some still believe that transfers is impossible without blockchain and see in action a token like thankscoin will open many eyes.


#121

Having fun with safe_client_libs :slight_smile:
I made a rust program that updates a safe page every minute :

safe://time.now