MaidSafe Dev Update - March 2, 2017 - Test 12c


#81

Oh, it’s a router from an ISP? well, no wonder it’s doing terrible, unorthodox things!


#82

Does it work with Windows out of interest? Just tried with non-vm Linux and still can’t connect. Windows, no problem. Same machine. Very strange. I have a BT router (yes, I know…)


#83

I can’t tell, I don’t have a windows machine here…


#84

Well I said it’s no big deal but it’s bugging me now. Here’s a summary of @nice’s and my experiences combined.

  • Linux build of vaults 13.1 fails to bootstrap with FailedExternalReachability error.
  • This has been tested on two of @nice’s machines running Fedora, also on one of mine running various Linuxes both virualised and not (USB stick). No firewalls or VPNs are running so far as I know.
  • These tests are with ISP-provided routers with port forwarding enabled for 5483.
  • Using the Windows build (same machine/router) the problem doesn’t occur for me.
  • Using an AWS instance of Ubuntu the problem doesn’t occur.
  • There is some strange behaviour with @nice’s router / firewall that @ustulation found.

So the problem may have something to do with incoming traffic from the echo/stun servers being mangled by the Linux vault build in combination with some peculiarity of our routers - haven’t heard anyone else complaining so I guess it’s not a widespread issue.

Hmmm. Buggered if I know, its got me scratching my head. Maybe sleep will bring an answer.


#85

not on a machine with direct access to the internet - it only fails behind my router

with any port apparently


#86

Ah OK. Definitely the router then. I wonder why Linux treats the packets from the router (mine at least) differently than Windows? Could there be some difference in the vaults build or is it OS related?


#87

Well the port is specified in the config file of vault.

So this would seem to be the sensible solution.

Also does this issue cause some problems with NAT traversal that you were experiencing?

I ask because doesn’t NAT traversal eliminate the need for port forwarding and thus the problems caused by it. So ignoring the port number from the echo/stun would only be a temp fix anyhow. BUT if this issue with port# changing due to the router is causing issues with NAT traversal then you need to solve it :slight_smile:


#88

Is windows using UPnP and linux not? If so then the router is treating the outgoing packets differently.


#89

Not sure. How could I tell?


#90

Turn off UPnP in the modem leaving the port forwarding in place and see if windows still works.


#91

The router you mean? :slight_smile: Yes it still connects with UPnP switched off


#92

Yes router, sorry for that.

Then linux must still have firewall rules preventing it. I haven’t done it recently so cannot help at the moment but google iptables and there should be a quick and easy guide to port forwarding in linux (usually gamers need it)


#93

I think this hit the nail on the head perfectly

Just get a $30 300MB router from Walmart that is just as good if not better, that won’t give you all these crazy limiting problems


#94

safe://cheburashka.movie/ :+1:


#95

Going swimmingly from what I can tell at my end.
When do we officially kick 12b in the rear and break new ground? :tada:

@Krekc the movie is not playing for me. I can download it and see it but it wont play in the browser.


#96

With a few improvements to the scan, I stumbled over one curious UTF-8 related :bug: that seems to limit return of non Latin, can’t find what that is to fix it; so, for now vanilla boring Latin only descriptions follow:

Out of 29 PublicIDs guessed, fell 26 websites
safe://dir.yvette

There are other directories out there safe://gugl looks to have a random option.


#97

That’s strange, assuming you are using the beaker browser as well. For me it’s working fine. I did have to update the code a bit. I shamelessly stole the code from @draw

Is his video playing for you? (sorry for making you check out that Flemish music :smile:).


#98

No probs here with the beaker browser. Video plays :+1:.


#99

There’s is some problem… I’m on Linux with slow connection atm.

I wonder media doesn’t stream until downloaded.
Earlier today, I had the audio work ok but I haven’t seen the video on safe://cheburashka.movie

The audio at safe://cheburashka.movie just now, gives error in the dev tools console as:

Failed to load resource: net::ERR_CONTENT_LENGTH_MISMATCH

My connection is rather busy atm with something else; so, it’s possibly that the file hasn’t fully downloaded, though that’s at odds with user expecting it just to stream what is available.

safe://zietemduun.draw worked… after a short delay
… though that was at a time I went into dev tools to look at the code - expect that didn’t affect it.
However, doing a hard refresh now, I get the same problem there too.

The video code on both obviously looks good for what works normally.

Also, I notice that the Launcher has whiteout… and remains so even with beaker closed now… I don’t know if launcher persists to download requests even if the browser is closed.


#100

Draws’s video plays fine for me, I am using SAFE Browser on linux. Strange that it works for Rene, what OS are you on @polpolrene?
My guess is an audio issue, did you choose MP3 audio when converting the file?