MaidSafe Dev Update - March 2, 2017 - Test 12c


#41

My vault seems to be running ok but I’m getting a few suspicious log entries.

Is the first character on each line the msg severity (trace|debug|warn|error|fatal)?

I’m getting a lot of these:

D 17-03-03 08:37:53.589198 [crust::main::connection_listener mod.rs:137] Failed to accept new socket: Error { repr: Os { code: 10035, message: “A non-blocking socket operation could not be completed immediately.” } }

and these:

T 17-03-03 08:55:15.766700 [routing::peer_manager peer_manager.rs:650] Node(bb051e…(101)) Candidate Status - No candidate is currently being handled.

and these:

D 17-03-03 07:35:34.463901 [routing::states::common::bootstrapped bootstrapped.rs:104] Node(bb051e…(101)) Message unable to be acknowledged - giving up. UnacknowledgedMessage { routing_msg: RoutingMessage { src: Section(name: bfef65…), dst: ManagedNode(name: bfef65…), content: RoutingTableResponse { Prefix(100), {PublicId(name: 8d76de…), PublicId(name: 802366…), PublicId(name: 9660fc…), PublicId(name: 8459ee…), PublicId(name: 87a8f2…), PublicId(name: 8e9277…), PublicId(name: 82775f…), PublicId(name: 9eee1f…)}, MessageId(58c991…) } }, route: 8, timer_token: 6935 }


#42

Demo app is crazy slow for me, everything from authing to creating public ID. Takes much much longer than previous test.

Im on Solus Linux.


#43

./safe_vault
I 17-03-03 08:56:14.703573

Running safe_vault v0.13.1

I 17-03-03 08:56:20.819505 Bootstrapping(b83ff5…) Failed to bootstrap. Terminating.

ubuntu tcp udp 5483 open
upnp activo

I can not boot


#44

If you could have a look at your logfile, it’s likely that this is down to failing the external reachability test - i.e. the vault yours is trying to bootstrap off can’t connect back in to you. This could be a spurious error, or could be down to e.g. having a firewall set up.

Your logfile should be called Node-.log and will be very small.


#45

Ah that should be fine - that says the non-blocking socket has nothing to give us currently and should be scheduled to be read again in the future, which it will beecause we mark it to recieve edge triggered notifications from it. So next time it triggers we would read it. There’s a PR now which should hopefully reduce the logging of these benign error msgs in future.


#46

This is awesome. Just got my first vault running from home. No problems, worked first time with no configuration or anything required on my router or mac. Just downloaded and run.

Really great work form the MaidSafe team and as excited as every about the project.


Lost password, how can I recover/change it
#47

It’s all working well now :heart_eyes:

safe://site.zz00zz/


#48

How are things looking over at HQ?


#49

Hangout city -> we are on to next iterations so mania continues. We are watching 12c logs but well into next work pieces.


#50

Almost 150 Vault now. That’s 30 more than this morning :+1:.

@maidsafe Are people allowed to run more Vaults on 1 LAN for Alpha 2?


#51

it is funny, I am running 2 vaults.
One is in the (101) section, and says "estimated network size 150"
The other is in (000), and says 104.
That makes a 50 % precision margin, quite a lot. Maybe it reduces when the numbers grow ?


#52

I don’t think you mentioned in what capacity you are taking part in this testnet? So just independent engineers running their nodes or actual collection of nodes on a webservice like amazon?


#53

Yes all independent folks here :slight_smile:


#54

How many vaults are MAIDSAFE running? 25 50 or 100? or none


#55

We are running 100 (Edit sorry) droplets here.


#56

Are the droplets still needed? Or do you run them to make the network a little larger? Started my node just now, I missed the update last night :innocent:


#57

Density is not homogeneous in the xor space and section 101 has many more nodes than section 000, so the node in this section has more neighbors and so it estimates that there are more nodes in the global network.

Real number is between the two. I think there are currently 139 nodes with the following ids I have identified:

[
		{ "prefix": "000", "count": 12, "ids":  [ "0085cd18", "05eb428b", "0695f723", "06a52a5b", "0dc1ad67", "0dfb39f0", "0f43bc47", "10928b3e", "10f7c55c", "1486de6a", "19bccb11", "1e8b686b" ] },
		{ "prefix": "001", "count": 16, "ids":  [ "22a2161f", "23ce752a", "24f5fd82", "2bf7da40", "2dbac9c3", "2edad5d6", "2f274344", "2f35de59", "348b4847", "36668f53", "36863474", "39533984", "3bef4010", "3da863e0", "3e2a34ba", "3fc3d892" ] },
		{ "prefix": "010", "count": 17, "ids":  [ "408a2679", "4304e547", "430aeecf", "44b424b5", "45cc4535", "469cf534", "476599e9", "47e03683", "4888063e", "49462557", "4acb9ee2", "4f95a1f8", "53c07a03", "541e4c11", "5631c6fe", "5c79a025", "5e7f25f0" ] },
		{ "prefix": "011", "count": 16, "ids":  [ "60506da2", "60e89a3d", "64cbac4e", "660f9682", "6813ab91", "6884f00d", "6c355c4d", "6d3395b6", "6e2e86f6", "7136fca2", "73e778a9", "74091ae7", "75918b4d", "7b5e906c", "7d5ff834", "7f65b2cf" ] },
		{ "prefix": "100", "count": 10, "ids":  [ "82775f96", "8459eee2", "8523964c", "87a8f22a", "8d76de93", "8e9277b5", "9481e229", "9660fca3", "9a0d9ecb", "9eee1fd3" ] },
		{ "prefix": "101", "count": 31, "ids":  [ "a082be18", "a0b73aa8", "a12fb7ff", "a15d6a8a", "a1fd904f", "a311b8b3", "a33a5715", "a3b8d0fd", "a5c63aed", "a92e742c", "aa55b01e", "aadf7425", "ac38dff7", "ac779872", "acaff099", "ad2a04a5", "adba769d", "aedc9abb", "af3213fd", "b09bc433", "b3531ad3", "b4544654", "b682b7fd", "b8fd665f", "b98790cc", "ba18aa35", "bc244d69", "bc7720aa", "becff4f1", "bf35c5ae", "bfef6562" ] },
		{ "prefix": "110", "count": 16, "ids":  [ "c2dd699e", "c4c20485", "c6c29ff3", "c7e85ab3", "c85c3c61", "c86fb30a", "ccd2e125", "cd2b141c", "d2a3fbdf", "d5932e30", "d8c20a37", "db2485e2", "db6c6168", "dc585c61", "de49964a", "df09841c" ] },
		{ "prefix": "1110", "count": 12, "ids":  [ "e084d4ca", "e17ac621", "e254e3ae", "e4294610", "e47727a3", "e656ac8e", "e6d74206", "e723931d", "ec3b9fa0", "ed6073c8", "ee3e2ba4", "ee50ad4a" ] },
		{ "prefix": "1111", "count": 9, "ids":  [ "f024518a", "f045f751", "f434001c", "f4a53aba", "f826b257", "fa4d6e0c", "fad72a56", "fb3ceca0", "fc507f69" ] }
]

#58

So I tried to launch a vault from home, but despite I triple checked that my router forwards 5483 tcp, and my firewall has 5483 open, the vault fails with :

Failed to bootstrap. Terminating.

I’m using the default crust config file from the zipped github release.

Upnp didn’t work either…Is there a way to turn more verbose output from the vault ? Not sure why it wouldn’t bootstrap.


#59

I found that with Linux on this testnet but it works straight away in Windows on the same machine.

EDIT: I should add the Linux version works fine on an AWS server so it’s something to do with my local setup.


#60

You should have a logfile in the same folder as your vault which is a good bit more verbose.