MaidSafe Dev Update - March 2, 2017 - Test 12c


#21

I expect you’ll need something like PuTTY for Windows… as terminal for the ssh. Long time since I used that but abcs online if you run to difficulty getting it started. Once you’re in the vultr server you are free and living the life of an ubuntu!


#22

ditto, nice find chap, looks pretty good.


#23

Happy Days are here again :fireworks:
Really liking the estimated network size! how many are droplets? 50 I guess.

safe://memory.savage
safe://wof.savage
safe://download.savage

I am oddly tense/anxious about this test, not in a bad way but in a I really hope it runs its course without any major issues kinda way.
Fingers crossed!


#24

My “Estimated Network Size” has dropped from 104 to 26. Is there a churn test happening, or is my vault broken?

I lost connection to my Linode that is running my vault for awhile, and was unable to ssh back into it. I ssh’d into another of my machines, and then tried to ssh into my vault linode from there. Still no joy. Then, a few minutes later, I am able to ssh into my vault machine again, and all seems happy, but the network size has dropped bigly.

I don’t know what weird network issue my linode had, but I wonder if it messed with my vault somehow. I assume other people are not showing a network size of only 26.

Here’s my log file, if anybody’s interested. https://transfer.sh/49L4C/node-1488488309.log
It’s complaining a lot about “Not enough signatures in Signed Message”. I think I broke it.


#25

I see atm Estimated network size: 102
and Routing Table size: 75
so perhaps you are the additional ~26 beyond the 75?


#26

Thanks. I’ll restart my vault. It’s complaining a lot about “Not enough signatures in Signed Message”. I think I broke it.
Edit: Restarted and happy again with network size of 104


#27

Candidate a33a57… passed our challenge in 99 seconds.

:open_mouth: Is that a record? I thought the test was a 400s+ required wait??

apparently not!..

Candidate 8e9277… passed our challenge in 39 seconds.


#28

You can pass quick, but the section will wait for a period anyway. So from start to finish it’s 5 mins plus a 60 second secondary vote buffer IIRC.


#29

Thanks Maidsafe Team,

Nice to have another test to try it

Starting asap :stuck_out_tongue:


#30

And if you need help with your vaults etc, you can join the live audio call right now!

Had lots of very knowledgeable people in it


#31

safe://yaw.dog


#32

I just popped my Vault “Cherry!” I got my first vault to work using AWS. This is Awesome!

Launcher and Browser work great just as before but i’m looking forward to the Authenticator!

Thanks to everyone in the conference call for helping me set everything up, especially considering my lack of computer knowledge.


#33

My first vault too! I’m quite proud of it (the team should be more proud). These are some screenshots to remind me in the future that I was running a vault when there were only 122 vaults.

Just wondering where vault data get’s stored. My C drive is a bit close to full, but loads of room on D: drive? Can I specify in config somewhere?


#34

Thank you for your service.

I’m going have to sit this testing out since I am quite busy with other things at the moment, and out of town.

What does ipc mean, from safe_client_libs folder.


#35

If you want to store your chunks on your D: drive, you can set the chunk_store_root variable in safe_vault.vault.config, perhaps something like:

{
  "wallet_address": null,
  "max_capacity": 5368709120,
  "chunk_store_root": "D:\\maidsafe\\"
}

The vault will create another directory safe_vault_chunk_store inside the one you specify, so in this case, D:\maidsafe\safe_vault_chunk_store. You’ll have to restart your vault in order for the config change to take effect.

I’m not super sure about the slash format (I don’t have anything running Windows to test on), but if you can’t get it work, just ping us and we’ll advise. Cheers!


#36

Working now. Thanks @hunterlester :slight_smile:


#37

I just checked the vault this morning , everything looks nice and steady.
It is very nice to see the estimated network size !

But this is too easy, this vault is a Vultr instance directly facing the net.
I will try from home behind the nat when I get a chance.


#38

awesome progress!!! i m sorry but I don’t understand why the tcp forwarding is needed. Thanks :slight_smile:


#39

There are some issues with NAT hole punching, so rather than delay the test 12 series the dev team turned off hole punching. So the port that the vault is listening on has to be forwarded to the vault so it can respond.

The fix for hole punching will come but their resources (people) were working on other areas for this test 12 series.


#40

NAT traversal is being worked on. For now open IP’s UpNP and port forward is OK. In time it will be automatic again where possible.


MaidSafe Dev Update - March 23, 2017