MaidSafe Dev Update - March 2, 2017 - Test 12c


#12

/Jealous

Looking forward to the vault requirement coming down a little bit so I can have a proper play with it.

Great stuff from Troon though. Fingers crossed for some really positive test results on this one. :grinning:


#13

b31a8761 @ static IP 104.154.104.21:5483

:seedling::evergreen_tree::four_leaf_clover::herb::deciduous_tree:


#14

Bah! I’m getting bootstrap error from both AWS and home machines (Linux)
Running safe_vault v0.13.1
==========================
D 17-03-02 21:10:00.534808 [crust::main::service service.rs:454] Network name: Some(“test_network_12_c”)
T 17-03-02 21:10:02.836173 [routing::states::bootstrapping bootstrapping.rs:131] Bootstrapping(7c4bdc…) Listener started on port 5483.
E 17-03-02 21:10:07.041994 [crust::main::bootstrap mod.rs:185] Failed to Bootstrap: (FailedExternalReachability) Bootstrapee node could not establish connection to us.
I 17-03-02 21:10:07.042381 [routing::states::bootstrapping bootstrapping.rs:216] Bootstrapping(7c4bdc…) Failed to bootstrap. Terminating.
D 17-03-02 21:10:07.042388 [routing::state_machine state_machine.rs:268] State::Bootstrapping(7c4bdc…) Terminating state machine

Anyone else?


#15

Is there a planned life span for this test net? If it is relatively bug free, will it run for a while, or will it only be a few days?


#16

This may mean that you need to explicitly allow external connections at port 5483, otherwise by default on AWS, no connections are allowed. I think…


#17

All the testnets in reality are short lived (maybe a week or so) as we move to Alpha II which will be longer lived. The new client API’s right now are looming so I would expect that we move rather quickly, but I always think that :wink:

I would imagine a testnet will go away in a few days, but recently the community keep them going with varying results. We have a couple of parts disabled like bootstrap cache that would allow folks to share a file simply that uses existing nodes on the network to seed of off.

So long winded and I am sorry, but bottom line testnets are probably considered short lived. Alpha/Beta will be much longer lived though.

We really need to get to secured data republish though to save everyone continually uploading again, we know it’s a pita, but we have to prioritise other things right now. More interviews this week though so hopefully more resources will help us, the recent hires have all proven very valuable, although a lot of the work is not yet visible to the community.


Pre-Dev-Update Thread! Yay! :D
#18

OK thanks. I’ll check.


#19

Vultr instance I’ve just setup is $2.50/month+VAT(uk) and less in reality if I stop it sooner a fraction of that.

For those wanting to play then here is a rough list of some of the buttons I pushed…

================
Goto
http://www.vultr.com/?ref=6817462

Deploy New Server/Instance
Vultr Cloud Compute
[Any location]
[Ubuntu 16.10]
20GB SSD $2.50/month
[scroll down and enter a server hostname]
[deploy now]

manage
get IP address and a copy of the password

[start a local terminal…]
ssh root@999.888.777.66
[password]
[you are now logged in to your server!]

mkdir ./SAFE
cd ./SAFE
wget https://github.com/maidsafe/safe_vault/releases/download/0.13.1/safe_vault-v0.13.1-linux-x64.zip
sudo apt-get -y install unzip
unzip ./safe_vault-v0.13.1-linux-x64.zip
cd ./safe_vault-v0.13.1-linux-x64
screen
[Enter x2]
./safe_vault

[wait a while…(410s)…for resource proof… ta da!]
[detach from screen and leave it running with “Ctrl-a” “d”]

then “exit” will drop your ssh connection and the vault will be there when you ssh again and “screen -r” to return to the screen with whatever is the latest output from the vault.
There are other options to screen but I can’t recall atm the detail of nohup etc to advise those.
also that setup is for a short burn and not as secure as I’d make a long standing server with new user and ssh only etc.

:thumbsup:


#20

That is cheap. Thanks for the info. I’ll see if I can work it out tomorrow. I’m a bit of a windows-using tech-tard though, so there’s a good chance I’ll get confused, annoyed and give up :laughing:

I see myself as the perfect tester for how idiot-proof and user friendly SAFE is when it’s ready to launch :wink:


#21

I expect you’ll need something like PuTTY for Windows… as terminal for the ssh. Long time since I used that but abcs online if you run to difficulty getting it started. Once you’re in the vultr server you are free and living the life of an ubuntu!


#22

ditto, nice find chap, looks pretty good.


#23

Happy Days are here again :fireworks:
Really liking the estimated network size! how many are droplets? 50 I guess.

safe://memory.savage
safe://wof.savage
safe://download.savage

I am oddly tense/anxious about this test, not in a bad way but in a I really hope it runs its course without any major issues kinda way.
Fingers crossed!


#24

My “Estimated Network Size” has dropped from 104 to 26. Is there a churn test happening, or is my vault broken?

I lost connection to my Linode that is running my vault for awhile, and was unable to ssh back into it. I ssh’d into another of my machines, and then tried to ssh into my vault linode from there. Still no joy. Then, a few minutes later, I am able to ssh into my vault machine again, and all seems happy, but the network size has dropped bigly.

I don’t know what weird network issue my linode had, but I wonder if it messed with my vault somehow. I assume other people are not showing a network size of only 26.

Here’s my log file, if anybody’s interested. https://transfer.sh/49L4C/node-1488488309.log
It’s complaining a lot about “Not enough signatures in Signed Message”. I think I broke it.


#25

I see atm Estimated network size: 102
and Routing Table size: 75
so perhaps you are the additional ~26 beyond the 75?


#26

Thanks. I’ll restart my vault. It’s complaining a lot about “Not enough signatures in Signed Message”. I think I broke it.
Edit: Restarted and happy again with network size of 104


#27

Candidate a33a57… passed our challenge in 99 seconds.

:open_mouth: Is that a record? I thought the test was a 400s+ required wait??

apparently not!..

Candidate 8e9277… passed our challenge in 39 seconds.


#28

You can pass quick, but the section will wait for a period anyway. So from start to finish it’s 5 mins plus a 60 second secondary vote buffer IIRC.


#29

Thanks Maidsafe Team,

Nice to have another test to try it

Starting asap :stuck_out_tongue:


#30

And if you need help with your vaults etc, you can join the live audio call right now!

Had lots of very knowledgeable people in it


#31

safe://yaw.dog