MaidSafe Dev Update - July 13, 2017 - Test 17


#106

Nope. Just downloaded, set up the authenticator, and tried to open a page. Authenticator isn’t showing any issues?


#107

Set your IP and use the invitation token. Otherwise you can’t connect.


#108

Did this process, successfully.

Is it possible to redo the set IP process, maybe?


#109

Seems that my IP changed. I managed to reset it by going to the inivte.maidsafe.net page and setting the IP again, but now when I try to navigate to safe://dir.yvette/ I get redirected to a page that says “This site cant be reached ERR_NOT_IMPLEMENTED”


#110

Tried another site, and it seems to be working now - I suppose it was just the IP issue!


#111

Maybe restart the browser after resetting your IP, or any time there’s a problem!


#112

Turn it off and on again. As true today as it’s always been …


#113

Thank you @maidsafe for all your hard work. This is my 1st time testing as I am very non technical and did not feel I could contribute much during the earlier testing phases. Below is the message I am getting when I try to launch the demo app and I don’t know how to fix it. Any help would be appreciated.


#114

Looking at your screenprint it looks like you are not running the SAFE Browser and thus not running the SAFE Authenticator which is integrated in to the browser.

You need to run the Browser and log in to the Authenticator to be able to authorize apps to run. You will need to make an account for the Authenticator as well.

So go back to the main post of this topic and under download get the SAFE Browser:

Then obtain an invitation token by clicking the link in the following text in the original post (click on the SAFE Network logo once the page loads):

Once you are running the browser go to the bottom of the main page and open the Authenticator. There make a new account using the invitation token you obtained.

When you have done all this and are logged in to the Authenticator try running the demo app again.


#115

Basically it is asking:
“Is it really that weak without safeguards against abuse?”

It is self-explanatory.


#116

I could be wrong but I don’t think the Demo App works with the Authenticator - I think it’s still tied to the old Launcher.


#117

I assumed she got one of the “demo” apps that are supplied for this latest test (Web Hosting Manager or Mail Demo). Either way she doesn’t seem to be running the SAFE Browser so that is a problem at least.


#118

Hi @Krekc

Thanks for your help.

I actually did all those steps 1st and then downloaded the demo app from Github from the link provided in the Authenticator. I also had the safe browser open when I clicked on the demo app link in the downloaded folder.


#119

Hi @Safety1st , only the web hosting manager app and the email app work with Test 17 for the moment, we haven’t migrated the other example apps yet.
Please download the binaries from the first post in this thread.


#120

Thank you @bochaco

This is the new error I am getting when I try to run the safe mail tutorial. I currently already have java downloaded (jre-8u131-windows-x64) and I don’t know if Java is the cause of the error.


#121

The hosting manager seems to be working just fine on the other hand. :grinning:


#122

I am too untrustworthy to participate :confused:


#123

Yes, I agree @tfa that it’s easier to tweak a config file than recompile with a flag. This suits us now, but is only a short-term solution. The key point here is that neither option is safe. It’s debatable about which option is safer, but ultimately its a moot point.

Longer-term we’ll be looking to make this safe regardless. That’ll probably involve a combination of changes: some of the dev options will become obsolete and get removed once they’ve served their temporary purpose; others may only (negatively) affect the vault running with those options but can be considered “safe” since they don’t affect the rest of the network (an example off the top of my head might be an option to log your vault’s throughput); others will be disallowed and enforced by the network.

Basically, the network will have to defend itself against any of these potentially harmful dev options whether or not they exist as dev options in a config file or dev options via a compile flag or not as dev options at all (i.e. an attacker modifying the code and recompiling).


#124

Is anyone else having issues logging into test17?

I’m getting this error message:

Core error: Unexpected: Could not connect to the SAFE Network

Thanks

Adam


#125

Just tried and seems fine to me.

That indicates a bootstrap failure, while not conclusive could be something to check quickly. If you were previously able to connect, might be worth visiting https://invite.maidsafe.net/ and confirming your registered IP matches the current IP. If it does not match, you might need to hit the update button and update the whitelist to bootstrap. If all that is as expected, then maybe worth having a look at the log file which would be next to the browser binary for more info.