MaidSafe Dev Update - July 13, 2017 - Test 17


#84

How exactly does the remapping work? I see the option but it’s kind of vauge.


#86

Remove all your old browser binaries.
Restart your machine.
Open the new browser and try to authorise from applications. This should register safe-auth protocol pointing the new path.


#87

For some reason I can’t set up the browser even though I’ve trust level 2-

I see this message. Any idea what I’m missing?
I first clicked the invitation link using my work laptop. It worked fine there. However I didn’t want to set up anything from work laptop. So I closed the window and tried to access the link using my personal laptop.


#88

make sure to update the IP. That needs to be done through the invitation link again.


#89

Sorry didn’t quite follow. I see this ‘please wait’ message if I click the invitation link. Is there any other way to update the IP?


#90

No that’s it. Could be some trouble with that server?


#92

YES will be testing tonight when I get home.


#93

Looks like I’m almost there


#94

No offense, but what good is it if it only works with trusted members? What you are trying to do is extremely challenging, and I commend your efforts. But is it really so fragile?


#95

Yes, think of all of this as an evolution, either an animal or ant being grown, or more the very first few web servers/browsers. So yes it will be this fragile as we move on, getting stronger all the time.

There are two paths to this.

  1. Until all the features are in place, like payment by resources for resources (or simplistically safecoin) then it cannot be considered “strong”.
  2. Even with all features in place there will be both bugs and much much better fundamental “rules” within the network. So even then it may be somewhat fragile, thats a tougher one to reason.

So we are heading for 1. and for 2. we are heading for minimal, perhaps slower that we anticipate.

On this issue, @Viv and I have been talking and I will do a blog post about this. We are not rebuilding the Internet as we know it. We have used the analogy of us building a quantum computer and everyone wants to run tetris/doom and word/excel on it, but it’s much much more than that and a secure autonomous network can allow so so much more than secure way of playing games or web browsing.

In saying that secure messaging and data storage is bigger than we all realise at times, but it’s more than that, and more than “secure super mario” even if cannot run super mario as we wish it to. Sort of like Tesla [edit cheers @BIGbtc ] cars produce nothing to feed our plants like horses did (I realise that is a sh*t analogy :wink: )

Anyway I ramble, hope this helps.


#96

Thanks for clarifying.


#97

I look forward to a blog expanding on this - was a bit hard to follow.
thx!


#98

Those must have been Elon’s betamobiles? Testla’s?


#99

I was just thinking, once alpha 2 is up and going @maidsafe should publish their maidsafe.net site to the safe network. Should be simple and it’d be cool to see a nice modern functional site on the safe network.


#100

I am assuming that the SAFE browser is separate to the module that collects (leeches) the data and peers (seeds) it off to the network, that must be the vault module. So people will still be able to use the browser without having the vault and that would mean complete separation of concerns. Can anyone confirm if that is right?


#101

2 important things in SAFE:

  • The Vaults: they make the network and route data etc.
  • The Client: this connects to a group of Vaults over a proxy.

So the SAFE Browser in this case is a client, it doesn’t route the data in the network.


#102

Ok thanks for the explanation, I see that the browser acts as a complete stand alone app then even if you don’t participate in the vault. I heard that you get a token when you get to level 2 which allows you to use it, I have just built it from the source but not sure where I would put the token when I get one as I don’t see any option to add a token…


#103

The token is input into the authenticator, which is now integrated into the browser and pops up inside the browser when an app requests authorisation using the API (or you can open it manually by visiting safe-auth://home/).

Note: the token is only temporary, to restrict testing to invitees. It isn’t part of the network design.


#104

Is the Test network currently up? I can’t seem to get any of the apps to connect, and I can’t navigate to any SAFE sites.


#105

Working fine here. Did you changed IP??