MaidSafe Dev Update - July 13, 2017 - Test 17

Hooray! safe://home.am2on seems to be working. My email is am2onmail (for some reason I couldn’t use am2on as a mail ID, it threw an error)

Was the network data reset? I tried some of the sites linked a few days ago in the feedback thread, but none of them seemed to work.

3 Likes

This is due to one of the limitations mentioned in the update:

Yes, this is a new network.

2 Likes

Great idea not to let the general public play as yet. Guys like me with no technical background would probably have difficulty. When you need a test dummy for the man on the street, I’m happy to help

4 Likes

Site: safe://portlandspirit/
SAFEMail: tomcarlson

How is this possible?

Previous version I had was v0.4.3…?

Date - 3-23-2017

Yes, this was for @joshuef’s version that was developed in the context of the CEP: https://github.com/joshuef/beaker/releases. It was compatible with SAFE Launcher.

The version you are using now (SAFE Browser v0.3.0) is being developed by @maidsafe: https://github.com/maidsafe/safe_browser/releases. It’s using the new paradigm of SAFE Authenticator and Mutable Data :slightly_smiling_face:

4 Likes

Ahh thanks for the clarification.

1 Like

This is great news, especially as I now qualify to be “in” :slight_smile:

2 Likes

I have exhausted my 500 operations :sob:
Having issues uploading video files, I reported the issue but if anybody else can try their luck I am out of the game until a reset I imagine.

safe://memory-game.sav

3 Likes

lol…

When I tried to load your website. It crashes the browser.

edited:

Huh. it works now. Three crashes, and now it works again.

1 Like

updated the link… please try again

Now it gets fun. :smiley: App dev is going explode and core development is going to move at a faster pace in parallel.

The days of low forum activity and mind numbing boredom due to little “apparent” progress is over.

By early august we’ll be at full steam. Buckle up people it’s going to a wild ride!!! :v: :sunglasses:

10 Likes

Sorry to ask the question if it was answered elsewhere: do we still need to configure our routers to let the client connect, or is a version of hole punching already in place ?

1 Like

That was required for running vaults, you shouldn’t need any special setup to run the browser and apps.

6 Likes

safe://hello
safe://the.odyssey

:thumbsup:

1 Like

Okay am I just doing something wrong? Whenever I try to launch and authenticate an app it launches in firefox not the SAFEBrowser.

NFS Bug still present (related to https://github.com/maidsafe/safe_vault/issues/601)
When creating a new account or attempting to login, the whole browser crashes.

I’m on a:
OSX El Capitan (v 10.11.6)
Processor: 3.2 Ghz intel i5
RAM Memory: 8GB 1867 DDR3
Graphics: AMD Radeon R9 M380 2048MB

Ouch that has gotta hurt.

Very glad to see the network up again.

Is there any particular reason for the browser being > 100 MB and the web hosting manager > 50 MB? This seems very large indeed. I understand dependencies are included etc but even so, it seems very large.

4 Likes

That’c correct @mav. We will looking to bring down the size the best we can by the next release hopefully. As you said, the dependencies are more and most of them download the entire source code. Most of the dependencies doesn’t seem to provide a minified version when we install. Here is a task for the same to start with browser

9 Likes