MaidSafe Dev Update - July 13, 2017 - Test 17


#118

Hi @Krekc

Thanks for your help.

I actually did all those steps 1st and then downloaded the demo app from Github from the link provided in the Authenticator. I also had the safe browser open when I clicked on the demo app link in the downloaded folder.


#119

Hi @Safety1st , only the web hosting manager app and the email app work with Test 17 for the moment, we haven’t migrated the other example apps yet.
Please download the binaries from the first post in this thread.


#120

Thank you @bochaco

This is the new error I am getting when I try to run the safe mail tutorial. I currently already have java downloaded (jre-8u131-windows-x64) and I don’t know if Java is the cause of the error.


#121

The hosting manager seems to be working just fine on the other hand. :grinning:


#122

I am too untrustworthy to participate :confused:


#123

Yes, I agree @tfa that it’s easier to tweak a config file than recompile with a flag. This suits us now, but is only a short-term solution. The key point here is that neither option is safe. It’s debatable about which option is safer, but ultimately its a moot point.

Longer-term we’ll be looking to make this safe regardless. That’ll probably involve a combination of changes: some of the dev options will become obsolete and get removed once they’ve served their temporary purpose; others may only (negatively) affect the vault running with those options but can be considered “safe” since they don’t affect the rest of the network (an example off the top of my head might be an option to log your vault’s throughput); others will be disallowed and enforced by the network.

Basically, the network will have to defend itself against any of these potentially harmful dev options whether or not they exist as dev options in a config file or dev options via a compile flag or not as dev options at all (i.e. an attacker modifying the code and recompiling).


#124

Is anyone else having issues logging into test17?

I’m getting this error message:

Core error: Unexpected: Could not connect to the SAFE Network

Thanks

Adam


#125

Just tried and seems fine to me.

That indicates a bootstrap failure, while not conclusive could be something to check quickly. If you were previously able to connect, might be worth visiting https://invite.maidsafe.net/ and confirming your registered IP matches the current IP. If it does not match, you might need to hit the update button and update the whitelist to bootstrap. If all that is as expected, then maybe worth having a look at the log file which would be next to the browser binary for more info.


#126

Forgot about this IP stuff. Had my VPN turned on last night and I didnt when I created my account…
:wink:

Thanks!


#127

I suggest adding a hint to that error message while we’re limiting IP addresses. This will keep cropping up.


#128

Yeh it’ll prolly make it more precise if rather than just a hint, we can also split the error reason further up as this is just one of quite a few things that can currently trigger it, for example

  • no network access (wifi off / cable out / …)
  • proxy is at max client capacity
  • IP related - outdated / not set
  • validated proxies have banned the client for something they did

#129

Screenshot of

You’re Banned

Will be the new forum badge of honour!


#130

I can always help you get that badge mark if you’d like :wink:


#131

Who moi? :grimacing:


#132

Cant get the Safe Demo App to work. Failed to authorize with launcher error?

Does anyone else have this working?

version is 0.62

Thanks!


#133

The Demo App and Launcher don’t work on the current network. The launcher has been replaced by the browser-authenticator. See here and comments below it.


#134

Hello!
I have created a SAFE account on the test net 19. What follows is a report of my failed attempt to create it on the test net 18.
I’ve downloaded the installation kit for the SAFE browser and run “SAFE Browser.exe”. The browser opened and offered me to open an account using the authenticator. I got an invitation token and input it, a secret, and a password. Instead of creating the account, the authenticator returns to the Invitation Token page and displays in red this text: "Core error: Unexpected: Could not connect to the SAFE Network"
I want to follow your work and test your programs. How will you help me e.g. open an account with you?
(I usually use computers logically. Now I’ve entered the secret and the password as if I had an account. The same error occurs.)


#135

@Julian Test 18 should be offline check for the most recent update with test 19 binaries.


#136

I did that as you wrote me.
The SAFE browser and web hosting manager work on Windows. I’ve done 400 out of the 1,000 operations permitted. I might not use these two programs for a while, but I’m interested in how they work, e.g. where they store what data and how they transfer data, and how they benefit us.
Who’s going to maintain the SAFE network under what terms?
We could make our data management program work in this network.


#137

The browser and web hosting manager are interacting with the SAFE network (testnet 19 more specifically). The data is stored in vaults running on nodes hosted by MaidSafe in this testnet. In later versions (and in some earlier ones) the vaults will be on user’s computers. The benefits for users are privacy, security, and control of their data. For developers, the advantages are not having to manage the infrastructure for your app, developer rewards, and the ability to make apps that weren’t possible before.