MaidSafe Dev Update - August 31, 2017 - Test 19


#62

When does the error occur?


#63

You don’t need to be logged in, BUT I think you will need to make sure your IP address is white listed (via the ‘invite’ link in the OP).


#64

When I try to visit a safe webpage. I am connected to the network.


#65

Does it happen with all safe web pages or just a particular site?


#66

I just had the same error. (It happened for all sites)
Try closing the SAFE Browser and start it again.
I left the browser open for a few hours without actually using it. This is when the error occured for me.
Restarting the browser helped.


#67

Interesting. This seems like a bug.


#68

It happens for all sites.


#69

Everything is fine now after restarting the browser.
It’ll be nice if this is addressed before alpha 2 release.


#70

That’s good. There are a few things that aren’t quite right still. That’s only to be expected in test mode. Fortunately most problems can be solved by closing everything down and starting up again.


#71

I’m finding the email app will not authorise after a while. When my account got up to something like 600 PUTs the email app just hangs on ‘initialising’ after authorising. After about 10 seconds it fails with a ‘could not authorise’ popup. I tried clearing everything and restarting but same thing happened. I then created a new account with a new invite code and it worked first time.

Edit: Going into this further it seems there’s sometimes contention between the applications for authorisation. So if you have 2 already authorised the third one will sometimes have problems. Sometimes but not always. Sometimes revoking the others does the trick. Sometimes but not always. @maidsafe let me know if you need any logs.


#72

Just downloaded the Safe browser for the first time ever and it works perfectly! This makes me happy :slight_smile:


#73

Should I file a github bug for this?


#74

It is so thrilling to see this system coming together! Thanks to the hardworking folks at Maidsafe and to all who have brought it to this point!

Check out my newbie test upload (safe://biblio.hlmencken). It is especially for any fans out there of H. L. Mencken and of his irascible, acerbic, insightful (and inciteful) wit. Mencken would have loved what the Safe Network is about.


#75

This is a great point


#76

Its telling me the same error as last time

image


#77

OK that is now fixed, cannot run must extract.

But now I get this:

image


#78

OK all fixed, have to extract all then run and MUST set IP via invite link.


#79

If you guys are having trouble getting into the system, then I have no hope in hell. I just hope that someone will be working on the “idiots guide” to the Safenet in due course


#80

Don’t worry - it’s currently complicated to restrict access to specific IP addresses, so when it’s time for an open launch, all you’ll need to worry about is downloading the right browser, then using a username / password combo.

It should be no harder than signing into Chrome at launch.


#81

Which ways are there to get an invite? It seems I can only get an invite by logging in via the safe browser but I need to be trust level 1, which is unfortunate because I am not. In your context does OP mean Operating Program (aka safe browser) ?