MaidSafe Dev Update - August 31, 2017 - Test 19


#42

@frabrunelle is there a master repository for documentation?? I’m getting asked by an interested developer


#43

No, the documentation is a bit spread out right now. But there are some good resources on the SAFE Dev Forum. For example, see the following topics:


#44

I ended up directing him to safedev.org and a couple of those threads but that would be nice to have a master doc crate in the GitHub repos


#45

The SAFE API Playground is working for me. I uploaded two sites safe://vidy.test and safe://demoy.test. They both initialise and receive an app handle but fail to connect or return any errors in the console. They are pretty much the same as the ones that worked on testnet 18.


#46

Through testing I’ve found that it’s not possible to share an app’s root (own) container.
It’s not to do with it being private because private MD’s may also be shared.

To find out I’m following the path of app registration, https://github.com/maidsafe/safe_client_libs/blob/master/safe_app/src/lib.rs#L143, but can’t quite see where and how the root container is created. I need insight from one of our back-end engineers.

@Joseph_Meagher I’ll get connected right now and see what’s going on.


#47

Looks like “protection” :smile:


#48

Testing over and over again in web API playground, I’m intermittently receiving this error as well.
Was mostly successful yesterday but I do see the rate of error has increased in the past hour or so.

Opening a ticket for this: MAID-2321


#49

First impressions on using Testnet 19:

It’s nice. The browser is pretty tidy.

The name of permission “App’s own container” is meaningless to me. It might be changed to something like “Store data for this app”. Just something that better indicates what the permission does rather than what it is. Giving permission to ‘store data’ is much more meaningful than to ‘be a container’. I think the details of the permission hidden behind the dropdown toggle explain it well, but the main name of it (which is the only thing most people will read) is not very descriptive. Same with using the Web Manager App, the permissions just don’t seem effective at describing what I’m allowing the app to do with my account.

I uploaded a file via Web Manager App and when it finished uploading it showed “Loading” then “No files found. Please upload web files” then “Loading” again, then it showed the file I’d uploaded. This was a bit odd and made me initially feel the upload had failed.

Overall this was a pretty smooth network to test and the things that bothered me were relatively small issues. I still wouldn’t feel comfortable demoing it to anyone nontechnical but I really like how it’s shaping up.


#50

Sounds like a ticket or two has been raised so I hope some of @mav 's feedback is considered. It was nice seeing the communities feedback heard to shape the UX thus far! I won’t be able to play till Sunday but it’s been since 17 for me so I’d like to get another crack. Looks like only new UI binaries would be needed. Alpha 2 should be solid!


#51

Looking really good. No glitches at all on my end.


#52

Just tried to register for the new Test19. The registration flow is really easy. Good work on that!

Edit: Error resolved. I copied the invitation token without clicking on "Set IP"
It might be better to show the invitation token only after the IP is set… :smiley:

setIp


The following error has been resolved by setting IP.

Unfortunately I am getting an error when trying to register. After entering my secret and my password, I get an “Core error” on the first page… Any idea?

coreError

Edit:


#53

yes i am getting the same error, is the safe network down atm?


#54

I got the browser running, and it looks good. But (here comes a noob question)… I’m not quite sure what to do with it. Are there sites to visit or apps to load?


#55

Best thing is to download the Web Hosting Manager and create and upload your own website. See the original post for links.

There are some sites to visit (see above) but there doesn’t seem to be much of a list at present.

You can try this one to see if it works though.

safe://safeblues.jpl


#56

At the risk of sounding like the I.T. Crowd have you tried closing the browser down and starting it up again? You might also need to check if your IP address has changed in the meantime and reset it at invite.maidsafe.net


#57

It’s working now. I forgot to actually click “SET IP”, so that’s why i could’nt connect. My IP wasn’t whitelisted. :smiley:

I uploaded a few js games:

safe://2048.play --> well known 2048 game
safe://ohh1.play --> pretty cool strategy game
safe://digger.play --> pretty nice strategy game
safe://alien-invasion.play --> 1 level only
safe://infinite-mario-bros.play --> Super Mario but my safe browser keeps crashing)

uploading such js pages works like a charm! superbe work @maidsafe


#58

I’m liking the sum total of small changes, seems a bit quicker to respond; the feedback is improved; and zero point files upload. :smiley:

If everything a user wanted to upload was within a folder, could that content not be uploaded into root, instead of creating that folder in root? So, just encourage that the user selects a folder and alert them everything within that becomes root.

The few usual suspects then:
safe://hello
safe://eye.eye
safe://the.odyssey
safe://wall.knot - speed test ~19.4MB


#59

Any chance of you coming up to Penang?


#60

I am running into this issue:
01 PM

Some help please?


#61

Do I need to sign in to visit these links ?