MaidSafe Dev Update - August 3, 2017 - Test 18


#122

Hi Everyone,

I am pretty noob to MaidSafe in the development side. I have two questions;

#1. Mock-routing

Recently I am trying to build a Mock-routing on my ubuntu 16.04,
but i have no luck. Many error, so I gave up for a few day.

Anyway, can anyone tell me what the problem here.

I have followed the README.md in the safe-browser still have those error.

#2. Related to Test 18
I have set up registered IP via the invite link.
It gave me the token and tell me to copy and use for the Authenticator
maid-test-18

What authenticator does it meant? How can I get there?

Thanks so much and looking forward for any help and advice.

Rithy


#123

brother, could help advice to my question above.


#124

I can answer number 2.

You need to download the SAFE Browser from here, unzip the file, launch the browser and click on the ‘A’ in the toolbar or go here: safe-auth://home/#/login

Then you have to set up an account. During that process you’ll be asked for the token.


#125

Did you follow this tutorial?


#126

I was trying to build safe browser from source via git clone but no luck.

Anyway, its now work with the download file thank you, @JPL i have it work now. Thank you.

@digipl i have tried so many time, but its always not working. Since the download file work direct with the mock-routing for now, so i think i am satified for now.


#127

Have a couple issues with the SAFE browser.

One is that WebGL doesn’t work for me, but it does for several others. It works in firefox and chrome on my computer.

I’m running Windows.

Here’s a test site for WebGL safe://test.webgl

Another issue I found is that if I go to Developer Tools, then Sources, then right click a file, then save as, then there’s a popup saying “You can’t open this location using this program.” It does work however, after closing the popup.


#128

While the localhost support was a vast improvement in dev convenience, the above change is a bit annoying. As far as I can tell there is no way right now to avoid having to re-authorise after every refresh. It’s not a very big deal, but after dealing with it for a number of days I’d rather see it gone sooner than later, or at least in dev env?


#130

Is this happening for you even after unlocking:


#132

@intrz @Matt

Do you still get this proxy.pac download notice with the latest testnets?

What OS are you on? (And it’s occurring when you navigate in the SAFE Browser, but the download happens in Chrome?)

Can you check if you have any proxy settings set in your browser/system (perhaps from an old testnet)?

Thanks!


#133

Yes, the download happened in chrome when navigating in the SAFE Browser.

There was some proxy settings from an old testnet as suggested in another post, removing it fixed the issue.


#134

Ah, perfect.

Thanks @intrz :confetti_ball: