MaidSafe Dev Update - August 3, 2017 - Test 18


#82

After alpha 2 we will likely go back to iterative test nets with vaults at home once data chains is ready which sounds like they are making some headway. Alpha 3 will be vaults at home most certainly


#83

It’s been spinning for 10 minutes for me…can’t seem to get in :(:confused:


#84

@Suriana, is it the authenticator that is spinning for a while? Can you also let me know the OS in which you are trying? If you are trying on linux or windows, you can find the authenticator log in the same folder where the browser binary is placed. If you can share it with me in a DM or stick it in as a Github Issue it will be helpful to check this issue.


#85

Disabling the drag and drop feature in the application should resolve this white screen issue. May be allow drag and drop only in the file manager section. Will try to get this addressed in the next version.


#86

TEST-17 (internal and normal) should be offline now and also gone from the network list in the invite token server.


#87

:slightly_smiling_face:you got DM


#88

Created the Github issue based on the logs from @Suriana. Thanks a lot for helping us out @Suriana.


#89

FYI: Linux Mint + debian 8 (LMDE)

  • Browser - fine
  • Web host manager - fine (created public id, service, uploaded) safe://rsports
  • Email demo - fine (created email ID: happybeing)

Not tried any other sites yet.

website: safe://rsports
email: happybeing

UPDATE: @Viv FYI, after shutting down and restarting my PC (so different IP now)…

Browser can’t connect (didn’t wait for an error as I realised I need to update my IP)
Go to the update IP link for my original invitation, I just get "Wait…"
Tried again, same thing "Wait…"
Being impatient I requested a new invite, and this successfully updated my IP and I can now access safe://yvette
I can also log into the account I created with the first invite
Now trying safechat.jam :slight_smile:

I’ve now loaded all these test websites (grabbed from the above posts):

safe://polpolrene/
safe://elvis
safe://rene
safe://davidspeaks
safe://tetris
safe://yvette
safe://bit.miffed
safe://safechat.jam (Details/support here: Joseph's Safe Websites Project)
safe://home.sam
safe://hello
safe://the.odyssey
safe://eye.eye
safe://plant.draw
safe://rsports


#90

Yep spinning for me with no results for several minutes. Running win7


#91

Hmm maybe also related to the same issue. Can you do a small check please. If you open file explorer and go to C:\Windows\System32 do you see a file called vcruntime140.dll ??


Can't get TEST 18 & 17 to work
#92

no that file is not on my system


#93

ah that might be good news then to get to the bottom of this issue.

Do you mind visiting https://www.microsoft.com/en-us/download/details.aspx?id=48145 -> choose Download, ensure in the following dialog you choose vc_redist.x64.exe -> click Next and the download should start.

Once done, if you run it and install it fully, might need to restart your system. That missing file should be there now and try the SAFE Browser then please to run it and see if you can create an account.

Side note: That download link is to install some dependencies(Visual C++ Redistributable 2015) required in the system which are not part of the browser application itself but expected to be installed in the target system. An installer should be performing a similar check to what you did and doing the install step if required, but this package not being an installer isn’t currently doing that check and it just might be that which is causing this issue cos of the missing dependencies.


Can't get TEST 18 & 17 to work
#94

Yep that worked! Just installed it and opened up the safe browser without restarting and have logged on straight away :smiley:


#95

Glad you got that sorted :slight_smile: Sorry about that issue.


#96

no problem at all, glad to have been able to help a bit to clear up the issue! :slight_smile:


#97

Hi,

I’ve participated in every test network since May 2016 and would like to participate in TEST 17/18.
Can someone tell me what I need to do to get my trust level (“basic user”) to at least Level 1?

These are my account stats:
170 days visited
1d read time
7.0k posts read
1 like given
0 topics created
4 posts created
7 likes received


#98

@sunhillow, I just checked and you are a Level 1.

Are you having some sort of issue?


#99

Hi,
On my account page (https://safenetforum.org/u/sunhillow), I see this:
Joined Oct 25, '14
Last Post 37 mins
Seen 2 mins
Views 5
Trust Level basic user

Which page displays the trust level you mentioned (Level 1)?


#100

Basic user = trust level 1 (don’t ask me why)


#101

Thank you for your help, @upstate and @JPL.