MaidSafe Dev Update - August 3, 2017 - Test 18


#42

Umm - that one slipped through the net - sorry! You’re right in that it means one client per IP address per proxy, but we actually had that restriction in place for Test 17 too - oops! :open_mouth:

We really only meant to mention the fifth bullet point: that we tweaked the client rate-limiter to remove the restriction on the total number of clients a proxy will support. We’re expecting that we’ll be poking about in there again once we get a chance to assess the results of Test 18.

For now, it’s a bit of a balancing act trying to protect the network from “problem” clients while still giving the rest of the clients a decent service. For example, the change we made in this iteration means that a proxy node with ten connected clients will now accept an eleventh client rather than rejecting it (assuming it has a different IP address to the other ten). Great news for that eleventh guy, but the proxy’s throughput is now shared between eleven, so the original ten all experience a slightly reduced service.

Sorry for the fake news! The rest of the update is all absolutely 110% correct probably :slight_smile:


#43

I can try answering from the rust side - so we always had this nfs file creation logic in safe-core but was exposed to safe-auththenticator only. There was a disconnect between safe-app and the nfs layer in safe-core. So safe-app only exposed primitives with which you could create a file in customised way (you create the immutable data, then pass it to self enc, get data map, put it to the network etc). With nfs now correctly exposed for safe-app too, if the frontend lib chooses it can use the facilities there which auto manage all this for you. There is that File struct linked in the update that contains the pointer to the ImmutableData with hosts encrypted/plain-text (depending) DataMap. The File is serialised (and encrpted, depending on privacy) and put as an entry in the parent MData.

Ofc, you can bypass all that and continue using the raw interface too to do custom stuffs, but now you have some choice of abstraction (and it manages security for you) - so that’s the change from high level.


#44

Nice example site. Thanks


#45

Very nice update as usual! I’m very excited about the next Alpha version!! :stuck_out_tongue:


#46

Usual suspects:
safe://hello
safe://yvette
safe://the.odyssey
safe://eye.eye

but there’s now no positive feedback on large file upload, so safe://wall.knot seems not to be completing its ~19MB upload. I rather miss the noise in the terminal to know something is progressing. logged at #222 trying that url, it’s as if it is expecting the file is there to download… rotating circle having caught the html and css file that have uploaded.

too trivial to log… the link from the web host manager back to browser seems to prefer the /index.html rather than not having that.


#47

Hello! :slight_smile:

After choosing test18 the authenticator assumes I already have an account. Tried to login with test17 details, no luck.
Not too obvious how to create a new network login.

Any tips?

Edit: !!! The create account was off screen. Sorry!


#48

Awesome !! Quick 18…


#49

Love your site. Pac man… wow.


#50

Browser.exe removed by antivirus, this has never happened before. Apparently the risk has increased with v0.4 to the point that I am not asked as with previous tests, its an automatic delete.

… there goes web hosting manager and email exe as I type. why the sudden higher perceived risk?

and… binding.node is not safe and has been removed.


#51

Here’s a great simple free open-source webserver for win / mac, simple 1 click serving of a desktop folder website etc, for quick use with the new SAFE Browser ‘localhost’ functionality.

Video tutorials:


#52

hmm so test 18 is working for you guys?

mine has been spinning for 10+ min straight


#53

I was able to connect (the loading spinner was only up for about a second or two) but I’m still getting the error messages with the Web Hosting Manager that I mentioned in my previous post.


#54

There doesn’t seem to be any ‘file not found’ error page any more. Much as I disliked the big old ugly ERR_NOT_IMPLEMENTED message, it at least had the benefit of clarity. Now there’s just an arrow that goes round and round forever.


#55

Just to check - have you got your invite code and authenticated your IP? https://invite.maidsafe.net/


#56

Yes, I’ve created an account via invite code generated from the forum, and have registered my current IP. I’m also able to browse to safe:// addresses successfully.


#57

I just checked - you havent reached [trust level 1] (https://safenetforum.org/badges/1/basic) yet. I guess that’s the problem. See the OP for info about the restrictions for this testnet.


#58

Not able to log in anymore.


#59

Was working an hour ago but now I get Core error: CoreError::RequestTimeout when logging in.


#60

@whiteoutmashups @Grizmoblust just set myself up with a new account and it worked. I’ll DM you guys a new link. Let me know how it goes.


#61

Are you sure? I got a notification saying I’d reached that level before I signed up. Visiting your link as well as my profile show me as having the basic badge.