MaidSafe Dev Update :safe: 24th May 2016

hmmmm, I’m now wondering what I did to think I was running a vault, I’m on windows 10 and just double clicked the vault exe and that was it, I think that was running a vault, thinking it wasn’t now, everything else was double click though…

cheers
Al

2 Likes

Thank You for the update! Much appreciated!

No, this would be the way moving forward. This is just a proposal at this point and also seems to be legit to take that route.

The data transfer is very much encrypted in the network layers. The data is encrypted when it leaves your machine. We are proposing to drop the encryption that happens locally between the applications and the launcher.
Since the applications and the launcher are running on the same machine, having a session based encryption just for the data transfer between local applications is a mere overhead.

11 Likes

We will take the issues raised in the demo app along with the launcher. My assumption is that the issues #65 and #66 are likely to be related to the 5MB issue raised in the safe_launcher. Will update the issue as soon as it is fixed.Thanks @polpolrene

1 Like

Hi Bluebird,

Sorry for my late reply, I’m on Ubuntu 15.10.

Like @Frontrow_Al I double clicked the vault exe, but I didn’t really get the impression that that was doing the job. I’m sure a lot more people would join these play around rounds if they only had some one do a step by step.

@bluebird thank you for being on the frontier and experimenting with the network like this. :stuck_out_tongue:

For what it’s worth, I tried running a local vault on my Ubuntu machine last week, and it generated a couldn’t run error. I suspect it was because I didn’t set the config file correctly. Anyway, I’ll try that again in TN4, or in the community_run_net. The launcher worked flawlessly in TN2 (Win7) and TN3 (Ubuntu) for me.

Thanks for the reply, but to be clear, the problem also shows up when I try to upload files <5mb. 1 by 1 to the network. Without hitting any limits for accountsize or filesize.

Right click on the vault folder and choose open in terminal. Then type ./safe_vault in the terminal and it should start :slight_smile:

2 Likes

Reminds me somewhat of Freenetproject, they have the users webbrowser as a main gui to the Freenet core daemon running on the local machine and for example exposing a webserver on localhost. But there is still a TLS option to fetch those pages from localhost via the webbrowser but which the user can opt in or out at free will. They have a password option to unlock the webserver, but the TLS layer is still in addition to that.

1 Like

The size of the file increases when it gets stored in the network because of the file getting encrypted and saved as chunks. Though we consider it has 4 Mb file, the actual size in the network can be higher. This is an assumption as I said earlier, will definitely need to check to confirm the same.

2 Likes

Well, to be fair, @Frontrow_AI was on Windows. By saying exe you mean executable or did you emulate the Windows package.

No I didn’t use wine, I’ll try the above

Thanks :stuck_out_tongue:

What about a usecase where the user wants to run the vault permanently on a headless server and connect the launcher to it from a separate machine? In this case, encryption would be good to have, even necessary.

3 Likes

@hillbicks as I understand it they are only talking about the REST/http API so it only affects Apps when they communicate with Launcher, which will only be in the same machine.

4 Likes

./safe_vault in a terminal should work, you probably did get it running in the background though.

Yes, reading the description again it does seem that way, you’re right :wink:

1 Like

Its about the communications between the launcher and the APP that is registered with the launcher.

You can run a vault without any launcher. Actually the last test I only ran a vault, did not even download the launcher.

3 Likes

You dont need a specific vault for a launcher to connect to it. The launcher connects to the network as whole. Not necessarily or not at all to your vault that runs on your own hardware.

1 Like

Thanks bro’s @bluebird @Arcturus @Artiscience @Dirk83 I’m finally on the community network. :stuck_out_tongue:

5 Likes

You´re welcome, and welcome on the community network :wink:

2 Likes