MaidSafe Dev Update :safe: 17th May 2016 - TEST 3 - Update (20th May 13:30 BST) Now Complete

works fine here, deleting and adding.

1 Like

hmmm - laptop with i5 - nothing special - ubuntu 16.04 - 2 nodes

the amd-forgotten-whatsoever-8-core is at 4% max (4 vaults)

2 Likes

We expect a lot of this, vault data will not survive this test, unfortunately. Network should stay up though, that’s this test.

5 Likes

That’s what’s going to be solved by porting stuff from threads to async code (MIO).

1 Like

Still running blocking I/O in crust this week. Hopefully next week this won’t be the case

1 Like

So creating web rings (for example) within this iteration is probably not the best way to contribute.

Thanks for the heads up @Ross

There will be no SAFE Webring during testnet 3

That’s great actually… it means I can have more time to extend and test my remoteStorage web app code for SAFEpress instead :slight_smile:

And @Ross, you didn’t think you would get away with not updating us on ARM did you? Tut, tut! Come on, please tell :slight_smile:

8 Likes

On Windows 10/64 it’s doing great. My CPU isn’t going above 3% so far.

5 Likes

Looks like vaults lost connections for the moment. Just a minute ago.

WARN 11:23:11.471251948 [routing::core core.rs:667] Prepared connection info for PeerId(65ee…) as ec7e…, but already tried as ec7e…

WARN 11:23:58.023084219 [routing::core core.rs:605] Node(e721…) Failed to connect to peer PeerId(65ee…): Error { repr: Custom(Custom { kind: TimedOut, error: StringError("Connect failed. errors: (1 o f 6) Tcp direct connect failed: Zero byte read - EOF reached, grace ful exit. (2 of 6) Tcp hole punching failed: Tcp hole punching time d out without making a successful connection. The following warning s were raised during hole punching: 121 warning(s): (1 of 121) Conn ecting to endpoint 127.0.0.1:35136 failed:

I’m going stop the vaults. And provide the Log.

Edited: Vault Sauce.

No that’s normal, we try many ways to connect to nodes, so think this is OK here. If you lose connections you will see routing table size decreases…

3 Likes

Is there a maximum total file size upload or only a maximum file size upload?
What wil be the maximum upload size of a file when the network is stable?

Yay…a replica of a german meme. Meet me at

http://drogenlied.de.safenet/

EDIT: sound now working :wink:

I will host that page on the real net and make millions of Safecoin muharharharhar

3 Likes

Files get split into chunks of max 1Mb each. The only limit will be how much safecoin you spend. It should be a lot of storage for very little cost if we get it right.

At the moment we have limited clients to 5Mb and vaults to 100Mb IIRC

6 Likes

Loaded really fast on the network!

5 Likes

Only tested TEST 1 a while back and was a bit slow and buggy, but this time the network reacts really fast and stable. No problems here. Wow 1 vault average only taking about 0,4% CPU on a I7 and Windows 8. Thumbs up peeps!!!

6 Likes

I’m storing about 8 MB’s of chunks right now, if you recognize one that’s yours please raise your finger.

9 Likes

Initially creating a new account was slow but I expect that was the vault trying to catch up… terminal for the launcher complaining about finding an IGD gateway, whatever that is.

WARN 18:36:08.606655936 [w_result lib.rs:288] Failed to find an IGD gateway on network interface wlan0 192.168.1.43. igd::search_gateway_from_timeout returned an error: IO error: Resource temporarily unavailable (os error 11)

but then it’s picked up and all working well, thought the demo app is a bit slow to respond to registering names and moving to the manage websites. I’ll try data upload in a bit.

for now I’ve put up a few sites… I guess the challenge from the OP is to see if we can break the network badly enough to lose what’s put up…

http://hello.safenet
http://the.teapot.safenet
http://heaven.safenet
http://yvette.safenet
and
http://a.random.safenet

They all loaded very fast for me. Including Yvette ;-). This on is up as well:

http://polpolrene.safenet

Where can i find those files?

1 Like

http://testing.tester.safenet/

All of your website links loads really fast. Less than 6 seconds or so. Impressive.

Safenet: Almost fast than clearnet, and more resilient! GG WP

1 Like

I’m on windows 10, should work on 7 as well. Go to your little search screen, type:

%appdata%

You’ll see a map called Appdata/roaming. Now I click on Appdata in the address-bar. In this map choose > Local and then > Temp and search for maps called Safe Vault. You’ll have more from the old tests, so check date to see which one is from today. Thanks to @seneca for telling me where this stuff is, I didn’t had a clue ;-).

4 Likes