MaidSafe Dev Update - 14th June 2016 - TEST 4

I stopped my 3 vaults from Stable Droplet Test Network and started 9 vaults on Safenet Test 4. I also added http://mystats.safenet/ site on it.

Comparison of statistics between the 2 networks are interesting:

  • Stable Droplet Test Network has about 50 nodes with an average disk usage of 73 MB

  • Safenet Test 4 has about 2000 nodes which are almost empty (1 MB disk usage and the limit per vault is 500 MB)

1 Like

Interesting and it’s useful data but obviously 50*73MB=3650MB c.f. 2000MB is little different.

Testnet4 appears stable but I don’t know really which bit of it needs pushing to the limit.
I wasn’t aware that limit is 500MB/vault… perhaps that follows from 5MB x 100 events.

If there was a trivial way to automate upload, I’d be tempted to try and break it but manual uploading individual files, is less fun. Perhaps need to look again at the API options … I recall seeing rust and Go flavours of those progressing somewhere that I wonder might lend themselves to testing.

No issues I’ve seen with what exists publicly:
http://explore.yvette.safenet
=>
http://mystats.safenet
http://dcymatrix.safenet
http://upstate.safenet
http://hello.safenet
http://home.ibm.safenet
http://zh.udhr.safenet
http://en.udhr.safenet
http://yvette.safenet
http://se.udhr.safenet
http://gugl.safenet
http://el.udhr.safenet
http://tutorials.c4se.safenet
http://maze.safenet
http://eye.eye.safenet
http://ian.safenet
http://5mb.safenet
http://ru.udhr.safenet
http://fr.udhr.safenet
http://ko.udhr.safenet
http://polpolrene.safenet
http://safeshare.safenet
http://explore.yvette.safenet
http://wof.savage1.safenet
http://bridge.thearkroyal.safenet
http://ar.udhr.safenet
http://quake3v2.perico.safenet
http://web.chunky101.safenet
http://web.dollyparton.safenet
http://elephant.safenet
http://quotes.blindsite.safenet

1 Like

Do you have the script/prog that generates the stats. ONe thing we have tried to figure is a good mechanism for network difficulty type setting. Well more what is network density, I suspect this is close to what you are doing, but I woudl be interested in accuracy. I suspect a few thousand nodes may have error, but the error will become manageable at some stage though. Finding that stage would be a big help.

1 Like

Tried to upload more data to Private Data and failed.

Upload failed
Failed to create file /private/blah.png

Have I used up my 100 PUTs?

ERROR 00:27:30.214451565 [safe_core::ffi mod.rs:302]


FfiError::NfsError -> NfsError::CoreError -> Low account balanceCoreError::MutationFailure::{ reason: LowBalance, data_id: Structured(1d7113…, 15101)}

ERROR 00:27:32.185307353 [safe_core::ffi mod.rs:330]


FfiError::InvalidPath

ERROR 00:27:48.474164851 [safe_core::ffi mod.rs:330]


FfiError::InvalidPath

ERROR 00:28:04.763144928 [safe_core::ffi mod.rs:330]


FfiError::InvalidPath

ERROR 00:28:14.489777085 [safe_core::ffi mod.rs:302]


FfiError::NfsError -> NfsError::CoreError -> Low account balanceCoreError::MutationFailure::{ reason: LowBalance, data_id: Structured(98addd…, 15101)}

ERROR 00:28:20.902552338 [safe_core::ffi mod.rs:330]


FfiError::InvalidPath

ERROR 00:28:37.003022432 [safe_core::ffi mod.rs:330]


FfiError::InvalidPath

ERROR 00:28:52.900634459 [safe_core::ffi mod.rs:330]


FfiError::InvalidPath

Time to make a new account?

Looks like it, your error is lowBalance so you have “spent” your fictitious safecoin :smiley:

5 Likes

Cretz created command line tools: [ANN] SAFE CLI, Go Library, and Integration Tests - Alpha Release

1 Like

Measuring network density around my vaults and averaging the results is exactly what I do. I also found out empirically that subtracting a fraction of standard deviation improved the result. See my post on the subject.

Yes, I think we can do better than that. But I am not specialist on the subject, you and people in your team are.

Finally the guilt of not running a vault consistently has gotten the better of me and I now have one running on a Windows 7 machine. The chunks I found placed in my vault was pretty immediate and of varying sizes.I need to install the vault software on a Raspberry Pi I have had for a while.

Will Test Net 4 be closed or could it be transitioned into being the stable developer network?

Thanks for everybody’s hard work!

1 Like

If you have a spare Pi then you might consider running my ARMv7 build, which needs testing.

1 Like

Awesome! Will do and thanks for the info. I just received an email the $5 Raspberry Pi’s are back in stock and wanted one of those also. :slight_smile:

2 Likes

If I understand correctly Testnet 4 will be wiped at some point fairly soon so I’d keep local backups of all your proposed uploads, public and private.

Someone will correct me if I have this wrong, I’m sure.

2 Likes

+ http://testtest.cryptoholmes.safenet
+ http://oldhold.southside.safenet

5 Likes

Strange… after failing to register half-a-dozen times on a Linux desktop, it worked 2nd time on Linux laptop. Same Distro on both.

I don’t think it was officially announced but this limit was already raised from 100MB to 500MB in SAFE Network - TEST 3.

See commit 716de96:

const DEFAULT_MAX_CAPACITY: u64 = 500 * 1024 * 1024

What is the difference between these two errors?

ERROR 22:27:32.080706681 [safe_core::ffi mod.rs:330] 

 --------------------------------------------------
| FfiError::DnsError -> DnsError::CoreError -> No such dataCoreError::GetFailure::{ reason: NoSuchData, request: Structured(b914cc.., 5)}
 --------------------------------------------------


ERROR 22:27:32.213595727 [safe_core::ffi mod.rs:330] 

 --------------------------------------------------
| FfiError::DnsError -> DnsError::ServiceNotFound
 --------------------------------------------------

The second is more common when requesting a subdomain that doesn’t exist but the first request was of a similar form and I think that the PublicID existed for both, so was expected two lots of the second error not mention of Core.

You will get the second error when you haven’t registered your service for www.
You can remove this error by posting data to /dns.

{ longName: 'hob', serviceName: 'www', serviceHomeDirPath: '/www', isPathShared: true }

This links the url www.hob.safenet to the folder /www on the Safe network.

If you then try to access this service through a browser (e.g www.hob.safenet) it attempts to load www.hob.safenet/index.html which points to /www/index.html. If it fails to load this file then you will get the first error returned.

You can remove this error by posting to /nfs/file:

{ filePath: /www/index.html, isPrivate: false, metadata: null, isVersioned: false, isPathShared: true }

This creates an empty file at /www/index.html. This means the url www.hob.safenet will now return a completely blank page.

You can add data to the file, and hence the webpage, by PUTing to /nfs/file/:filePath/:isPathShared.

This is all handled by the demo app but this is roughly what it’s doing behind the scenes.

1 Like

Can I upload a video streaming?

Sorry, you will need to link to the video.

You can upload images, but not videos.

The vault now does not work with video streaming? Ok…

Sorry I thought you were asking about the forum. My Bad

1 Like