MaidSafe Dev Update 14th June 2016 - TEST 4 - Now Complete

#160

I call this screenshot “Maidsafe 101” :joy:

4 Likes

#161

Apart from caching being disabled for now - this will need to be reimplemented to work with split messages -, another aspect that might impact the performance of the network is message prioritisation: Instead of sending all messages in the order in which they were put into the queue, higher-priority messages are sent first, delaying other messages, and under extreme load, low-priority ones may even be dropped. Unfortunately for the user waiting for a website, the priorities are (and probably have to be), from highest to lowest:

  1. Keeping the network structure intact so that routing is functional in the first place, i. e. when nodes join or leave, make sure the connections are established/replaced as required. (This is very little traffic, as it’s just messages like: “Connect to me!” or: “Node 1337 joined, you might want to connect to it.”)

  2. Relocating the data to keep it replicated, e.g. if a node leaves, create another copy of every data chunk that node has been storing. (This is a lot of traffic, as it’s actual data, but it is only relevant while lots of nodes are joining or leaving. Also, as of this version, these messages are not duplicated anymore: Only one of the remaining holders of the data is sending the actual data.)

  3. Mutating the data: E. g. Put and Post requests should not be dropped after half the group authority has received them, as either all or none of them must process the data mutation.

  4. Getting the data to clients: If that fails, at least there’s no damage to the network, although the user will have to retry and possibly wait until the network is less overtaxed.

We should have included that in the original post. Sorry I missed that one!

Anyway, note that this is just a crude solution for now. There is very much room for improvement, like trying to route around slow nodes, etc.

18 Likes

#162

Would it be good for a TEST to have more testers as we have now? I guess lot of people joined, but if you want to go up to 3000 or so we might set up a thunderclap campaign with lot’s of promotion on social media maybe combining it with a blogpost on the Maidsafe website. Just poke us here and we’ll set it up :thumbsup:.

12 Likes

#163

Happy days my data allowance just went up from 300GB to 1TB. It must be fate :slight_smile:

Comcast in select US areas if anybody else felt throttled you may be in luck.

1 Like

#164

Locking in 1 vault per machine funny business will cause trouble for my door to door free home routers for all of my 200,000 local 1000Mbps(1Gbps) uploaddownload/ neighbors.

Limiting vaults per machine would be no problem for data centers (thought we were trying to limit centralized farming). As I said (years ago) Bandwidth is going to be the equivalent to bitcoin ASIC’s. At least a bandwidth arms race will benefit everyone. SafeCoin should just skip the chase and tie directly to bandwidth only (CPU and hard drive are a moot point) and if possible be able to determine my 200k individual 1Gbps fiber connections are more valuable than 200k instances in a data center.

0 Likes

#165

Don’t think we’re too far off from network size 3000 already :slight_smile: it seems like this network already has at a minimum 1800+ nodes right now(just calculated from droplet nodes), which we haven’t had before. Think the max we’ve seen from previous tests was ~750.

10 Likes

Forum Update: 2600 members, new Price & Trading topic
#166

Should this be possible? It looks to me like safe demo app is working without permissions (I had previously granted them but logged out of launcher and back in again, the app was on the list of permissions but as you can see is now gone). I can upload/download file and create websites etc.

1 Like

#167
---------------------------------------------------------- 
| Node(39b970..) PeerId(66c4..) - Routing Table size: 338 | 
---------------------------------------------------------- 

:astonished:

1 Like

#168

A record :wink: Looks a bit strange though. It is something we are measuring.

2 Likes

#169

Awesome maidsafe team, will run the test4 vault tomorrow,thanks for hard works

0 Likes

#170

Can I assume that when you logged in again the app was on the list and then all of the sudden the list is emptied. But the demo application still conects?

If yes, then it should be a UI issue which we will try to reproduce. The permissions are kept in the memmory and validated behind the scenes though the UI has lost its state for some wierd reason. In case, if the permission is not in the memmory of the launcher then applications wont be able to connect.

But thanks for spotting this one :slight_smile: We will try to reproduce this locally and test. We have tried testing with too many applications listed but never ran into this scenario. Anyways, we will try to reproduce this issue.

Thanks @oceanic_panda

6 Likes

#171

Are they taking the droplets down? I see about 1/3 of my routing table entries dropped in the last half hour.

0 Likes

#172

No but droplets at less than 10% of network earlier anyway.

4 Likes

#173

Something is happening, since it’s now about half of my routing table dropped.

0 Likes

#174

I run 2 Vaults and I have 82 and 97 nodes without any weird moves in the routing table.

0 Likes

#175

Been running it on/off since yesterday, and no real issues so far.

0 Likes

#176

Looking at my chart, I detect a daytime trend: There was a big rise around 0800 UK DST time, then a sharp leap upward at 0900, a plateau all day long, then a sharp downward slope from 1745 DST. so it looks like someone was running many vaults at work.

0 Likes

#177

I haven’t managed to open a .safenet page…
Proxy is set up. Is actually anybody able to open a .safenet page at the moment?
My vault is running nicely though… (Routing table size is 199 btw)

1 Like

#178

Had a vault up all day today (Since the newest version got uploaded late last night after the network went down) and my routing table is now at 99 which is the highest ive seen it all day. Max cpu usage ive seen is 0.5% on surface pro 4/i7

3 Likes

#179

http://hello.safenet is up and small file so should work for you too. Have you setup the proxy?

1 Like