Launch of community network 2

I have launched a new community network with vaults from home. It is based on the code of last week Maidsafe IGD test and has the same limitations: no browsing yet, only one section, no possibility to become an elder and a vault can only store new created chunks.

To try to avoid the same fate, I have deactivated free balance creation. User wanting to add data to the network must ask @Traktion or @neo for a safe key containing 0.000002 coins. Once again, they have kindly accepted to manage the keys.

Only forum level 2 members can apply for a such key. This process is very similar to the invites system used in first community network.

The value seems small but in fact it allows 2000 put operations which means potentially 2GB data upload. In comparison this is twice the put balance allowed in Alpha 2 and first community networks.

When a user is given such a key he can create an account paid by the key and log to this account with following commands:

  • ./safe-authd start
  • ./safe auth create-acc --sk <given key>
  • ./safe auth login --self-auth

Users wanting to read data don’t need to create an account. Same for user wanting to provide a vault.

The vault and the cli are provided in both source code and binary form. Binaries have been generated for the following targets:

  • x86_64-unknown-linux-musl
  • x86_64-pc-windows-gnu
  • x86_64-apple-darwin
  • armv7-unknown-linux-musleabihf

Vault:

The command line to launch a vault is ./safe_vault -h '["N.N.N.N:5483"]' -vv

CLI:

For the CLI to work, content of ~/.config/safe_vault/vault_connection_info.config must be set to "N.N.N.N:5483"

In both cases N.N.N.N must be replaced with any value from the following list:

  • 95.217.220.65
  • 135.181.26.49
  • 95.217.214.96
  • 95.217.214.150
  • 95.217.214.231
  • 95.217.214.249
  • 95.217.215.17

(no preferred IP address is specified to avoid a concentration of requests on a particular vault)

Note: The main modifications of my fork compared to Maidsafe repository:

  • removal of free balance creation (as mentioned above)
  • removal of all forms of auto-update (to avoid exe being overwritten by the wrong one)
  • change of quic-p2p cert (to avoid mixing up vaults and networks)
33 Likes

I promise not to upload 50Mb folders containing 3000+ items. Well not for the first half-hour, anyway…

Seriously, thank you very much for this initiative, I hope it goes well and we can learn a lot while the devs sort out the “official” VfH.

17 Likes

This is cool @tfa.

Is participating in the community network and the Baby Fleming tests mutually exclusive, or could the same machine run your vault/CLI and also participate in BF?

10 Likes

Even if it is possible I think you might be issuing safe network switch commands very frequently

3 Likes

It works!!! well kinda… I had to try various of the supplied IP addresses until this error went away
willie@gagarin:~/projects/maidsafe/VfH-tfa$ ./safe auth create-acc --sk cdb5ba4413aseceret-bits-go-here22923394c2c11
Passphrase:
Password:
Sending account creation request to authd…
[2020-06-15T21:32:47Z ERROR safe] safe-cli error: [Error] AuthdClientError - Failed to establish connection with authd: [Error] ClientError - Failed to establish connection with remote QUIC endpoint: timed out

But when i edited the config file to use 135.181.26.49 I got in…

willie@gagarin:~/projects/maidsafe/VfH-tfa$ ./safe auth create-acc --sk cdb5ba4413a8c93dd3e646efcb2ahemm4444444444476477222923394c2c11
Passphrase: 
Password: 
Sending account creation request to authd...
Account was created successfully!
willie@gagarin:~/projects/maidsafe/VfH-tfa$ ./safe auth login --self-auth
Passphrase: 
Password: 
Sending login action request to authd...
Logged in successfully
Authorising CLI application...
Awaiting for authorising response from authd...
SAFE CLI app was successfully authorised
Credentials were stored in /home/willie/.local/share/safe-cli/credentials

This does not return to the prompt - I had to open a new terminal and continue there…

I had created a new network name before I tried to logon


and then I uploaded the binaries back to themseves :slight_smile:

and


which is nice…

THank you @tfa

15 Likes

Yes, this happens to me too. I just do ctrl-c because everything is done at this point (the CLI is authorized and the credentials are stored in a config file).

3 Likes

Yes, its no biggie, I just mentioned it for completeness, I could see that the work was done.

2 Likes

Nice one @tfa, I’ll fire up a pi or 2 tomorrow :tada:

5 Likes

I tried start a vault but since I wasn’t able to change my router I am still getting the error message regarding IGD.

I haven’t learned how to put data as a client yet from the CLI but that is my next mission.

One issue I have this go around and with the shared section testnet was when I was trying to create an account it just says that is sending a request to authd (I think, it’s not right in front of me at the moment) and it doesn’t advance past that point so I never get a response on whether the account was created or not. Not sure if anyone else experiences this or if anyone has any tips. -n00b to CLI on a Mac.

4 Likes

I will gladly add a vault ! I can only make it from a public IP, though, so it may not be that interesting with regard to testing IGD ( I’m on a capped 4G internet plan at home )

4 Likes

Great to see this! Nice one @tfa :tada:

I might be able to help you out with this @Nigel
Could you try removing this folder:

/Users/<user-name>/Library/Caches/net.MaidSafe.quic-p2p/

It might be picking up older bootstrap contacts from the cache.

9 Likes

I’ll give this a try Lionel, thanks!

3 Likes

I got a key , thank you very much !

I need to figure out how to make the community network live ( or not ) on the same machine as the maidsafe one.
@tfa If I understand good, you created a modified auth , which does not allow balance creation ( thus the key ) .
So I suppose I should first uninstall the maidsafe official cli, auth and vault, then install from the links you provided ?

Is the community vault code different than the maidsafe one ?

4 Likes

Here’s how I did it on linux. Mac will be very similar, if you are on Windows, then you might get a few hints…

Yes - slightly

No need to uninstall - hopefully we will all be updating that code sooner rather than later. I made a sub-dir in my ~/projects/maidsafe folder
willie@gagarin:~/projects/maidsafe$ mkdir VfH-tfa
then I saved and extracted both files from @tfa 's github to that folder

I added a new network - call it anything you like - I chose VfH-tfa Vaults from Home - tfa
safe networks add VfH-tfa ~/.config/safe_vault/vault_connection_info.config

then I edited ~/.config/safe_vault/vault_connection_info.config to contain just one line
“135.181.26.49:5483”

@tfa gives a number of IP addresses you can try. I had no success with the first couple I tried but the one above Works For Me. Whichever IP address you use, (and we should all try NOT to use the same one) must specify port 5483.

then run ./safe networks <-- make sure you are in your new directory and you put “./” in front of the safe command to ensure you are using the local version of safe and safe-authd you just downloaded.
Your output should include

or similar
then
./safe networks switch VfH-tfa
and
./safe-authd restart

create your account …
./safe auth create-acc --sk #pasteyour key here#
enter the passphrase and password of your choice - dont forget them

then login…
./safe auth login --self-auth

Have fun!!

`

7 Likes

Thanks @Southside for your comprehensive procedure.

Yes, safe-vault and safe-api are slightly different and were made incompatible with those from Maidsafe (the main differences are mentioned in the OP).

5 Likes

OK I’m up and running. Not sure my vaults are though, output is stuck on
INFO 2020-06-16T22:02:06.745344719+01:00 [/cargo/git/checkouts/quic-p2p-2ed24583cc4479e8/1f47bb8/src/lib.rs:292] Could not send the IGD response: sending on a disconnected channel - "SendError(..)"

and I can’t find the vaults in any of the usual places. Where should they be on Linux?
Edit: in /tmp/ yes?

5 Likes

Vault data should be in: ~/.local/share/safe_vault/root_dir/

4 Likes

Ah yes - no chunks though. I’ll restart and try again

2 Likes

I got a bunch of chunks

willie@gagarin:~/.local/share/safe_vault/root_dir$ du -h
116K ./chunks/mutable
36M ./chunks/immutable
20K ./chunks/login_packets
12K ./chunks/append_only
36M ./chunks
37M .

Do we know how many users are on the community network - or VfH-tfa as I prefer to call it :slight_smile:

4 Likes

OK chunky. No need to rub it in.

6 Likes