Launch of a community safe network


#81

New node added.

Come on, guys, we need more volunteers. We are close to the first split.


#82

Thank you very much for your 2 nodes.

Here they are (highlighted in green):

To get this image, I just entered your ids (found in your screen shots) in parameters tab:

image

Only 16 nodes for now, we need at least 6 more nodes. Not enough people motivated for providing vaults, let us hope this is because they were on holidays.


#83

A little disappointing that so few people join the network. Those who don’t have a fast enough connection at home also have the option of spending a few dollars renting a VPS.


#84

Hope that more will join soon. I’am waiting on some new hardware and hope to join in upcoming weeks. For anyone that don’t have that much experience with linux, it is not that difficult to give it a try, the steps can be done in desktop mode. It would be great if we had a youtube tutorial.


#85

You don’t need linux. Any desktop or notebook (windows, mac o linux) is fine as long as you have a enough fast connection to pass the resource proof (+/-6Mbps. upload).


#86

Well I’ve tried to join a few times and most times I either fail the resource test or no data is transferred to my vault. Plus I can’t get it working in Linux and I can’t get the browser working as detailed above, so it could be people are trying but not managing to connect.


#87

I need just a little bit more time and to check the ol’ budget but I might take a crack at digital ocean soon.
If I do could you help me set it up @tfa?


#88

well, i am trying, but with little success.
my up speed averages 20mb so that shouldnt be the issue.
ive done the port forwarding on the router
tried with upnp enabled and disabled
tried many times with each setting

I 19-01-05 17:22:56.879228 [safe_vault safe_vault.rs:74]

Running safe_vault v0.17.2

I 19-01-05 17:22:56.910428 [safe_vault::chunk_store mod.rs:122] Created chunk store at C:\Users\new\AppData\Local\Temp\safe_vault_chunk_store.9dVfw8NNUfnz with capacity of 2147483648 bytes.
T 19-01-05 17:22:56.972828 [routing::states::bootstrapping bootstrapping.rs:160] Bootstrapping(7f52c0…) Listener started on port 50366.
I 19-01-05 17:22:57.986828 [routing::states::bootstrapping bootstrapping.rs:287] Bootstrapping(7f52c0…) Failed to bootstrap. Terminating.
D 19-01-05 17:22:57.986828 [routing::state_machine state_machine.rs:418] State::Bootstrapping(7f52c0…) Terminating state machine
possbly my antivirus, which im removing now as this is a spare machine.

Removed antivirus and still no joy. Not sure whats up…

IPv4 firewall

Firewall protection

Enable

Block fragmented IP packets

Enable

Port scan detection

Enable

IP flood detection

Enable

possibly something to do with this, router firewall?
any help appeciated, im reaally not so techy, almost bricked an S2 while trying to find it many moons ago

wasnt the router firewall as still wont connect with all turned of. for now i give up, ill try again if i get some pointers


#89

This isn’t the value I have defined. Are you sure you are using config files from my repo “vaults” directory?

Yes, it is more likely Windows firewall because you have done the port forwarding on the router. You have to allow safe_vault.exe for incoming connections on 5483/tcp or more simply any ports. But I am not sure of the commands because I don’t use Windows for running my vaults. I remember a long time ago that Windows just asked me to allow this program.


#90

i didnt change any config files, i used the ones alredy present in jpl’s guide for

i allowed a windows firewall exception on pvt networks, which im on at home

ive had to much gin n juice to play further tonight, but ill have a look at swapping out the config files in the morn

thanks for the input


#91

Ok, that explains everything.

To create a vault, you must follow one of the procedures linked from the OP, for example use binaries from Maidsafe

I have mentioned @JPL very informative topic in a subsequent post for general advices and troubleshooting, like how to setup port forwarding on a router. But you shouldn’t use files downloaded from there, they were adapted to old Maidsafe network but not to current community network.

Sorry for the confusion.


#92

ok, ill try again tomorrow, thanks

and no need to apologise for confusion, it says more about my reading comprehensoin than your instructions


#93

I’ve just added a Raspberry Pi 3 B+ (+external USB hdisk with separate power supply) Vault using @bart’s ARM musl safe_vault version.
For other Belgians: Raspberry Starter Kit is on ‘sale’ here atm.

My Node has id d28087. Network size is now 18.


#94

well, ive given it another shot, still no joy
i downloaded the maidsafe binaries,
deleted the contents of the 3 files and replaced with the configs you said to use
did port forwarding for tcp 5483
allowed an exception in win for vaults on pvt networks

I 19-01-06 11:03:24.385310 [safe_vault safe_vault.rs:74]

Running safe_vault v0.17.2

I 19-01-06 11:03:26.943714 [safe_vault::chunk_store mod.rs:122] Created chunk store at C:\Users\new\AppData\Local\Temp\safe_vault_chunk_store.wqiucAaFgJ0p with capacity of 34359738368 bytes.
T 19-01-06 11:03:27.037315 [routing::states::bootstrapping bootstrapping.rs:160] Bootstrapping(c77023…) Listener started on port 5483.
E 19-01-06 11:03:31.030922 [crust::main::bootstrap mod.rs:208] Failed to Bootstrap: (FailedExternalReachability) Bootstrappee node could not establish connection to us.
I 19-01-06 11:03:31.030922 [routing::states::bootstrapping bootstrapping.rs:287] Bootstrapping(c77023…) Failed to bootstrap. Terminating.
D 19-01-06 11:03:31.030922 [routing::state_machine state_machine.rs:418] State::Bootstrapping(c77023…) Terminating state machine

no doubt something im doing wrong, but i dont know what


#95

I get this on Linux but not on Windows - but I see you’re on Windows. Someone suggested connecting to the router via Ethernet instead of WiFi. Not feasible for me but it might be worth a shot.


#96

You are setting your local ip?
I had issues connecting until that was corrected.
My router was masking my computers ip so by bypassing it and going directly to the modem it solved my issue.

Probably better ways to fix this but it was the only way I could figure out.


#97

I checked the ipconfig so definately the right ip.
And i am plugged via ethernet straight into the modem.


#98

Ill have to dig one of my pis out and try that, but im more useless with linux than windows


#99

Got 1 running now on a Debian server by using the Maidsafe binaries. No troubles here. Only had to forward the 5483 port on the 2 routers I’m sitting behind.

For the people who want to run this with logging enabled in a separte background process (So your safe_vault process won’t get killed by closing the terminal)

#enable logging
~/app$ cp ../safe_vault-v0.17.2-linux-x64/log.toml .

#launch vault in the background
~/app$ setsid ./safe_vault > output.log &
using nohup command might work as well


#100

Seem a modem problem. I’m on windows without problems.

Just in case, I have both TCP and UDP ports open.