Launch of a community safe network


#41

Hmm … no connection for me in Win10 using the Maidsafe vault binary, Ports 5483 and 5484 TCP port-forwarded in my router, VPN switched off, safe_vault allowed through Windows Firewall but the console is hanging with just a flashing cursor. Have I missed a step?


#42

Does this mean we will be able to farm on a pi?


#43

Thanks, bart. I will look into it and see if I can figure it out, Raspbian seems to be built out of Debian, I will give it some trial and error. :slight_smile:


#44

In the future, I guess so :wink: (of course farming is not implemented yet)

@tobbetj I made my binary available here, if you want to try it (along with all tfa’s config files): https://home.ebvalaim.pl/safe_vault-linux-arm.zip


#45

It might be working, but just not outputting any logs (which is the default). You can try setting RUST_LOG=info like @tfa suggested in a post above, or copy the log.toml file from a MaidSafe release.


#46

Yes thanks it’s working now. Not sure if copying the toml file over did the trick but I tried again and it’s chugging away merrily.


#47

I think it’s just you are seeing the logs now.


#48

I could see progress in the console. I haven’t managed to join the network yet though :frowning: Towards the end of the 400 s resource test it mentioned a number of nodes being dropped from the routing table then restarted and then quit.

Summary
[routing::states::node node.rs:3944] Node(58ba51..()) Received LostPeer - c74965..
I 18-12-31 14:58:45.656129 [routing::states::node node.rs:3738] Node(58ba51..()) Dropped c74965.. from the routing table.
T 18-12-31 14:58:45.656129 [routing::states::node node.rs:3240] Node(58ba51..()) Scheduling a SectionUpdate for 30 seconds from now.
D 18-12-31 14:58:47.110948 [crust::main::active_connection active_connection.rs:140] PublicId(name: 58ba51..) - Failed to read from socket: ZeroByteRead
D 18-12-31 14:58:47.110948 [routing::states::node node.rs:3944] Node(58ba51..()) Received LostPeer - daa89a..
I 18-12-31 14:58:47.110948 [routing::states::node node.rs:3738] Node(58ba51..()) Dropped daa89a.. from the routing table.
T 18-12-31 14:58:47.110948 [routing::states::node node.rs:3240] Node(58ba51..()) Scheduling a SectionUpdate for 30 seconds from now.
D 18-12-31 14:58:53.194123 [crust::main::active_connection active_connection.rs:140] PublicId(name: 58ba51..) - Failed to read from socket: ZeroByteRead
D 18-12-31 14:58:53.194123 [routing::states::node node.rs:3944] Node(58ba51..()) Received LostPeer - eee3ba..
I 18-12-31 14:58:53.195109 [routing::states::node node.rs:3738] Node(58ba51..()) Dropped eee3ba.. from the routing table.
T 18-12-31 14:58:53.195109 [routing::states::node node.rs:3240] Node(58ba51..()) Scheduling a SectionUpdate for 30 seconds from now.
D 18-12-31 14:58:55.768383 [crust::main::active_connection active_connection.rs:140] PublicId(name: 58ba51..) - Failed to read from socket: ZeroByteRead
D 18-12-31 14:58:55.768383 [routing::states::node node.rs:3944] Node(58ba51..()) Received LostPeer - 77aab0..
I 18-12-31 14:58:55.769138 [routing::states::node node.rs:3738] Node(58ba51..()) Dropped 77aab0.. from the routing table.
T 18-12-31 14:58:55.769138 [routing::states::node node.rs:3240] Node(58ba51..()) Scheduling a SectionUpdate for 30 seconds from now.
D 18-12-31 14:59:02.132511 [crust::main::active_connection active_connection.rs:140] PublicId(name: 58ba51..) - Failed to read from socket: ZeroByteRead
D 18-12-31 14:59:02.132511 [routing::states::node node.rs:3944] Node(58ba51..()) Received LostPeer - 09d262..
I 18-12-31 14:59:02.133216 [routing::states::node node.rs:3738] Node(58ba51..()) Dropped 09d262.. from the routing table.
T 18-12-31 14:59:02.133216 [routing::states::node node.rs:3240] Node(58ba51..()) Scheduling a SectionUpdate for 30 seconds from now.
D 18-12-31 14:59:02.133216 [routing::states::node node.rs:3761] Node(58ba51..()) Lost all routing connections.
D 18-12-31 14:59:02.133216 [routing::state_machine state_machine.rs:418] State::Node(58ba51..()) Terminating state machine
W 18-12-31 14:59:02.133216 [safe_vault::vault vault.rs:125] Restarting Vault
I 18-12-31 14:59:03.447343 [safe_vault::chunk_store mod.rs:122] Created chunk store at C:\Users\John\AppData\Local\Temp\safe_vault_chunk_store.EF1MeG7m1Pd1 with capacity of 34359738368 bytes.
T 18-12-31 14:59:06.456562 [routing::states::bootstrapping bootstrapping.rs:160] Bootstrapping(1d0f54..) Listener started on port 5483.
D 18-12-31 14:59:08.636214 [routing::states::bootstrapping bootstrapping.rs:266] Bootstrapping(1d0f54..) Received BootstrapConnect from 6770ad...
D 18-12-31 14:59:08.636214 [routing::states::bootstrapping bootstrapping.rs:332] Bootstrapping(1d0f54..) Sending BootstrapRequest to 6770ad...
I 18-12-31 14:59:08.670372 [routing::states::joining_node joining_node.rs:310] JoiningNode(1d0f54..()) Requesting a relocated name from the network. This can take a while.
D 18-12-31 14:59:08.670372 [routing::states::joining_node joining_node.rs:99] JoiningNode(1d0f54..()) State changed to joining node.
T 18-12-31 14:59:12.465207 [routing::states::bootstrapping bootstrapping.rs:160] Bootstrapping(572d2b..) Listener started on port 5483.
E 18-12-31 14:59:16.533278 [crust::main::bootstrap mod.rs:208] Failed to Bootstrap: (FailedExternalReachability) Bootstrappee node could not establish connection to us.
I 18-12-31 14:59:16.533278 [routing::states::bootstrapping bootstrapping.rs:287] Bootstrapping(572d2b..) Failed to bootstrap. Terminating.
D 18-12-31 14:59:16.533278 [routing::state_machine state_machine.rs:418] State::Bootstrapping(572d2b..) Terminating state machine

#49

This means the vault couldn’t complete the resource proof challenges on time.

It could be either the CPU speed and/or upload bandwidth that are not enough. When the test fails then it retries again (see Restarting Vault message).

Normally there are messages that indicates the percentage completed every 30s or so.


#50

Yeah, it got to about 58%. Strange, I have a good connection, enough disk space and a Core i7 CPU so it should be OK. I’ll try another machine.


#51

I have one node running now… :clap:


#52

Congratulations @JPL, you did it!

For now, there are 5 nodes from the community (@DavidMc0, @bart, @Savage, @JPL and one anonymous). Many thanks to them.


#53

A very fishy video safe://fishy.savage


#54

I can run a vault on Windows but on all three Linux devices I’ve tried there have been problems bootstrapping (“bootstrappee node could not establish connection to us”). I’m using the same router as with Windows. Has anyone else had this problem?


#55

I did, I had that error when I downloaded binaries from Maidsafe and copy/pasted configs manually.
When I followed these instructions it worked.

EDIT: this solved this error, error: FileHandler(JsonParser(ErrorImpl { code: KeyMustBeAString, line: 2, column: 1 }))

Download zip file

wget https://github.com/maidsafe/safe_vault/releases/download/0.17.2/safe_vault-v0.17.2-linux-x64.zip

Unzip file

unzip safe_vault-v0.17.2-linux-x64.zip

Get configuration files

git clone https://github.com/Thierry61/tfa_safenetwork.git

Configure vault

mkdir app
cd app
cp …/safe_vault-v0.17.2-linux-x64/safe_vault .
cp …/tfa_safenetwork/vaults/*.config .

Launch vault

RUST_LOG=info ./safe_vault


#56

Nope - still not bootstrapping for me. Maybe a firewall problem.


#57

@JPL Correction, in my case I had to bypass my wireless router and go directly to the modem.


#58

Firstly, I have left this default value in vault config file: "allow_multiple_lan_nodes": false. It means that running more than one vault on a single LAN or machine is disallowed. This value should be set to true only for a local test network.

This is a first reason why an attempt to run a vault on a Linux device fails if you already run one on Windows.

Secondly, if you tried to run a vault on Linux before running the one on Windows then the problem is probably about port 5483/tcp. Two prerequisites must be fulfilled for vault at home:

  • you must configure the firewall to allow incoming connections on port 5483 for TCP protocol. If you are using UFW the commands are:
# Default rules
ufw default deny incoming
ufw default allow outgoing
# Ssh
ufw allow 22/tcp
# Safe vault
ufw allow 5483/tcp
# Turn it on
ufw enable
  • you must configure the ISP box to forward port 5483/TCP to the local IP address of the machine that runs the vault. If it was configured to point to your Windows PC, then you must change it to point to one of your Linux device. This is another reason why you cannot run 2 vaults on the same LAN.

#59

Is this a good idea? Seems like it is more appropriate for a single computer or local lan to run many vaults in order to maximize available resources.


#60

This flag prevents people from creating many vaults on the same machine (sharing the same CPU) or same LAN (sharing the same bandwidth).

By launching the vaults one by one, each vault would pass individually the resource proof challenges, but this wouldn’t reflect their real capabilities.

This is a solution found by Maidsafe to mitigate this problem.