Launch of a community safe network

Is there some potential for denial of service with the proof of work (ie existing vaults might be able to deny new vaults)? Existing vaults can choose to (maliciously) claim the new vault failed the test. This is in their interest since it would be a way to exclude competitors.

I know this is maybe not the best topic for it but since POW-to-join is being discussed in pretty good detail I figured I’d put the idea here.

1 Like

I think this needs exploring. Is it really in their interests?

  • Nodes are relocated at times so their efforts may be for naught once relocated.
  • The node joining is generally not going to be located in the section the test is done against so no improvement in earning ability
  • Preventing the network to grow may actually hurt the network as a whole and reduce earning ability for that node and all others.
    • especially as nodes leave the network these malicious nodes may not recognise that since its happening in other sections. If sections fail because of this activity then the malicious nodes cannot earn either.

So really it would seem that this is a question to be considered when trying to answer the other.

My initial thought is that

  • if its an attempt to improve their earning ability then it will be minimal and potentially reduce earning as the network slowly dies.
  • If its an attempt to improve their chances to become an elder (for future maliciousness) then it may work and may cause the network to slowly die too.
  • If it is to slowly destroy the network then there is a fair risk it will not too.
1 Like

How well does the smallest cloud VM (2.49 euro) perform with its 20TB bandwidth allowance. Is it sufficient

Wow that’s great @tfa that’s a cool way too, that I hadn’t considered :+1: was just looking for a way for the casual readers to be able to help if they wanted, but this is good enough for now. Hopefully most people can figure out how to create a droplet etc. Still limits the amount of people who can support this community network, but not too bad of a solution for now.

1 Like

Bandwidth allowance is largely enough. The problem is this one has only 20 GB disk and the vaults are configured for 32 GiB (specified in the OP and defined in safe_vault.vault.crust file).

The code doesn’t check the capacity of the drive containing the chunk store, so you can start the vault but it is not safe for the network. For now it’s ok because the needed space is largely below 20 GB. But if the network ever reaches this level it could be a problem (wrong group computation and cascading vault failures).


Ah yes. I didn’t look too far did I. Oh well I’ll leave them running till the space is needed.

Hello ,

on the alpha2 network, the new version 0.13.0 of the browser fixed the “app.webfetch is not a function” issue that I had when trying to browse any safe site.

But when I try on the community network, for instance safe://traktion or safe://fishy.savage , the issue is still here.

I am not sure I understand how it relates to xdg-open, as I am not following the links from here, but just pasting the links directly inside the browser.

xdg is required (on linux) for the browser ‘application’ (that does the network connecting) to receive a response from the authenticator saying that it can access the network. (Yes, even for an unauthed connection, you just dont need to approve it, but it does need to grab bootstrap info).

Still, odd it’s working for one and not the other. You’ve updated the network config files to connect I assume? (And restarted the browser?)

Something we’re trying to get a handle on right now is that in some (difficult to repro) conditions, connections appear to drop (which could result in the error you’re seeing). But it’s not happening in any consistent fashion :expressionless:
I’m not sure that’s necessarily what’s happening here. But just in case: if you are able to reconnect after restarting the browser, eg, could you just update us here. That’d be excellent to know. :bowing_man:

1 Like

Thank you for looking into this, and for claryfying where xdg-open is triggered
I did replace the safe-browser.crust.config file by the one provided by @tfa , and restarted the browser.
Restarting twice doesn’t help

I am not sure if it can be relevant, but I am using xfce as a window manager. At some point in the past I had noticied that lxde was triggering issues for authentication, and switching to xfce had fixed it.

1 Like

I tested new SAFE Browser on Windows and it works for the community network.

I had to to authorized SAFE Browser for firewall because I extracted it in a new directory. Windows asked me and I just answered “Yes”. I don’t know the equivalent procedure on Linux.


not sure there is actually an equivalent. I can say for sure that my firewall rules do not prevent the browser from reaching the outside, which it does nicely for the alpha2 network :thinking:

Aye, if you’re able to / were able to, I don’t think it’s firewall related.

If I learn anything more, I’ll ping back in here, @nice :+1:


Node(f4e4d4..()) Resource proof challenges completed. This node has been approved to join the network!

I just added a little vault to the network :slight_smile: It seems the size is 14 now


Please note that I have made some small improvements to the web app:

  • Added a “Contacts” tab that shows the health of contact nodes in provided crust config file.
    It uses the recently delivered safe_auth CLI to test connection through each contact nodes. This one allowed me to uncover a strange network behavior mentionned in another topic: connect time is either 4s or 24s but no other values has ever occured (and this is still true since 5 days ago).

  • Replaced an unimplemented function on Edge browser. I use Polymer framework with Vaadin components, so in theory the web app is portable among the main browsers, but I was using javascript flatMap function which is not supported by Edge.

  • Reordered tasks in “Docker” tab so that they are grouped by host. This was needed because WS host has now a second task to manage the new tab (check-contacts).


What good is running a community safe network if it can only be visited by trust level 2 people?

I want it down to 0 so anyone can visit my site
and a limited daily dose of data so I can regularly update my site.

Anyone can visit - you don’t have to be logged in to browse, only to create an account and store data.


Oh that’s nice.
I just noticed that I’m level 2 as well.

I’ll check it out this weekend then.

@tfa, so are you allowing level 1 users? @folattw was going off the opening post and it says level 2

You only needed to ask for an invite as we have the freedom to give an invite to trusted members who may not be level 2. But I was under the impression it was available to level 1 now anyhow.

I would think we want people to be a part of the community at least and that means level 1 as a minimum which does not take all that long to be.

As said by @happybeing, anyone can visit. One needs to be level 2 only to put data in the network.

The plan was to lower this restriction to level 1 members when there are more nodes to support the storage of much more data. But this didn’t happen.


Another one who tried to join my swarm without success: linuxkit-025000000001 (this is his node hostname).

The problem was that /var/log/safe_vault.log was missing. If anyone recognizes his hostname, please try to join again after issuing this command:

touch /var/log/safe_vault.log