Issue with SAFE Launcher on Ubuntu MATE 16.04


Ok i am back. Here’s the code. safe-launcher didn’t do anything:


DEBUG 19:47:40.466 - Starting FFI worker client
DEBUG 19:47:40.519 - Sending message to FFI - c73ad2d1-227d-4361-8f86-ada45d1782d8 - get-log-path -
DEBUG 19:47:40.654 - Application starting
TRACE 23:47:41.641105788 [safe_core::ffi] FFI Dropping vector.
DEBUG 19:47:41.937 - Sending FFI initialisation request
DEBUG 19:47:41.944 - Sending message to FFI - 7ab51557-c680-4961-a4fc-da5121924098 - connect -
DEBUG 19:47:41.945 - FFI response code 0 for id - logFilePath
TRACE 23:47:41.947518788 [safe_core::ffi] FFI create unregistered client.
TRACE 23:47:41.947618841 [safe_core::core::client] Creating unregistered client.
TRACE 23:47:42.015042069 [safe_core::core::client] Waiting to get connected to the Network…
DEBUG 19:47:42.171 - FFI/mod/auth.js - Create Unregistered Client Handle
Illegal instruction (core dumped)
jon@piserver-deepspelunker:~$ DEBUG 23:47:45.899410959 [routing::core] Disconnected(5a6eb1…) Received BootstrapConnect from PeerId(ac6d…).
DEBUG 23:47:45.899493792 [routing::core] Disconnected(5a6eb1…) - Sending ClientIdentify to PeerId(ac6d…).
DEBUG 23:47:47.547510182 [routing::core] Client(5a6eb1…) - State changed to client, quorum size: 5.
TRACE 23:47:47.547636152 [safe_core::core::client::message_queue] EventReceiverThread received: Event::Connected
TRACE 23:47:47.547781787 [safe_core::core::client] Connected to the Network.
throw er; // Unhandled ‘error’ event

Error: channel closed
at (internal/child_process.js:509:16)
at Object.sendLog (/opt/maidsafe/safe_launcher/resources/app.asar/api/ffi/mod/util.js:96:11)
at registerObserver (/opt/maidsafe/safe_launcher/resources/app.asar/api/ffi/mod/auth.js:14:8)
at /opt/maidsafe/safe_launcher/resources/app.asar/api/ffi/mod/auth.js:48:5
at /opt/maidsafe/safe_launcher/resources/app.asar/node_modules/ffi/lib/_foreign_function.js:115:9


What version / download link, of SAFE Launcher is that? I thought the name was changed to safe-launcher a while back.

Is the above output complete or just the last few lines? If truncated, the startup might be helpful too, but I’m not your man here so…

@frabrunelle can you make sense of this debug output, seems like a process has excited early on there.


I got it off of the SAFE Github. If someone has a better link to use then I would be all for it. That was the only error readout I got


The current builds are updated regularly, so it’s best to go via the latest developer update and follow the download links from there:

I’m not sure this explains your problem, but the first step is to make sure you are using the latest software, then we can take it from there.


I imagine you are using SAFE Launcher v0.8.0 - Alpha 1.

You can try the latest test network as @happybeing suggested. But the Alpha 1 network should also be working. What hardware are you using?


Awesome! I am glad I joined this forum. Thanks @happybeing! I will give that a shot. Will this update overwrite the one that I already downloaded?


It’s an HP desktop. The specifics of the hardware I can get for you when I get home. At work currently


You’re welcome. And yes, just install the latest and give it a try. Keep at it and once you get this working you’ll be browsing SAFE websites and able to try out these incredible web apps running on the next internet! :slight_smile:

You’ll need SAFE Beaker Browser as well as Launcher for that, then try safe://diy.yvette and other “safe:” urls posted on the forum.


Playing around with it on Windows while I figure the Linux stuff out. I put up a website and if you’d like to check it out and give me feedback that’d be great



I did get the safe launcher working on Linux. The safe demo app starts up and then disappears. I am using the version of safe demo app for Linux below:

safe_demo_app-v0.6.0-linux-x64.tar.gz is the package i downloaded


Are you using SAFE Launcher v0.8.0? Are you logged in to SAFE Launcher?


I am using version 0.9.0 and I am logged in to the launcher when I run the demo app, yes


you mean 0.8.0?

but yeah I’m not really sure what the issue is. On Ubuntu 16.04 it works fine for me. But I’ve never tried Ubuntu MATE. Maybe you could try using the binaries from TEST 11? I’m curious to see if you would get a similar issue when trying to run SAFE Demo App.

also, instead of using SAFE Launcher v0.9.2 (which should work fine), I would recommend using SAFE Launcher v0.9.3, as explained here:


I’m sorry I meant SAFE Launcher v0.9.3. I missed some things in this thread. I’ll go back over it:


make sure to use SAFE Demo App v0.6.1 :slight_smile:

you mentioned v0.6.0 in your post above


Thanks all for the help :slight_smile:


hello folks! So I’ve tried the following combinations:

launcher 0.9.3 - demo 0.6.1
launcher 0.9.3 - demo 0.6.0
launcher 0.9.2 - demo 0.6.0
launcher 0.9.2 - demo 0.6.1

Ran in terminal and keep getting this error - ‘Illegal instruction (core dumped)’

uffff… slow going but at least the launcher works no matter which version. The demo just keeps crashing


I just installed Ubuntu MATE 16.04.1 LTS in a VM and everything seems to work fine :slight_smile:

For example, SAFE Launcher v0.9.3 and SAFE Demo App v0.6.1 work fine. The latest versions (SAFE Launcher v0.10.0 and SAFE Demo App v0.6.2) also work fine.

So I’m not sure why it wouldn’t work on your machine. Can you give more details on the hardware you’re using maybe? (e.g. CPU, RAM, etc.)


2 posts were split to a new topic: SAFE Demo App not working on Windows