Introducing SAFE Wallet app


#162

Is it currently working for anyone? I just get a blue screen:

Blue


#163

Yes it’s working for me.


#164

Thanks a lot folks for all the feedback, no only here but also from the SAFE Faucet!
Also thanks Mark (@happybeing), @bittog9, @digipl and @JPL for reporting and troubleshooting the issues, this is extremely useful info. What I get from your problems @bittog9 is that I’ll need to start focusing on working now on the error handling mechanisms to be able to show the user why a transaction is failing or why it cannot finish, etc., I’ll need to figure out how to handle transactions that failed after some coins were already transferred, etc.

@polpolrene, can you take a look at the dev tools console (from the browser’s menu View -> Toggle Dev Tools) ? You seem to be having issues with loading the app/site, are you able to load any other safesite? You should see the landing page where @anita is awaiting for authorisation.


#165

Just a minor correction, the safe_app_plugin uses a single conn for all safesites/tabs rather than one per safesite/tab.

Edit: Now I realise you must have been probably talking about the conn made by each of the safesite, in that case they are independent of the safe_app_plugin’s conn


#166

working here too - AND SO FAST!!! this is exactly the wow-effect i was missing when using bitcoin the first time

thank you So Much @bochaco !!! you are showing the world here the coming awesomeness of safecoin :sunglasses::heart_eyes:


#167

Here’s a screenshot:

Other sites are working.

log:

Uncaught TypeError: Cannot read property 'page' of undefined
    at t.value (main.0d06cf88.js:20)
    at performInitialMount (main.0d06cf88.js:17)
    at p.mountComponent (main.0d06cf88.js:17)
    at Object.mountComponent (main.0d06cf88.js:3)
    at performInitialMount (main.0d06cf88.js:17)
    at p.mountComponent (main.0d06cf88.js:17)
    at Object.mountComponent (main.0d06cf88.js:3)
    at performInitialMount (main.0d06cf88.js:17)
    at p.mountComponent (main.0d06cf88.js:17)
    at Object.mountComponent (main.0d06cf88.js:3)
DevTools failed to parse SourceMap: safe://safewallet.wow/webview-preload.build.js.map

#168

Thanks @polpolrene. I suspect the issue is with the locale, I try to use the locale lang for the landing page, and I presume yours is not in the list of supported ones so it’s not defaulting to English. I think that’s a bug and I will try to fix it in next couple of days. In the meantime, perhaps you could try by changing your locale lang? I’m not 100% sure though, but if you try that out please let me know.

Edit: I just uploaded a patch which I hope should solve the issue.


#169

I can’t see history


#170

30

Have you turned on this feature?

Click on the pencil to edit the wallet settings.


#171

Thanks! I didn’t see that switch because is too white. XD


#172

Hi Bochaco, anita and vivavisual!
Thank you for coding the most interesting use-case I seen so far on the Safe network.

After changing language preference in the control panel from Swedish to English (United States) I can now see the QR codes for the addresses, which were not visible before.

I took some time for me to figure out should add the Thankscoin wallet to play with the faucet (maybe put on the top of the add list instead of last), but now I just sent 1 coin to hereismypublickey1 :smile:

my adress is: thanksrepublic


#173

is this your public key or your wallet id?


#174

General feedback for @bochaco

I tried to send @Jordglob 1 coin but think i got the address wrong, missed of the t from thanksrepublic. The transaction stopped at 66% then froze. I had to quite safe wallet and load it again. I tried to send 1 coin again to the correct address thanksrepublic but now the wallet app stops on 0%.

After revoking access and reloading I then tried to send a coin to one of my other wallets which I know received coins yesterday but that also failed. It now seems the wallet is now broken and cant send to any address.

Stupid question but should we be sending to wallet id’s or public keys?

@Jordglob is thanksrepublic your public key?


#175

Nice work! Works like a charm now.


#176

I continue to receive transactions without problems. For now I have received 7 ThanksCoin, two in the last minutes.


#177

Feel free to share by using: Pubkey as my public key :grinning:


#178

Done. + 20 Char…


#179

Hi

I took the address from this screen shot. So far I have only received the 6 coins from the faucet.


#180

Thanks for making this app.
When I add a Maidsafe wallet, the modal remains blank tho


#181

I made the same mistake. It’s because Safecoin is not live yet. You need to use the ThanksCoin wallet (it’s not a real coin, just for demo purposes btw).