Introducing SAFE Wallet app


#182

Okay thanks @JPL Makes sense :slight_smile:


#183

Send some coins/ get some coins

@jpl hereismypublickey1
@Yerontour Yer
@Jordglob thanksrepublic
@polpolrene PubKey


#184

@bochaco thanks for your hard work & good to see the SAFE Wallet app online again.

@anita & @vivavisual welcome to the forum super ants, great to see an SAFE Network team for the first time.

Can somebody please send me some thankscoin? @ thankyouscoin

Have fun and happy testing :stuck_out_tongue:


#185

I have tried to send 2.5 THXC and the progress bar stopped at 75%…

EDIT.: While the previous is stucked at 75%, I tried to send another two 2 THXC transaction and both stucked again, on 0%…


#186

Hi @lubinew, I think sending non integer amounts could cause issues and it probably leaves the wallet in an invalid state. This type of validations were not implemented yet. You can try creating a new wallet and avoid sending non integers amounts.


#187

This is what has been happening with me. But I have always sent whole coins…


#188

Can you please share any errors you see in the dev tools console (from the browser’s top menu, View -> Toggle Dev Tools)?


#189

Hi @bochaco, every second I get this message:

Uncaught (in promise) Error: The coin already existed in my wallet, so discard TX
at AltCoin.js:116
at


#190

Thanks @Yerontour, that helps, it is then related to a failed TX which leaves the wallet in a wrong state, I still need to work on reporting errors and detailing in which state it is left, but also on recovering from such states. I will try to fix that soon as it seems it’s affecting a few of you.
Creating a new wallet should be fine though for the time being


#191

Yes, here the issue with a coin from ‘Pubkey’ to ‘Yer’:
Coin data: Object {owner: “Yer”, prev_owner: “Pubkey”}
AltCoin.js:135 TX notification received. TX id: 58252e73f5e2350095cd552ddae122a2
AltCoin.js:106 Checking coind ID: 20393ef7d2930017e4afb9d211213294665f689c4c67d08c23b0fac5fa150159
storage.js:439 Reading coin data… Yer 20393ef7d2930017e4afb9d211213294665f689c4c67d08c23b0fac5fa150159
AltCoin.js:135 TX notification received. TX id: dd0727a05c38b7db1f7557e1ccf3715e
AltCoin.js:106 Checking coind ID: 3062caa622794f11140a5db98aa455d3e73e74a4a710f20774133d82540c1ad0
storage.js:439 Reading coin data… Yer 3062caa622794f11140a5db98aa455d3e73e74a4a710f20774133d82540c1ad0
storage.js:431 Coin data: Object {owner: “Yer”, prev_owner: “Pubkey”}

When sending coins from a new wallet to these addresses it also creates an error:
/Applications/SAFE Browser.app/Contents/Resources/app/node_modules/pauls-electron-rpc/lib/import-ap…:228 Uncaught (in promise) Error: Core error: Routing client error -> Requested data not found
at module.exports (/Applications/SAFE Browser.app/Contents/Resources/app/node_modules/@maidsafe/safe-node-app/src/native/_error.js:19:10)
at /Applications/SAFE Browser.app/Contents/Resources/app/node_modules/@maidsafe/safe-node-app/src/native/_base.js:121:57
at /Applications/SAFE Browser.app/Contents/Resources/app/node_modules/ffi/lib/callback.js:66:25

Love to send my first coins on Safenetwork and will investigate to put coin functionality in my own app… :slight_smile:


#192

Thanks!

I am planning to publish the faucet code in the next few weeks with an explanation of how the coins and wallet work, so if you like it we can work together to make them compatible.


#193

Cool, let me know. I’m working on a car sharing app and want to use multiple currencies.


#194

Hello I cannot find the ‘get free thankscoins’ button?


#195

Hi @TheSAMYK1981 , you should load and authorise the faucet site at safe://safefaucet.wow


#196

I have done this and created 2 thankscoin wallets but in the process could not see anywhere to request the free coins to test the transfers


#197

My pub key is KDAWG123 anyone feels like sending me some coins!


#198

I think you are confusing the two apps, one app is the SAFE Wallet where you created your wallet/s: safe://safewallet.wow, and a separate one is the faucet which is at a different URL: safe://safefaucet.wow

I just sent you some coins.


#199

Ah ha yes sorry my mistake! Thanks I got the 6 coins :smile:


#200

Tried sending 3 coins to my second wallet and the tx got stuck at 80%. see attached console log


#201

I was taking a look at the code and was wondering what pk means it seems to come up a lot.
Is it previous owner?