Installation script bombs out

Hi - new user here, just tried out the install script and got this error:

./comnet.sh: 65: [[: not found.

Also you have a typo at line 46 - should read ‘network settings’

Thanks.

2 Likes

Hi - can you explain what you’re trying to do exactly? Which script are you using?

exactly which script are you using please?

If it is from https://github.com/safenetwork-community/comnet-install don’t run it as root, run as a normal user and type in the root password when asked

Tried both ways - same error.

BTW I’m on Debian 11/Bullseye - but looking at the script it shouldn’t make any difference unless I were on a Debian system on a non-sudo account.

1 Like

I’m not sure exactly, but that kind of error may mean you’re trying to run a bash script through sh, which is an older shell that won’t completely understand Bash syntax like the double braces.

2 Likes

ah yes @neik mentioned a similar error in a PM to me and sh was involved

Not you @Forester, another Nei*

thanks - echo “$SHELL” gives /bin/bash

1 Like

Changed script to executable - worked fine.

New issue - vdash command not found - will start a new topic…

Thanks!

3 Likes

Running the install script [767a958] I got the error
line 273: vdash: command not found

This followed the line

Now cofiguring vdash from @happybeing


       press 'q' to quit vdash     --- this will not interfere with your node ---

Thanks

1 Like

OK I’m looking at that now

Please post the output of rustc -V

OK please everyone git pull https://github.com/safenetwork-community/comnet-install

There was a stupid error that I have just fixed

Probably not picked up earlier cos most folk have curl rust and vdash already installed

5 Likes

This topic was automatically closed after 59 days. New replies are no longer allowed.