How to use the SAFE browser?

I recently found out about SAFEnet, and I was quite enthusiastic to get my SAFE browser working. I’ve got the SAFE Authenticator working, aka. I can access the “Authenticated Apps” tab (safe-auth://home).

However, I’m not able to use the browser for… “browser activities”. It might just be me that has missed some big thing about it or not realized something else, but every time I make a bland search, a.k.a only typing in singular words, not links, it either says “Requested service is not found.” or “No content found at requested address” and when searching directly using links (Such as “Youtube.com” or “Steampowered.com”) it tells me “Requested service is not found”, just like before.

Is it supposed to be this way? I haven’t found a single thread mentioning how this works, so I assumed it would work like a normal browser, or maybe mine is just broken? Any answers are appreciated!! :face_with_raised_eyebrow:

P.S. This is my first post, so if there is anything wrong with how I created this topic… That’s why. :slight_smile:

5 Likes

It is supposed to be this way :slightly_smiling_face: SAFE Network is independent from the web, therefore the browser only reads safe:// sites and not http:// or https:// ones. Try this post for some safe:// sites List of Websites/Safesites & WebIDs (Community Resources)

4 Likes

Thank you for your answer! I’m a newbie at this kind of stuff, didn’t realize that.

5 Likes

@JPL beat me to it - that list is an example of what currently exists on the SAFE Alpha 2 network. Also note, current behaviour for the SAFE Browser is that it will not try to launch your regular browser for non SAFE links, they just won’t open.

4 Likes