How do I set up SAFE on windows

I downloaded safe.exe, safe-authd.exe and safe_vault.exe. I placed them in their respective folders: .safe/cli, .safe/authd and .safe/vault. I also added the path .safe/cli to PATH and can now call the Safe CLI from CMD. I can run the following commands: safe update, safe auth update, and safe vault update with no errors.

Is there something more I need to do? Because when I run safe networks check I get an error like this:

Creating 'C:\Users\John Doe\AppData\Roaming\MaidSafe\safe-cli\config' folder for config file
Checking current setup network connection information...
[2020-06-13T11:35:30Z ERROR safe] safe-cli error: There doesn't seem to be a any network setup in your system. Unable to read current network connection information from 'C:\Users\John Doe\AppData\Roaming\maidsafe\safe_vault\config\vault_connection_info.config': The system cannot find the path specified. (os error 3)

What else do i need to do to fully set up?

EDIT: The first error is fixed, thank-you to @Southside

I also tried creating an account with some test-safecoins and got this:

C:\Users\John Doe>safe auth start
Starting SAFE Authenticator daemon (safe-authd)...
safe-authd started (PID: 6952)

C:\Users\John Doe>safe auth create-acc --test-coins
Creating a SafeKey with test-coins...
[2020-06-13T12:14:13Z ERROR safe] safe-cli error: [Error] NetDataError - Failed to allocate test coins: Unexpected: Connection timed out when bootstrapping to the network - CoreError::Unexpected::{"Connection timed out when bootstrapping to the network"}

If it helps, here are my safe_vault.log contents:

INFO 2020-06-13T13:26:27.665833400+01:00 [src\bin\] 

Running safe-vault v0.24.0
INFO 2020-06-13T13:26:27.681839800+01:00 [C:\Users\runneradmin\.cargo\git\checkouts\quic-p2p-9a2715614ed5c99d\c6ae051\src\] Fetched IP address from IGD gateway: V4(
INFO 2020-06-13T13:26:27.683845500+01:00 [C:\Users\runneradmin\.cargo\git\checkouts\routing-616e72cf40f12bc0\4a092f0\src\node\] eac668.. Bootstrapping a new node.
INFO 2020-06-13T13:26:27.683845500+01:00 [src\] Initializing new Vault as Adult
INFO 2020-06-13T13:26:57.686839300+01:00 [C:\Users\runneradmin\.cargo\git\checkouts\quic-p2p-9a2715614ed5c99d\c6ae051\src\] Node is unresponsive, removing it from bootstrap contacts; 0 contacts left
INFO 2020-06-13T13:26:57.686839300+01:00 [src\bin\] Vault connection info: ""
INFO 2020-06-13T13:26:57.686839300+01:00 [C:\Users\runneradmin\.cargo\git\checkouts\routing-616e72cf40f12bc0\4a092f0\src\node\] eac668..(?) Failed to bootstrap. Terminating.

EDIT 2: Thanks to @Southside again, I now know that the second error is normal because the shared section is down

Is there a way of knowing when the shared section is going to be up?
Thank-you in advance :slight_smile:


Try this and let us know if you are still stuck

You now need the network configuration containing the details of a hardcoded contact that will bootstrap you to the shared section. If you have connected to this or previous iterations of our shared section then you may already have a shared-section network profile saved on your machine. You can confirm this and update it to the latest configuration using safe networks check :

$ safe networks check
Checking current setup network connection information...
Fetching 'my-network' network connection information from '~/.config/safe-cli/networks/my-network_vault_connection_info.config' ...
Fetching 'shared-section' network connection information from '' ...

'shared-section' network matched. Current set network connection information at '~/.config/safe_vault/vault_connection_info.config' matches 'shared-section' network as per current config

If you don’t have a configuration in your results which points to the exact S3 location listed in the results above, you can add using safe networks add :

$ safe networks add shared-section
Network 'shared-section' was added to the list

Now you need to ensure you are set to use this shared-section configuration that we have updated/added, we can use safe networks switch shared-section for this:

$ safe networks switch shared-section
Switching to 'shared-section' network...
Fetching 'shared-section' network connection information from '' ...
Successfully switched to 'shared-section' network in your system!
If you need write access to the 'shared-section' network, you'

I did that, and now the first error is gone, thank-you for that


Yes, that’s as far as any of us will get for now with the shared-section.
It started well then failed after about 5-6 hours. Work is ongoing to determine the cause of the failure and a work-around.
For now however you seem to be set up and can participate as soon as we have a working-shared section.

You CAN run your own section at home and I will post links to that shortly or you can search “baby-fleming” in the forum.

Just to check, please paste the output of
safe auth status
safe networks


I see, so it isn’t an error on my end. Thanks.

The output of safe auth status is:

| SAFE Authenticator status                |        |
| Authenticator daemon version             | 0.0.10 |
| Logged in to a SAFE account?             | No     |
| Number of pending authorisation requests | 0      |
| Number of notifications subscribers      | 0      |

and the output of safe networks is:

| Networks       |                                                                                                  |
| Network name   | Connection info location                                                                         |
| shared-section | |

Yes - that output is as expected.
I have just fired up Windows on my laptop so I can follow along with Windows users problems.


Okay great. Thanks for helping me. I’ll just wait for the public section to go live again then. Will there be a post saying when it’s live? How is one meant to know when its live?


You can run your own local section if you want to start playing with CLI and commands to create an account, upload data to it:


I am unable to connect to a local baby-fleming with the latest vault binary.

1 Like

Make sure you have latest CLI v0.14.0 (safe -V), and perhaps make sure you don’t have any vault running (safe vault killall), then try again, I just tried locally and it’s working fine for me on Linux. I assume you do have latest vault (v0.24.0), but you can also double check by trying to update it with safe vault update.