Free ssl for every one


#1

Hey if you have a website and want to get SSL for free.

[Use CloudFlare, they now offer SSL to all their customers (even the free account)][1]

You can read a better story about it, [here @ techcrunch][2]

P.S. for people like me who don’t like to read… IT WILL TAKE UP TO 24 HOURS BEFORE YOUR SSL IS ACTIVE. But if you don’t like to read you probably won’t read this PS

Youtube how to install it for your website, I’m to lazy too look it up
[1]: http://www.cloudflare.com/plans
[2]: http://techcrunch.com/2014/09/29/cloudflare-adds-ssl-to-all-hosting-customers-in-advance-of-googles-focus-on-security/


Resources Category
#2

That’s nice, but a word of warning is in order: sometimes sites become slower (the exact opposite of how it should be; it’s usually when one of their regional caches is having problems) and another, extremely annoying issue is that they, based on their fuzzy-crap-logic, add captchas for people to be able to access the site (maybe you don’t get this “feature” if you’re a free customer, thank god).
To give you an idea, related to this second problem: if I read my RSS feeds and there’s 5 articles or posts on a site, CloudFlare will force me to enter ReCAPTCHA in order to access every single one of them (even if I do that sequentially, so it can learn my IP address). Sometimes I just mark new content as read and move on, so they effectively make sites lose viewership. I don’t know how widespread it is, but it’s totally pathetic.


#3

@janitor your right sir,

I forgot that bit, they also have the captcha when I use the Tor browser and go to coinpunk.com for instance.

but on the bright side, typing words from Captcha is helping to write books…

Hmmmm it might be that your host doesn’t support SSL (One of my host doesn’t support ssl, go figure).


#4

I just use Chrome on Windows to read my RSS feeds with Feedly - a very standard client configuration. And I read “coin” sites that support HTTPS. It may be that they “optimize” (i.e. ruin) access from certain parts of world where there are hackers and attackers so I get caught in that net. Again, I could understand the first ReCaptcha for the first site I hope from Feedly, but to ask me to do that moments after that - because my IP is by now known to CloudFlare - is outright idiotic. Hopefully they’ll fix that. many sites are now losing viewership because of their free service :slight_smile:


#5

@janitor

I’ve been playing around with Cloudflare and you can set the SECURITY to ESSENTIALLY OFF. In this mode it doesn’t require a Captcha.

Another handy tips. Redirect all your websites URL to be HTTPS as follow:

  1. Go to the gear icon to open up your settings.
  2. Go to the 'Page Rule’s option.
  3. Go to ‘Add New Rule’ and put in the URL you want to forward in the box.
  4. Put the destination URL in the forwarding box.
  5. Press the “Add Rule” button.

Wait 24 hours and you have an HTTPS site

Cheers


#6

Thanks for the tips. Maybe I’ll contact one of those sites that I read and ask them to tune their config or ask Cloudflare to stop presenting captcha for the same IP.