Fleming Testnet v3 Release - * NOW OFFLINE - v4 RELEASED*

I was able to get it



Ah OK I was just following the instructions in the OP

I’ll try that TYVM :slight_smile:

And it works – thank you @Traktion

We need to get the OP changed then and move safe auth start to after the networks section


I read it too rapidly and I understood it as your lazydog was a cat!


I’m the worst sometimes. What command do I use to watch my logs?? Trying to start a node before I go off to work. @StephenC that might be a good command to have in the user guide for noobs if there’s room for it.

1 Like

He’s right here next to me… he looks deeply offended! :rofl:


I am still not able to get it. Weird. UBUNTU 18.04.4. LTS

safe cat safe://hygoygyenxp3e516x1uktohmzxd3w8ubcnr9rhcd97xrjfsf4pztn5gbynw > pullopollo
Error: NetDataError: Failed to GET Public Blob: SelfEncryption(Storage)

Some context:

  1. I am putting it again at the same time. But I was not able to get this file even before.
  2. I have another cat process running in another terminal

Question: are the cat processes in my system activity monitor these cat’s of Safe? There is two of them running now.

Now I have to go. I’ll be back after a couple of hours.

1 Like

tail -f $HOME/.safe/node/local-node/sn_node.log

Yes that should be in the OP as well

IF - and its a big IF - I get time I will refresh the post I did a couple of days back where all the “start from scratch” instructions re in the one place Testnet - How to get started


Thanks @Southside

I think I’m in! no op from node duty (uncertain what that entails) but it says I’m storing chunks and storage space used. What is the directory to see the chunks being stored?

This is awesome!!!


from memory ~/.safe/node/local-node/chunks/immutable

furtle around in ~/.safe/node/ and it will be obvious

tree is your friend here :slight_smile:



wow this feels so much more responsive than V1…
I’m still afraid I might have IGD problems with my router…I’ll keep an eye on the node log and see if I get killed when/if promoted to elder


Trying to upload a map with some pics. Nothing happens…When should I get a response? When every file is uploaded or per single file?

Safe-the-planet.png download success!


I updated this a little earlier as per here so hopefully was just your page needed refreshed - let me know if I missed it somewhere else though.


Getting a connection from your node to an other public node should be pretty easy (if there’s no firewall etc blocking it), the other way around through NATs is the hard part.

1 Like

I use a local firewall on my machine … I expect that SN wouldn’t like that, so I am using (successfully so far) “proxychains” to push all connections through Tor (which my firewall allows) … and amazingly seems to be working fine.

1 Like

Once the whole lot have uploaded - no feedback at the moment is a sign that it’s running.

Much UX improvement required here, we know. It’s on the to do list :slight_smile:


Created a couple of Keypairs and have been successfully sending SNT between them.

I tried sending some SNT to my Nodes Reward Public key but it failed is that to be expected?

1 Like

40MB for me:

$ du -ch --max-depth=1 .safe/node/root_dir/chunks/
40M     .safe/node/root_dir/chunks/immutable
40M     .safe/node/root_dir/chunks/
40M     total

It seems to be returning requested chunks too, which presumably are incoming, e.g.

[sn_node] INFO 2021-04-15T13:58:43.566779857+01:00 [src/node/handle.rs:27] Handling NodeDuty: ReadChunk
[sn_node] INFO 2021-04-15T13:58:43.566954768+01:00 [src/chunks/mod.rs:65] Checking used storage
[sn_node] INFO 2021-04-15T13:58:43.567027233+01:00 [src/chunk_store/mod.rs:149] Used space: 20376114
[sn_node] INFO 2021-04-15T13:58:43.567105134+01:00 [src/chunk_store/mod.rs:150] Total space: 2147483648
[sn_node] INFO 2021-04-15T13:58:43.567166226+01:00 [src/chunk_store/mod.rs:151] Used space ratio: 0.009488367475569248
[sn_node] INFO 2021-04-15T13:58:43.567237251+01:00 [src/node/handle.rs:27] Handling NodeDuty: Send [ msg: OutgoingMsg { msg: QueryResponse { response: QueryResponse::GetBlob(Success), id: MessageId(dc88ab..), correlation_id: MessageId(f3e8c9..), target_section_pk: None }, dst: EndUser(Client { public_key: PublicKey::Ed25519(bf65070bbe2426d4aace6144672eb1be622d70584172df459e576fbb947d4e4d), socket_id: 4d1c91.. }), section_source: false, aggregation: None } ]
1 Like

YOu did Stephen, thank you - I just needed to refresh the page - sorry

1 Like