Fleming Testnet v3 Release - * NOW OFFLINE - v4 RELEASED*

On both laptop and desktop machines I get a similar error trying to start sn_authd
I have stopped all safe and sn_authd process and nuked the .safe folder

willie@gagarin:~$ safe auth start
Error: Failed to start authd

Caused by:
    AuthdError: Failed when invoking sn_authd executable from '/home/willie/.safe/authd/sn_authd'
willie@gagarin:~$ /home/willie/.safe/authd/sn_authd
sn_authd 0.5.2
SAFE Authenticator daemon subcommands

USAGE:
    sn_authd <SUBCOMMAND>

FLAGS:
    -h, --help       Prints help information
    -V, --version    Prints version information

SUBCOMMANDS:
    help       Prints this message or the help of the given subcommand(s)
    restart    Restart a running sn_authd
    start      Start the sn_authd daemon
    stop       Stop a running sn_authd
    update     Update the application to the latest available version
willie@gagarin:~$ /home/willie/.safe/authd/sn_authd start
Starting SAFE Authenticator daemon (sn_authd)...
[Error] GeneralError - Failed to start sn_authd daemon '/home/willie/.safe/authd/sn_authd' (exit code: 1)

What trivial mistake am I making?

Ubuntu 20.04 and 16Gb RAM on both machines

I get the same error if I try to get that file.

Are auth and authd the same? Both exist? Just guessing…

1 Like

Well that was too easy!

Just for fun and to make it more difficult, I’m running it all through Tor :wink: lol … amazingly it’s working !!

Edit: It’s probably the mission impossible (network) music running in the background.

8 Likes

You have to add and switch network first.

2 Likes
I was able to get it

Toivo_through_bottle

4 Likes

Ah OK I was just following the instructions in the OP

I’ll try that TYVM :slight_smile:

And it works – thank you @Traktion

We need to get the OP changed then and move safe auth start to after the networks section

6 Likes

I read it too rapidly and I understood it as your lazydog was a cat!

3 Likes

I’m the worst sometimes. What command do I use to watch my logs?? Trying to start a node before I go off to work. @StephenC that might be a good command to have in the user guide for noobs if there’s room for it.

1 Like

He’s right here next to me… he looks deeply offended! :rofl:

2 Likes

I am still not able to get it. Weird. UBUNTU 18.04.4. LTS

safe cat safe://hygoygyenxp3e516x1uktohmzxd3w8ubcnr9rhcd97xrjfsf4pztn5gbynw > pullopollo
Error: NetDataError: Failed to GET Public Blob: SelfEncryption(Storage)

Some context:

  1. I am putting it again at the same time. But I was not able to get this file even before.
  2. I have another cat process running in another terminal

Question: are the cat processes in my system activity monitor these cat’s of Safe? There is two of them running now.

Now I have to go. I’ll be back after a couple of hours.

1 Like

tail -f $HOME/.safe/node/local-node/sn_node.log

Yes that should be in the OP as well

IF - and its a big IF - I get time I will refresh the post I did a couple of days back where all the “start from scratch” instructions re in the one place Testnet - How to get started

6 Likes

Thanks @Southside

I think I’m in! no op from node duty (uncertain what that entails) but it says I’m storing chunks and storage space used. What is the directory to see the chunks being stored?

This is awesome!!!

4 Likes

from memory ~/.safe/node/local-node/chunks/immutable

furtle around in ~/.safe/node/ and it will be obvious

tree is your friend here :slight_smile:

image

7 Likes

wow this feels so much more responsive than V1…
WELL DONE GUYS!!
I’m still afraid I might have IGD problems with my router…I’ll keep an eye on the node log and see if I get killed when/if promoted to elder

6 Likes

Trying to upload a map with some pics. Nothing happens…When should I get a response? When every file is uploaded or per single file?

Safe-the-planet.png download success!

4 Likes

I updated this a little earlier as per here so hopefully was just your page needed refreshed - let me know if I missed it somewhere else though.

6 Likes

Getting a connection from your node to an other public node should be pretty easy (if there’s no firewall etc blocking it), the other way around through NATs is the hard part.

1 Like

I use a local firewall on my machine … I expect that SN wouldn’t like that, so I am using (successfully so far) “proxychains” to push all connections through Tor (which my firewall allows) … and amazingly seems to be working fine.

1 Like