Fleming Testnet v3 Release - * NOW OFFLINE - v4 RELEASED*

Trying the ‘safe xorurl’ method on a local dir

Blockquote
<NetDataError: Failed to PUT Public Blob: SelfEncryption(Generic(“Insufficient balance to complete this operation”))>

Isn’t this a client side operation? Why does it need a balance, or what does it want to PUT?

1 Like

How do I know how much spave I am offering as a node? What is the default? Can I change that?

3 Likes

Yeah strangely it seems intermittent, some S3 downloads have worked for @tjf while others haven’t. The DNS settings David mentions is certainly worth a check.

So the error here is at the part where it tries to get the config file from S3, there’s a simple workaround for this part by entering the config details in a command:

$ safe networks set manual-ips 138.68.130.204:50087 138.68.135.139:49440 138.68.146.170:32859 138.68.167.124:43149 138.68.180.216:49021 138.68.182.161:34595 139.59.162.138:52910 139.59.177.49:42192 139.59.184.250:50196 165.227.224.102:34793 165.227.224.69:34758 165.227.225.237:60110 165.227.226.230:33552 165.227.229.100:49408 165.227.229.103:59359 165.227.229.104:33663 165.227.229.129:57822 165.227.229.131:53334 165.227.229.142:60960 165.227.229.148:47735 165.227.229.150:33874 165.227.229.33:12000 165.227.229.55:32936 165.227.229.57:45221 165.227.229.59:47925 165.227.229.70:48326 165.227.229.71:54735 165.227.229.96:46868 165.227.232.158:50965 178.62.10.198:51741 178.62.122.173:58245 178.62.32.210:39347 178.62.74.247:51223 188.166.172.140:37214 188.166.174.88:54107 188.166.175.92:33968 46.101.17.63:46664 46.101.61.67:59088 46.101.72.129:37483` 

Then follow that up with:

$ safe networks switch manual-ips

ahh I see you got past this :smiley: I’ll leave those commands above there anyway incase anyone else would need them

Right, this bit has a much simpler workaround! You can download the latest node from GitHub here and add it to your ~/.safe/node/ dir.
You should hopefully then be able to run $ safe node join.

Just about there @tjf ! :sweat_smile:

4 Likes

Hollywood is probably guilty too, but I think the main reason people think stuff is difficult is Microsoft’s marketing people and Windows. It just isn’t a good system, and it makes trivial tasks seem complicated. I switched to Linux 20 years ago, and it wasn’t because I’m such a geek. I’m not. I just like my gear to work. My main reason for switching was ease of use. Even 20 years ago Linux was just more convenient than Windows.


I’m receiving chunks while tethering over my phone in the middle of the Gulf of Finland. Becoming an Elder with this connection would be fun.

The following has either crashed or is VERY slow.

safe cat safe://hygoyeye9mq5jmipo3we79wohue8hjyw55e6f8xyk1hquwy9hsxnk9tdsme > ~/Downloads/safe-the-planet.png

EDIT: I started another identical cat process while the former is still running. I quickly got this:

sascha@Knut:~$ time safe cat safe://hygoyeye9mq5jmipo3we79wohue8hjyw55e6f8xyk1hquwy9hsxnk9tdsme > ~/Downloads/safe-the-planet_2.png

Error: NetDataError: Failed to GET Public Blob: ErrorMessage(NoSuchData)

real	0m14,926s
user	0m0,342s
sys	0m0,144s
6 Likes

How do I get this @happybeing ? Is there any instructions anywhere?

1 Like

See here: https://safenetforum.org/t/vdash-safe-node-dashboard-safe-vault-run-baby-fleming-t

3 Likes

perhaps just a bug…noted! thanks!

Awesome. Thankyou.

1 Like

It also takes a very long time on a map. Just guessing here…but might be related that it’s checking the balance for each file?(because safe keys balance is also a slow method). So when I do a real put, is it possible that it also runs this xorurl method in front and unnecessarily does all these operations and makes the complete upload really slow together?

1 Like

Update from MaidSafe HQ

Thank you so much to everybody who’s had a go at trying out Fleming Testnet v3, and for all the fantastic feedback provided.

Yet again, your assistance and persistence have been absolutely invaluable in highlighting issues that have evaded us in-house.

Next priorities for us for testnet v4 are to fix another data loss bug that you found, as discussed here, along with completing the implementation of Anti Entropy across the board. No doubt we will squeeze in a few more improvements along the way.

The team will be taking some downtime tomorrow (Friday) and come back next week refreshed and raring to go again. You can expect testnet v4 to come along around the middle of next week at the earliest.

In the meantime we plan to leave testnet v3 up and running, unless it becomes unstable and unusable, in which case we will take it offline and update the title of this topic to reflect this.

41 Likes

WOW… I may not have managed anything else but I have chunks! I am running a node! :smiley:

13 Likes

Thanks @StephenC & everyone at MaidSafe. This is really something to watch and be part of. Well done everyone in the community too. Great stuff :sunglasses:

21 Likes

Yes, we have to improve our sn_client lib, currently it checks the transfer’s history/balance so it’s ready for any operation, but we don’t need this for read-only operations, so you are on the right track of where the root cause is.

3 Likes

EDIT: I spun up a brand new ubuntu instance, did the exact same thing… and everything worked.

OLD COMMENT:
Trying to cross compiling on the same Ubuntu box as yesterday for my raspberry pi but have issues.

Need some help from some rust-ies :slight_smile: Only polluting this thread with Pi rubbish as it worked yesterday, and keeps not exiting successfully at the same point today… incase its useful.

Am git cloning the latest repos.

All other dependencies for sn_api compiled ok except for sn_messaging v13.1.0,
and all other dependencies for sn_node compiled ok but is hanging on sn_messaging v14.0.0 for ages and I expect it to not exit successfully.

compile of sn_api:

Compiling sn_messaging v13.1.0

error: could not compile sn_messaging

Caused by:

process didn’t exit successfully: rustc --crate-name sn_messaging --edition=2018 /home/ubuntu/.cargo/registry/src/github.com-1ecc6299db9ec823/sn_messaging-13.1.0/src/lib.rs --error-format=json --json=diagnostic-rendered-ansi,artifacts --crate-type lib --emit=dep-info,metadata,link -C opt-level=3 -C embed-bitcode=no --cfg 'feature="simulated-payouts"' -C metadata=562c9392f44444ea -C extra-filename=-562c9392f44444ea --out-dir /home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/aarch64-unknown-linux-musl/release/deps --target aarch64-unknown-linux-musl -C linker=aarch64-linux-gnu-gcc -L dependency=/home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/aarch64-unknown-linux-musl/release/deps -L dependency=/home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/release/deps --extern bincode=/home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/aarch64-unknown-linux-musl/release/deps/libbincode-6164a30f1bfeb5de.rmeta --extern bytes=/home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/aarch64-unknown-linux-musl/release/deps/libbytes-5312a2cab8becf96.rmeta --extern cookie_factory=/home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/aarch64-unknown-linux-musl/release/deps/libcookie_factory-3039925320269c60.rmeta --extern crdts=/home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/aarch64-unknown-linux-musl/release/deps/libcrdts-234af766ce15f852.rmeta --extern ed25519_dalek=/home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/aarch64-unknown-linux-musl/release/deps/libed25519_dalek-1e5aced1e449a752.rmeta --extern hex_fmt=/home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/aarch64-unknown-linux-musl/release/deps/libhex_fmt-17a08fb64efeec1d.rmeta --extern multibase=/home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/aarch64-unknown-linux-musl/release/deps/libmultibase-03ad98fc50692f32.rmeta --extern rand=/home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/aarch64-unknown-linux-musl/release/deps/librand-aedc564f4d9ae27d.rmeta --extern rand_core=/home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/aarch64-unknown-linux-musl/release/deps/librand_core-73d2e50433cfbe31.rmeta --extern rmp_serde=/home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/aarch64-unknown-linux-musl/release/deps/librmp_serde-ede691744142bc70.rmeta --extern serde=/home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/aarch64-unknown-linux-musl/release/deps/libserde-0083f07b4cff06d3.rmeta --extern serde_bytes=/home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/aarch64-unknown-linux-musl/release/deps/libserde_bytes-37052c0e6482c9e2.rmeta --extern signature=/home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/aarch64-unknown-linux-musl/release/deps/libsignature-505c3f4e171b9df3.rmeta --extern sn_data_types=/home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/aarch64-unknown-linux-musl/release/deps/libsn_data_types-fd8f894912e4ffca.rmeta --extern thiserror=/home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/aarch64-unknown-linux-musl/release/deps/libthiserror-248d6ea9cce0a28f.rmeta --extern threshold_crypto=/home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/aarch64-unknown-linux-musl/release/deps/libthreshold_crypto-d289ecd584f23c26.rmeta --extern tiny_keccak=/home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/aarch64-unknown-linux-musl/release/deps/libtiny_keccak-2d1defc85450295f.rmeta --extern xor_name=/home/ubuntu/tmp_compile_safe/ubuntuxc/sn_api/target/aarch64-unknown-linux-musl/release/deps/libxor_name-40ce4da7c73d6c89.rmeta --cap-lints allow -C target-feature=+crt-static -C link-arg=-lgcc (signal: 9, SIGKILL: kill)

One more thing about this bug:

Just a minute ago I tried to cat file that I managed to re-put, and got the Failed to GET Public Blob: ErrorMessage(NoSuchData) error. So I was trying to put again a file I had put before. I would have expected to be able to cat it, because likely no section splits between the put and cat. So I wonder if the de-duplication works so that I cannot put new chunks in the places where the previous chunks were lost?

1 Like

$ safe keys create —test-coins —for-cli
Error handling network info message: InsufficientElderConnections(3)

This means that the network does not need new resources, thus there are not enough Elders to connect to?

1 Like

No, that means is not able to connect to at least 5 Elders to perform the operation

2 Likes

It is now officially beer o’clock for you lot

WTF are you doing still hanging around???

GTF - go relax…

oh and thank you - all of you :slight_smile:

6 Likes

Oh ok, so this should not happen or it’s a planned behaviour?

This one might collapse now folks, but I would just let it, we are gathering logs in any case, but right now I am switching off and :beers: after :shallow_pan_of_food: and chill. We have a lot of small tweaks and more simplifications again. Amazing stuff!!!

26 Likes