Fleming Testnet v1 Release - *NOW OFFLINE IN PREPARATION FOR TESTNET V2*

Congrats on the milestone.

Will give it a try this weekend

3 Likes

I’m not allowed to join as a node yet, but it looks like the network is still up.

sascha@sascha-Librem-15-v3:~$ safe dog safe://hello

== URL resolution step 1 ==
Resolved from: safe://hello
= NRS Map Container =
PublicName: "hello"
XOR-URL: safe://hyryygy3u8n9g1u4oaz3utykjo5g9y4drkqwetqnxejgz1kzwzron8g8u1en7a
Version: 0
Type tag: 1500
XOR name: 0x3338be694f50c5f338814986cdf0686453a888b84f424d792af4b9202398f392
Native data type: PublicSequence
Native data XOR-URL: safe://hyryyyy3u8n9g1u4oaz3utykjo5g9y4drkqwetqnxejgz1kzwzron8g8u1en7a
+------------------+----------------------+----------------------+---------------------------------------------------------------------------+
| NRS name/subname | Created              | Modified             | Link                                                                      |
+------------------+----------------------+----------------------+---------------------------------------------------------------------------+
| hello            | 2021-04-08T16:33:22Z | 2021-04-08T16:33:22Z | safe://hyryyry999x547c4qphhzhg15jgexkrx8snh6awwxu8gx45ufyueek4at4enra?v=0 |
+------------------+----------------------+----------------------+---------------------------------------------------------------------------+

== URL resolution step 2 ==
Resolved from: safe://hyryyry999x547c4qphhzhg15jgexkrx8snh6awwxu8gx45ufyueek4at4enra?v=0
= FilesContainer =
XOR-URL: safe://hyryyry999x547c4qphhzhg15jgexkrx8snh6awwxu8gx45ufyueek4at4enra?v=0
Version: 0
Type tag: 1100
XOR name: 0xfffbf7aeb34e6f397e1a5b4990f511e7b0b9ec528f99ccfd6e6504d0856b11d2
Native data type: PublicSequence
Native data XOR-URL: safe://hyryyyy999x547c4qphhzhg15jgexkrx8snh6awwxu8gx45ufyueek4at4enra?v=0
2 Likes

I more expect shutdown today and days (or weeks) of fixing before next test.

1 Like

The Safe Network Telegram Bot is now connected to the public fleming testnet!
You can view all files uploaded to the shared testnet, your own and those from others! You can also send coins from your CLI to any address generated by the bot or vice versa, or receive/tip people on Telegram if they initialized their Tip Wallet!


Starting the bot and doing /init to create a tip wallet.


Viewing all commands and some info.


Your secret data, for this test it’s will not have any value but once live you don’t want to share this with anyone.


Adding testcoins, sending, tipping, etc.


Telegram Test Chat, user tipping another user that has initialized his Tip Wallet.

Feel free to join, first we had this bot in the public SafeNetwork chat but it was too spammy and the admins feel it’s more appropriate if there is a different chat for this. Here you can ask questions and tip each other for fun.

Will add more features like viewing images directly from the network if the file is png/jpg/gif or if there is a file with movie format. Currently you can inspect text files and it will show the content, but for images/videos it will tell you it cannot be displayed.

31 Likes

My logs have got over the the issue I was having and returned to normal.
I can retrieve safe://deusnexus but not safe://lazydog.

Sorry @Nigel I was asleep did you get in?

Are these not enough, still busy today but let me know. It’s straightforward if you have Rust installed: Vdash Safe Node dashboard `safe vault run-baby-fleming -t`

1 Like

Now it seems to go faster. One transfer takes just under 40 seconds.

It seems to me that some people don’t realise what a huge step it is to have a network running in the wild with everyone being able to send data freely.

Congratulations to the whole team. Many years waiting for this.

23 Likes

It is monumental, and the most serious criticism of the last testnet was ‘yeah, it works, but isn’t decentralized’… there are no blockers like that anymore, no gotchas for the naysayers, just the technical merits as it evolves.

It will be interesting to see if it speeds up as it grows and once data is devolved enough and the nodes span all time/internet zones. Also, optimization and caching will happen… this is just the beginning.

11 Likes

Woohoo… I must test it too… :+1: A lot of talk about speed, delighted to hear it works, even if slow to start :grin: I guess significant speed optimisation is indeed possible?

Again, congrats :ok_hand:

2 Likes

My guess - 10x faster is no problem, 100x - maybe not possible.
And separate question is how speed relates to network size.

1 Like

For now I see opposite thing: larger the network - more slowdowns.
But it may be just coincidence.

Hmhmm - most certainly depends on how much of the delay is caused by final bugs and how much of it is none optimized code :face_with_monocle:

3 Likes

Morning! We’ve not seen any reports of the dreaded IGD errors which plagued testnets of years gone by, so it seems safe to say that we have resolved those connection issues! This is a pretty remarkable achievement in its own right, and something that I know will be HUGELY appreciated by those who were having those frustrating IGD issues in previous testnets, of which I was one.

I’ve updated the OP with this excellent news :rocket:

No More IGD connection problems!

Who remembers not being able to participate in previous testnets over the years due to an IGD error:

Automatic Port forwarding Failed. Check if UPnP is enabled in your router's settings and try again. Note that not all routers are supported in this testnet.

With ZERO reports of IGD errors after 15 hours of the testnet being online, we can now safely say this issue is resolved! :tada:

We’ve changed a few strategies in our qp2p crate since previous testnets. We now lean on the bootstrap nodes and echo service, rather than trying to contact the IGD gateway, and we haven’t seen an IGD issue in-house since. But with such a small in-house sample size we wouldn’t know for sure whether this had been completely resolved until we tried it in a public testnet - well the results are in and the evidence confirms that all IGD issues have been completely eliminated!

39 Likes

File upload is for sure have lot of room for optimization.
Loading whole file into RAM (in multiple copies) looks like very rough solution.
Also adding progress bar may make upload look faster )

4 Likes

Hooray! Congratulations to the team.

7 Likes

If I try to generate test-coins with safe auth create --test-coins it hangs. Someone knows what to do?
Edit: It works now switched console :slight_smile:

1 Like

Looks like i hit my upload limit.
Error: NetDataError: Failed to PUT Public Blob: Transfer(InsufficientBalance)

so that check works. :slight_smile:

5 Likes

Good work! Will there be official arm/aarch64 builds? The install script has x86 hardcoded into it.

2 Likes

If things seem to hang leave them running. Even simple commands are taking a minute or five.

Last night I left an upload running which looked like it had hung but it eventually completed even though when I left it there had been no output to the console. It was only two MB but probably took over an hour.

I think there is probably one of two bugs in that area, but so far I’ve not seen any real errors.

8 Likes

Thanks for your answer switched to powershell and it seems to work now :sunglasses:

2 Likes