Feedback for Test 17 (internal testing)


#144

Were you able to claim the token and update the IP? Once you claim the token the UI will show an update IP option. The user must click on the Update IP button to get the IP whitelisted to connect as a client. After updating the IP, the invite token can be copy and pasted into the authenticator’s create account section.


#145

So what actually happened here… It is just some simple html with a picture. Here’s my guess:

  • Created Public ID
  • Created www-root folder and uploaded the 2 files
  • All worked well until I tried to create another domain called: safe://davidspeaks

The second website never worked on the network although it’s a simple site with a video with David in it. locally it works well.

  • Next thing I tried was to delete the files in the safe://polpolrene www-root folder and uploaded these other files to this map. The upload worked well so I assume there’s something else crashing the browser. Locally the website works in several browsers

      <!DOCTYPE html>
    
      <html> 
      <body> 
    
    
      <video width="1280" height="720" controls>
        <source src="david.mp4" type="video/mp4">
    
      </video>
    
      <p>
    
      </body> 
      </html>
    

Or did something break because of pointers in MD that didn’t got updated to the new html (with a different hash)???

EDIT: Is the network down?? I can’t connect…


#146

Could someone please explain what the rate limiter is, and why we’re adding IP’s back into SAFE? :stuck_out_tongue: not sure how I feel about either of those recent developments…


#147

@frabrunelle and I got together on a audio line and checked it all out.

Definitely have done all the things right that you’ve touched on above. We even checked into ensuring that all previous versions were trashed, trash emptied and reboot to erase any possible association problems.

No joy. The Authenticator button and the Authenticator link to safe-auth://home/ are completely null and even entering into the url line and executing doesn’t get any response, though other buttons are responsive.

Previous binaries worked as expected for me, and current ones worked fine for Francis with the same OSX version, so go figure.

I’m going to assiduously erase all previous binaries and await the next iteration.


#148

I take it there’s still a size limit on uploaded files? Tried a 52MB file but the upload failed.


#149

The rate limiter was introduced in the June 22nd update:

As I understand it, this is to make sure that if a client is using too much bandwidth to the detriment of the network / other clients, they are throttled. Some kind of mechanism will be needed to ensure nobody can disrupt the network by overloading it with download requests etc. Any resource that is free is a potential attack point unless there’s some other rationing mechanism. I believe a rationing mechanism for a ‘free’ resource the network provides to clients.

Please correct me if I’ve got this all wrong :slight_smile:

IP addresses are needed for white listing users for early tests to ensure the network isn’t disrupted again like it was in previous public tests. This serves a temporary purpose for this private testing stage.

Again, if I’ve got this wrong, someone with a better understanding can correct me!


#150

I seem to have hit my limit far below 50mb.

What is the limit for current testers, and is there a way of seeing your current account balance?

My experience on Windows 10 has been very good so far, other than hitting the account balance limit, which also means I can’t authenticate new apps.

I agree with those who have mentioned the confusing wording when it comes to publishing a web site.

I also had issues with my test website not working due to having ‘index.htm’ instead of ‘index.html’ as the detault page.

Great to see this network alive and kicking, and it’ll be great to see it refined and rolled out to more users soon.


#151

2 posts were merged into an existing topic: Hardfork BTC - maidsafe positions


#152

Am having the EXACT same problem as you John. No dice. I deleted all previous binaries, downloaded new binaries, put in my name to google doc and clicked on the corresponding link and updated my ip address and it shows it as correct. Open Safe Browser and click on Authenticator link on the bottom, the info “i” next to it, put the auth url in manually, and no reaction at all. When i hover over the Auth link at bottom the pointer changes to a hand as if it’s a clickable link but does not respond to any clicking. Ideas @Krishna_Kumar? everything seemed very straight forward so not sure what the issue is exactly. Any info you need i can give.

Running MacOS Sierra 10.12.4


#153

I just tested and was able to connect. I also was able to upload a a simple html file with the SAFE Host Manager and view it with the SAFE Browser - safe://berespectful.upstate1


#154

What OS? 20 characters


#155

As @DavidMc0 said. And to add this IP registering would be replaced by each relay node rate limiting each IP address connecting and using it as a relay node. This way no machine can hog the relay’s/network bandwidth.

Again this is how I understand it for the live network


#156

SAFE Browser:

If I click on a clearnet link (github) it automatically opens a tab in the default browser (firefox) going to that link.

Since we are after a Secure system, it is possible for future SAFE sites to code malicious clearnet links that appear good but go to wrong sites. And to do this immediately.

Really this is no more secure than the current internet, but people are of the mindset that it is safer/more secure.

I personally think we need some sort of (maybe) popup to alert the user to the actual URL it wants to open and get verification that is what the user wants to do.


#157

Got this error when trying to register my account (same secret as previous test)

EDIT: stupid me, forgot to click “Update IP”


#158

Should be most current version of Sierra but I’ll append my post with version number tomorrow.


#159

I can connect again, my account is still there.

I uploaded safe://polpol.rene/index.html and this one works fine. But safe://polpolrene still crashes the browser although it has the same index.html and same data. Like I said before, I think something went wrong after I tried to upload a new website in the same container (_public/www-root).

Uploaded a video as well, this one works fine…

safe://play.davidvideo/index.html


#160

So it does. As an experiment I deleted safeblues.jpl using the Web Hosting Manager, tried to visit the site in the SAFE Browser and the same thing happens: instant death. I’d say that’s a bug for sure.


#161

Ahh, nice work. Guess there’s trouble when a piece of MD (in this case a domain) links to certain files and therefore their hashes. No idea really though, could be something else.


#162

Web Hosting Manager - usability test
Here’s a walkthrough through the eyes of a newbie (i.e. me two weeks ago) trying to create a site.

Note: Ignore all the pre-created IDs for the sake of this walkthrough, they can’t be removed
Hmm … SAFE Hosting Manager? Oh well, I guess it’s probably the same thing.

OK, that all makes sense, create a public Id - maybe ID should be capitalised though.

So now what? Ah, perhaps I click that Tick icon? Nope, that means connected. I would use a green dot or a plug symbol for that. In Excel and other apps a tick is what you click when you’re done.

Right, create a service. Hang on, what’s a service? A website? And why is that button blue on white rather than white on blue? Is it active? Ah well, I guess I’ll find out.

What in the name of the Merry Irvine is this? :grimacing: What the hell is a container and why would I want to map one? What is root? Last time I heard that word was just before a mate bricked his phone. Now I’m scared. OK, be brave, type in a name go with the default option (Note: not sure if this is actually the default for a new user, but still)

What now? I don’t like the look of that weird-looking link beginning with the underscore. Perhaps I need to click on the newsite link? Well that looks like a road to nowhere :confused:, weird-looking link it is then.

OK I’ve created my service, whatever that is, and uploaded my website folder. Lets see what happens if I browse to newsite.jpl2 - nope, that site doesn’t work :disappointed_relieved:- it exits to clearnet brower with ‘DNS can’t be found’ error.

Tell you what, I’ll delete this service and go back a few steps and try the newsite-root option.

OK site uploaded - let’s try again.

Hallelujah!

I realise the immediate goal is to get things working, but I must say I found the old demo-app a lot more intuitive and easier to use.

Recommendations:

  • Instead of ‘service’ (techie word) use ‘website or folder’
  • Instead of ‘container’ user ‘folder’, ‘storage area’ … something more standard (not sure if either of those options fit the bill TBH).
  • Hide the mapping option on separate page (e.g. reachable through an ‘Advanced options’ link) - make the default option the creation of a new website using a new container.
  • Make the newsite link (in my example) a link to the file management page, where you upload and download files)
  • Add some dialogue about the website folder needing an index.html file, and how to access the website once it’s been uploaded.
  • Add some dialogue about mapping / remapping, how and why. I still don’t really understand this.
  • Add some dialogue about public and private storage (can we actually store private files using the Web Hosting Manager? I couldn’t work out how to do it.)

#163

Has anyone tested streaming via safe?