Feedback for Test 17 (internal testing)


#122

Yay, thanks for demoing the SAFE test sites :smiley: (was waiting for this vid :stuck_out_tongue:)


#123

I did notice the lock and like the subtlety of it, I did not notice search though. I think these things will be discovered and do not need to be overstated, I like it the way it is. Much like the authenticator logo changing color/state, I only just discovered that, finding little treasures as you explore only adds to the experience.

Edit: I don’t see a way to delete public ID’s? I created an ID that I don’t want or need but am unable to delete it. This does not allow for it to be recycled/used by somebody else. But mostly it clutters my space and I want to make it go away.

  • I am able to upload video clips only by individual file not by directory. (individual file size limits not directory size right?)
  • When I attempt to drag and drop to hosting manager I get different responses depending on the file, image and index files open in the hosting manager window and others cause an immediate crash but all require a restart.

#124

Yesterday, we updated the internal testnet for Test 17. It now has the Rate Limiter feature.

We just invited the 3 batches of forum users to download the new binaries and participate in this updated testnet :slightly_smiling_face:


#125

The executable in both the platforms are Web Hosting Manager. Previously we had named it SAFE Hosting Manager, we recently renamed it to Web Hosting Manager, this issue might be because of using an old binary (SAFE Hosting Manager). However, as you have pointed out the naming would have to be consistent and will try ensuring the same.

We will try to reproduce at our end also.

Thanks for the feedback @Krekc


#126

Noted as an UI issue, will rectify it.

The clearnet links should be opened in an external browser if it is registered to handle http scheme

Cheers for sharing your thoughts. Will bring up your points in the discussions for UI/UX improvements in the coming week.


#127

we don’t have the streaming/buffering/partial read functionality in place. May be on a slower internet connection it takes time to download the entire content and play. The core library supports streaming, have to integrate the same on the nodejs api too


#128

Thanks @mav. Have aggregated your suggestions at my end. Will take the inputs and improve the experience.


#129

Just gave it a try and I spot some nice improvements. Have a look at how the Authenticator asks you if you allow a certain App.

This is all nice and clear and these little “info” icons work as well:

Same for the Email App:

safe://polpolrene is online again and those that want to mail can use: polpolrene

1 point I noticed is that favorites for certain domains aren’t saved and are therefore gone when you log in again. Maybe this is done for security reasons (??) but it might be an idea to only load favorites after a log in with the Authenticator? Not a big thing though, I’m actually excited about this one.

I also like the fact that there are links to clearnet (our Forum and GitHub URLs) which open in your standard browser. This way it’s really clear that you are leaving The SAFE Network back to the world of trackers and cookies.

Really nice work @maidsafe

Sorry for everyone who is teased right now :yum: hope you all be in soon.


#130

Keep up the good work!

I’ve just updated to the new testnet and did some quick tests.

I had the following issues:

  • At the first ‘account secret’ when creating new account in SAFE Browser: I got a ‘not long enough’ message or something like that. Although I tried to use exactly the same account secret as the one I used at the previous Test 17 network. But maybe that is the cause of the problem, because
  • After creating the new safe://plant.draw, when I tried to get to this page, this browser kept on loading, without showing anything (also no error message). But safe://onepunch.draw of the previous test was still reachable. I think I also restarted the browser. If this was the case: same problem.
    I could also still login with the account of the previous network.

After reboot of my pc safe://plant.draw worked and safe://onepunch.draw gets the ‘cant be reached’ error msg.
The old account also doesn’t work anymore.

Also I got the following message when clicking on the github url link in the screen below:

Error popup:

A JavaScript error occurred in the main process
Uncaught Exception:
Error: Object has been destroyed
    at Error (native)
    at Function.win.webContents.session.webRequest.onBeforeRequest.e (/home/ward/maid/safe-browser-v0.2.1-linux-x64/resources/app/background-process.build.js:1415:19)

#131

Okay. I’m having a problem ramping up new binaries.

Downloaded. Got new token. Opened browser. Clicked on “Authenticator” button. Nothing happens. I believe it should open Authenticator in new tab so I can register an account using new token.

Am I missing something? Didn’t have a problem with last binaries.


#132

yes, this is how it worked for me.


#133

I’ll try redownloading that binary.


#134

Tried redownloading binaries. Perhaps a bug with the OSX binaries?

Anyone else using the OSX version successfully?


#135

How about having “Allow Deny” outside the scrollable part of the window, underneath the scrollable part?

Also, I think it is strange UX for that window to be off-centre. It might be more intuitive it it looks as much like a modal dialogue as possible - so centred within the browser window making it the centre of attention.


#136

Yes, the OS X version seems to work fine for me.

As an alternative, you could try going directly to safe-auth://home.


#137

I think I broke something :yum:. Uploaded my simple web html to safe:polpolrene
I deleted the .html and .png files (empty www-root) and uploaded 2 new files (a different website). Now every time I try to open my domain safe://polpolrene the SAFE Browser crashes for some reason. Anyone else who dares to try my domain?


#138

Just tried your site and the same thing occured.

EDIT: @polpolrene I just sent you a message in the SAFE Mail tutorial after the crash to see if that was still working. Did you receive it?

ANOTHER EDIT: Tried safe://polpolrene again and it killed the SAFE Browswer instance for me again.


#139

safe://polporene also causes a crash here.
Now I’m going to crash a party myself, so no more testing for me today.


#141

Stop it… I like it :wink:

Smooth sailing, this time I created my public ID first and had no issues using the same thereafter for my email ID.
I am on new connections throughout the day so having saved the invite url to my favorites bar its quick and easy to update my IP, great stuff, I was afraid it may be a pain.

Email: savage
safe://memory.savage


#143

Technically this is possible. May be we can have this feature in the email app, to allow the user to choose a publicid or create a new public id. Will check with @bochaco also