Feedback for Test 17 (internal testing)


#62

lol with my username I will probably receive my invite when Safe is out of beta.


#63

haha I am also waiting for my invite :blush: I hope I get one, it is a real torture…


#64

So I had a teeny bit of spare time to try the new release this evening. So here’s some feedback, my apologies if some items have been mentioned before.

SAFE Browser / Authenticator

  • I think that the Authenticator should be more prominently displayed on the landing page. I had to search for it a bit the first time I started the browser. To me it makes sense to make (new) users aware that they can explore the network with the browser without doing anything else, but that the Authenticator unlocks a whole range of extra possibilities for them. The current location at the bottom of the landing page just doesn’t draw any attention at first.

  • Apps that I have previously authorized are listed as “Authorized apps” when I log in to the Authenticator, but when I start the SAFE Hosting Manager I have to authorize it again. If that is how it should be it would make sense to not show it under authorized apps every time you log in to the Authenticator.

SAFE Hosting Manager

  • If you click delete the file is immediately gone. So if you accidentally click delete the file will be gone. Now I can imagine that some people would find it annoying to have to confirm that they want to delete a file. Especially when they want to delete a bunch of them and not the whole folder. For this it would be handy if you could select a couple of files using check boxes and then deleting them all at ones (after being asked if you really want to delete the files).

  • When I click on a file I have uploaded it automatically downloads it to a temporary folder. I’m not sure immediately downloading a clicked file makes sense. People may not wish to do so for a variety of reasons. To me it would make sense to ask if the user wants to download the file. Another option would be to add a download button like with the delete button.

  • Tried uploading a folder again, but no success either today. I tried selecting the folder and then choose “Select folder” and I also tried clicking into the folder and then choose “Select folder” both ways didn’t do anything. Only uploading separate files works.

  • When I click on the name of the service (with the red square around it) I created for a Public ID Windows 10 comes with a pop-up stating that I need an app to open the safe. Maybe this is working as intended, but it feels like it’s not.

The message reads “You need a new app to open the safe” “Search for an app in the Windows Store” “Always use this app”.

  • I tried creating a service under my first Public ID. I click CREATE SERVICE.

I then fill out the name of the service, in this case “blablabla” and I get “Access denied”. I also tried “www” and it then says “Entry already exists”. Which is not true as you can see in the first screenshot. I have used “www” under another public ID, but it doesn’t make sense that it can’t be used for other public ID’s?

I tried restarting the SAFE Hosting Manager, but this doesn’t have any effect.


#65

Basically I was thinking in terms of the APP asks for all the things it might need to do. The user approves/disapproves each and every permission. To save time they default to yes (or the user’s selection last time they ran the APP) and the user can then change it before allowing the app to proceed.

Now when the APP is running and tries to do something the user denied permissions then the APP receives an error from the API call. Could even have the error as DENIED. This would allow the APP to educate the user as to why it needs the permission or the APP just gracefully accepts the user is selective in what they allow.

SO something like

This APP wants these Permissions

  • perm group 1
  • perm group 1, sub perm 1
  • perm group 1, sub perm 2
  • perm group 2
  • perm group 2, sub perm 1
  • perm group 3
  • perm group 3, sub perm 1
  • perm group 3, sub perm n

And each has a check box next to them allowing the user to deselect any Permissions group which deselects all sub permissions under the group or to deselect a particular sub-permission.

If you mean the APP is running and asks for permission when the APP code wants access to private data, THEN later ask for permission when it wants access to say the network. I’d say that is annoying at best because in theory you could have the APP ask for 20 permissions throughout its operation and if its an APP that runs for a long time (eg a home monitoring APP) then the person may not be present to allow/disallow some permission and the APP may fail.

EDIT:

You know what might be great is to be able to click the APPs title bar and in addition to the “move/size/minimise/maximise/close” options there is one to view/change the permissions for the APP. This way the user could change their mind as to what permissions the APP is allowed.

So say for instance

  • the user is running an APP that runs for a sufficiently long time.
  • They want it to have a certain permission at the start since it looks for updates (access the network)
  • But afterwards they turn off that permission (access the network). The reason for denying could be user doesn’t want it accessing their mobile data, or the APP has built in advertising they don’t want.

Thus if the user could click the APP title bar and change the permissions allow/disallow settings it would be really great. So have the initial asking for permissions and then they user can view or change the permissions as the APP is running.


#66

Am I not permitted to have the the same ID for public ID and email ID or is this a bug?
For example,
I create the email id: savage but once that’s done I am not able to create safe://mystuff.savage

safe://memory.savage1


#67

I would personally still like to be notified when sensitive actions occur even if I allowed them initially. This not only educates me as to when the apps needs to perform the action but gives a second chance to decide if Im comfortable with my original decision.

An option for not alerting me again (after the second confirmation pop up) is of course useful in this scenario. It could also default to interpreting your second authorization as consent to continue without further user feedback. That needs further community discussion due to several implications.


#68

I just tested it out what @Savage was saying using another invitation code and seems to be an issue.

If you register a public ID first in the SAFE Mail app it won’t allow you to create a service in the SAFE Hosting Manager for that Public ID. I tried both “Create a new public container” and “Select a container to be mapped”, but it’d error out. I restarted all the apps, revoking the apps privileges, did a hard reload in the SAFE Browser and did this all these steps in various orders but nothing would allow me to register a service with the public ID I registered in the SAFE Mail App first. The errors I was getting is “Access denied” or “Entry already exists” depending on whether I cleared the cache in the SAFE Browser or not.


#69

WEB HOSTING MANAGER
Trying to create a service and i either get access denied

or this
Which has spelling error i believe. Instead of “contain” it says “containER”.
I cannot create a service even after revoking access, restarting, etc.
Also when creating a service, instead of having to click CREATE SERVICE with the mouse it would be slicker to just hit ENTER on the keyboard.

SAFE MAIL APP
i got this java script error message when initially launching safe mail app but i clicked okay and it didn’t affect anything.

AUTHENTICATOR
I liked the fact i could search my authorized apps though personally i would leave the dashes ---- out of the app name. As you can see the app only shows up IF the dashes are included.

Here i’m just being a nit picker but i really want everyones grandma to be able to instal safe, so. I feel that underscores_are_used_to_heavily in authenticating and container names.

I think they have a place in the developer world for before root files?? But the everyday user does’t get it and it makes things look like something is wrong to them or confuses them on what they might be there for, etcetera.

I agree with others on the allow/deny button and i saw @Krishna_Kumar earlier post with the reworked allow/deny pop-up and it looks much better!

On Authenticator home page it might be worth having something under create account or maybe the url bar that says “Just Browsing?” or “Browse without an account” something to that effect.

So far I’ve just been looking at the UI and the directions and i think the UI is pretty damn close, it looks amazing, just not sure everything is where it needs to be or simplified enough when it comes to explanations. Got into authorizing and revoking apps and that all went smoothly. Bummed that i cannot create a service though… I’ll try tackling that when i get more time to see if i can find what works and then get into browsing sites :slight_smile:

Sorry for all the criticism, i know how hard you all work on this but i promise it’s all coming from a good place because like i said i want everyones granny to be surprised at how easy it was to use.

Edit: I also want to mention the Authenticator is a major upgrade as far as UX to me. It’s all right in front of you. The creating an account process is THE EASIEST PART! Which is great! Just need to replicate that simplicity all over.


#70

This is expected to work, the idea is demonstrate that you can have several services attached to the same public ID, like email IDs and web pages, thus it sounds like it’s definitely a bug there. I just added to our internal list of things to analyse. Thanks @Savage and @upstate, this is a good test case indeed!


#71

I also recreated using a second invitation code before saying something. But felt too greedy to use a third to see if it worked the other way round.
Create public ID first then email ID, I guess that if nobody else said anything it works in that order?

@Nigel I suspect you have the same issue. Create a public ID different to your email ID and it should allow creating services… did for me.


#72

I don’t remember the order I’ve done it (probably first public ID, then email ID with same account of course), but for me it works. If you don’t believe me:

You can visit safe://onepunch.draw
And I’ll respond to mails sent to draw (this evening).


#73

@Savage, @draw, depending in which order you tried it the issue is in the email app, in the web hosting manager app, or in both. This should be a bug just in one or both of the sample apps but not in the API or underlying layers.


#74

I uploaded a site that I was using to help me understand and play with the safe js api safe://test.joe (make sure you have the console open to see it working) . I know noticed after authorising then refreshing three times an error came up in the console
Uncaught (in promise) Error: Core error: Blocking operation was cancelled at onCbReply (C:\Users\josephm\Desktop\safe-browser-v0.2.1-win32-x64\resources\app\node_modules\pauls-electron-rpc\lib\import-api.js:203:19) at EventEmitter.onIPCMessage (C:\Users\josephm\Desktop\safe-browser-v0.2.1-win32-x64\resources\app\node_modules\pauls-electron-rpc\lib\import-api.js:118:14) at emitMany (events.js:127:13) at EventEmitter.emit (events.js:201:7)onCbReply @ C:\Users\josephm\Desktop\safe-browser-v0.2.1-win32-x64\resources\app\node_modules\pauls-electron-rp…:203onIPCMessage @ C:\Users\josephm\Desktop\safe-browser-v0.2.1-win32-x64\resources\app\node_modules\pauls-electron-rp…:118emitMany @ events.js:127emit @ events.js:201


#75

I get the same error


#76

I’m a lousy tester – it all Just Works…
safe://rust.southside

I am pushing no envelopes here, I am on Ubuntu 16.04 and uploading a simple site that has been known to work (apart from the “tRust Me” button which was expected to fail)

The Scotcoin Meetup at Napier Uni last night - in the very room where John Napier invented logarithms BTW - went very well indeed and has generated a lot of follow-up work so please excuse me if it is late until I start trying something more adventurous on platforms other than Ubuntu


#77

I’m loving it, it ts amazing to see the progress from test 1 to test 17. It is a real privilege to be part of this journey.

Very small point but big to the anally retentive like myself :roll_eyes:
I know I am not the only one here that is OCD about symmetry. I find my eye drifting uncontrollably to the new browser logo on the sidetab (only in this location not elsewhere). I like the logo and the design but, the shadow on the lower half and its positioning on a white background makes it appear to be distorted and it has already given me a sleepless night… one and counting.

Could it possibly be given a fine border on the outer edge to have cleaner lines and prevent this illusion?

Or just tell me to go get a life… I’m OK with that too :stuck_out_tongue:


#78

I never noticed that before - but now I’m losing sleep too.


#79

Meant to add - please mail me at
southside

to test the mail.
Can we get a list of folks willing to let their temporary emailID be known?
Only one I am aware of so far is

draw
and he wont be answering until later
.


#80

savage [20 char…]


#81

Email me: Nigel (20 characters)