Feedback for Test 17 (internal testing)


#22

I think something different needs to be done with the barely visible option that toggles apps being able to re-authenticate automatically or not. It just reminds me of those little hidden check marks when you go to install an application and it tries getting people in a hurry to miss deselecting them. The option should be more visible so the user understand it’s important.


#23

We just invited a second batch of forum users :slightly_smiling_face:

Here are a few examples of safe:// websites that have been uploaded to the internal testnet so far:


#24

Looks really nice @Krishna_Kumar. What’s the idea for storing private data? All from the SAFE Browser? Can’t really test the upload/download of private data right now, don’t know if that’s needed either??


#25

I would like to test please :blush: is it possible ?


#26

I’m using the Linux version on Linux Mint 18.1. I can’t seem to authorize the SAFE Hosting Manager.

I start the SAFE Browser and log in with my credentials. I then start the SAFE Hosting Manager which automatically sends an authorization request to the SAFE Authenticator.

Feedback: It’s not very handy that you have to scroll to choose to allow or deny the Authorization request.

I choose to allow the access and the focus goes back to the SAFE Hosting Manager which now gives me an error message.

I’ve retried a few times, but with no success. The SAFE authenticator shows that access has been granted, but for some reason the SAFE Hosting Manager just doesn’t work. I even retried after manually revoking the access in the Authenticator.

Not sure if there are any log files I can supply? The email authorizes without any problems by the way.


#27

One idea is to pin the allow and deny button to the bottom of the pop up window. The scroll bar still provides indication of more text below.

Experienced users then have the option of speeding through if they’re already aware of the full permission grant.


#28

So I decided to switch to Windows. First thing I got when launching the SAFE Browser was a “Windows defender” pop-up saying I had been protected by them blocking access to an unknown app (using Windows 10). The after clicking ‘More information’ I could choose to allow the app. Later it did the same for the SAFE Web Hosting app.

Feedback: Not sure others are getting this, but it’s not a great start for people who are wanting to try out the network for the first time.

So I then went on to proceed with starting the Authenticator and logged in with the credentials I created on Linux. After doing so I got a pop-up from Windows Firewall asking me to authorize the SAFE Browser. Not sure others got this as well? I guess this may be needed either way. Can’t remember it asking me to do so for other browsers or apps. Later it asked the same when launching the SAFE Hosting Manager

So the Authenticator still had the Authorization for the Web Hosting Manager and the SAFE-Mail-Tutorial from when I was using Linux, but when I started the SAFE Hosting Manager in Windows it asked for additional authorization.

Feedback: It would be handy to use the same Authorization for apps on different OS’es. It’s also more clear, because now I have three authorizations for only two apps

On Windows the SAFE Hosting Manager does work for me though.

Feedback: I used the SAFE Hosting Manager to create a public id. Then created a service and chose to upload a folder. Selecting the folder and confirming didn’t do anything however. Tried this several times. Uploading the files separately did work however.

Need to stop experimenting now, but wanted to put this out there:

safe://free.maidfaucet


#29

I got a message from AVG saying they wanted to scan the executable first. Not that weird though, even Windows itself pops up with warnings if I try something new.


#30

This should hopefully go away once the binaries are signed. These internal test binaries aren’t I think. Worth checking against the Mock Versions to see if they also produce that warning as they are signed releases. Shouldn’t be too much of an issue also having these internal test binaries signed for future releases though :thumbsup:

Hmm looks like the app names(and identifiers) arent consistent between the different platforms thereby creating unique identities switching between the different platforms.


#31

First impressions - trying to think like a noob… using Mint 18.1 Serena

Noted the Browser+WebHost+Mail is 367.6MB zipped!

Home page to the browser is nice and clean but links to clearweb that are not accessible, perhaps might as well be plain text.

The SAFE Authenticator Home: “Create Account” at the bottom of the page, is not visible on my laptop =1366x768. Navigating through that authenticator, then see the top and bottom hidden and perhaps more fluid design could work better to see full page?

Authorisation Request popup is shorter than needed and then has a scroll bar!.. that need scrolling to see the buttons. I see noted already.

Thought: the windows all look the same white and grey… colour would help the juggle between the window user is interested in and the Authenticator… perhaps make the Authenticator all one shade or striped or something immediately and obviously different from the web host.

There’s not enough hints on the [create service] to understand what to do for next step… those familiar might navigate this but missing instruction to update and then map etc.

why when I type servicename does it suggest “servicename-root” - I delete that “-root” because I don’t know that it might be useful??

So, having got through that, it makes a lot of sense to create service as a name and then upload into it.

The back button top left is a poor option for navigating.

The Manage Files: list of documents uploaded

  • offers [delete] but I click at the filename wanting an option to rename it rather than to download it.
  • does not declare the url!.. just suggests _public/domain/service

but it works :smiley:

safe://hello
safe://yvette
safe://heaven

I wondered that suffixing /index.html is a bit redundant following requests to simple safe://domain - don’t get that visiting clearweb google for example.

I like a lot the Hosting Manager: Home design
but the [Create Service] on first passes does not suggest clearly enough in which domain you are adding service… and misleading then the list [Select a container to be mapped], so I’m adding to /yvette/ but seeing container for /hello/ as the only location orientation detail. That the domain is actually suggested in the right side of the URL is less obvious than it should be… simply make it larger or bold perhaps?

Web Hosting terminal messages are a bit cryptic:

FFI cross-boundary error propagation:
 --------------------------------------------------
| **ERRNO: -106** CoreError(No such entry - CoreError::RoutingClientError -> NoSuchEntry)
 --------------------------------------------------

Given the Authenticator is part of the Browser, it’s kind of odd that it does not have the menu panel on the left side or apparently any link back to home.
I’m surprised not to see a [Home] button on the URL toolbar next to the other navigation.

beaker:favorites SAFE Network Directory points to a url that now exists but oddly fails. Putting the same request to the URL bar does work. Given I haven’t figured out to hack the new API to get at testing sites, there is not updating directory just yet - just that placeholder for expecting people might use that favourite button.

/end-of-1st-pass… good impression all round - was fun and no big issues - would recommend :slight_smile: :thumbsup:


#32

Immediate impressions (Debian)…

SAFE Browser

  1. I ran the browser - no need to set permissions - good.

Feedback: start screen isn’t clear what to do - no clues on the menus - suggest adding something like:

Getting Started:

  • Create New SAFE Account
  • Log in to existing SAFE Account
  • Manage Apps With Authenticator

Each being a link which takes you to the relevant /auth page.

Tooltips over toolbar buttons!

  1. Created an account

Web Hosting Manager

  1. Ran it… I see “Authorisation request sent” but that’s it. No activity in browser (same as @Krekc) so I guess I’m stuck as far as desktop apps go until this issue is resolved. Now working, SOLVED by ensuring no spaces in path to safe-browser or web_hosting_manager.

Try test sites:

  • safe://safeblues.jpl
    Looks fine - music player works

  • safe://berespectful.upstate
    Looks fine, HTML and image load. Hell of a view @upstate! :slight_smile:

  • safe://free.maidfaucet
    Bah, no Safecoin but annoys as intended :wink:

SAFE Mail Tutorial

Stuck at “Authorising Application” as expected (no activity in browser). Should be on now, see SOLVED above.

Dang! I’m not gonna run Windows to play with this - any word on fixes for non-Ubuntu? @Viv

Overall impression: pretty slick all round. Things are coming together nicely - can’t wait to get to grips with this, port my demos and play with apps!!! :slight_smile: 5 … 4 … 3 … 2 … 1 … :rocket:

EDITed to hide my stupidity :wink:


#33

@Krekc It’d been better had the video auto-played. :stuck_out_tongue:


#34

@happybeing

erm… that’s user error… replace user :stuck_out_tongue:
you’ve copied the number of uses of those links(4) into the url…

=>
safe://testing
safe://polpolrene


#35

Good spot! [crawls away]


#36

Is anyone making screen recordings of the tests and putting them on youtube? Tutorial style, with explanations that its a test network, explaining how well things are progressing, interest points etc… I think that would be awesome to have a showcase of whats in the pipeline and i’d love to be able to share these type of videos, people more likely to watch through a video eh?

Video 1: Safe browser, site type 1
site type 2 etc…
Video 2: …

It’s probably worth doing them well too, decent audio editing etc…


#37

I did add the autoplay in the HTML, and for me it did autoplay. Not sure why it didn’t work for you.

Edit: it takes a short while for the video to load of course, even though it’s only ~700kb. So perhaps you pushed play before it was finished loading?


#38

That’s what it was. Patience young grasshopper! :slight_smile:


#39

Nice work folks. Looking pretty slick. Everything seems to work on Windows (I also get the Windows Firewall popup @Krekc ), and I’m going to try a few Linux distros.

Later …

First time unlucky:

Fedora 25
SAFE browser doesn’t launch
[user@localhost safe-browser-v0.2.1-linux-x64]$ ./safe-browser
./safe-browser: error while loading shared libraries: libXss.so.1: cannot open shared object file: No such file or directory
EDIT: Fixed - see below

Second time… lucky

Ubuntu 17.04
SAFE Browser launches :champagne:
Authenticates Web Hosting Manager :clinking_glasses:

Web Hosting Manager
A few observations in addition to those mention in the posts above.

Uploading a 55MB file failed with a ‘self-encryption’ error.

Smaller files (1MB to 25MB) upload fine but the progress bar doesn’t change - stays on 0%.

I agree that the name ‘service’ is not helpful. How about simply ‘site’? as we’re basically creating websites here. So, 'Create site" > safe:// [enter site name ] .id

Also the dialogue around containers and remapping needs thinking through. There’s no explanation as to why you would remap a service.

And clicking on the service name link (e.g. safeblues) doesn’t do anything. Well in Windows it opens the “You’ll need a new app to open safe” dialogue.

OK trying some more Linux distros now.

EDIT:

Ubuntu 15.10
Everything seems to be working. This is a step forward as the previous version didn’t authenticate apps.

Debian 8
Also working :clap: - Authentication didn’t work on this distro before.

openSUSE Tumbleweed
Another success - couldn’t get anythiing to work on this before.

In conclusion
The browser plus authenticator seem a lot more stable and are supported by more Linux platforms than before. No doubt there will be various architectures where it still doesn’t work (I haven’t tried Arch yet) but this is definitely a big step in the right direction. The interface looks good but it’s non-standard and the design and wording will be confusing for newcomers - luckily this is a relatively easy thing to fix.


#40

Good luck with the testing folks. Looking forward to reading the results.


#41

The less new terminology the better. Domain is good for the base of the url… service is odd and perhaps should be ‘subdomain’ - as that is more obviously bound to what we see from the clearweb.

Might there be an option to split out progress on self-encryption and then for the upload?.. as I understand much of the pause on a large file is waiting for client-side and the upload is relatively quick.

Edit: just to note the email app is nice and simple too.