Feedback for Test 17 (internal testing)


#204

Having the UI reviewed by a team that has not spent 4 to16 years deep in the MaidSafe forest will serve everyone well. Putting ideologies and techno-preferences aside will give this long overdue project a fighting chance. You have the right idea @Stark here’s hoping more support it.


#206

I’m trying the safeApp API in a Vue.js ‘to do’ example: [safe://todo.draw]
(safe://todo.draw)

fu ‘initialise’ and ‘authorise’ work, but connectAutorised fails.
Instead of console.log(), I used windows.alert()…
Eventually I want to save the todo-list to the Safe network instead to the local system.
I’m just trying a bit, I’m no web developer: it could be that I made an obvious mistake.


#207

Seems to work for me. It worked before authorising too, although there was a security error in the console.


#208

I can’t test right now, but if you click on ‘OK’ in the popup showed in your screenshot, what popup do you get then (you have to wait a couple of seconds)?


#209

Happy Forum Anniversary to me!

My one true love, most serious relationship for the past few years, and soulmate :stuck_out_tongue: :smiley:

SAFE Network Forums <3 :heart_eyes: :heart:


#210

The popup says the app is registered, but the console shows an error:

events.js:160 Uncaught Error: Async reply came from main process for a nonwaiting requestonCbReply @ C:\Users\John\Documents\SAFEnetwork\TEST\safe-browser-v0.2.1-win-x64\resources\app\node_modules\pau…:170onIPCMessage @ C:\Users\John\Documents\SAFEnetwork\TEST\safe-browser-v0.2.1-win-x64\resources\app\node_modules\pau…:118emitMany @ events.js:127emit @ events.js:201

Clicking OK again brings up a popup saying ‘safeApp freed’ (or something, I didn’t write it down) but no further errors in the console.


#211

Ok, “Application is now registered in the network” I didn’t get yesterday on my Linux Mint 18.1.
I’ll try again this evening, also on Windows.


#212

I tried again (hard reload) and this time I got Application token received, Application authorised by user, and then Application connectAuthorised was rejected - obviously something not quite right.


#213

The browser should hold only one unregistered client. We identified that there was an additional unregistered client getting created. Only 4 clients are permitted per IP and this bug in browser was resulting in 3 or 4 clients on the browser.
The PR for fixing this issue is raised.

We will also have to integrate a feature to clear or free the handles created by the app automatically by the browser. Have added a task in JIRA for the same.


#214

safe://messing.southside
safe://test.joe
safe://memory.savage1
safe://memory.savage
safe://testing
safe://safeblues.jpl
safe://berespectful.upstate
safe://berespectful.upstate1
safe://polpolrene
safe://free.maidfaucet
safe://cheburashka
safe://hello
safe://yvette
safe://heaven
safe://testing
safe://polpolrene
safe://knot.prime
safe://play.davidvideo
safe://onepunch.draw
safe://plant.draw
safe://todo.draw
safe://rsports
safe://rust.southside
safe://davidspeaks

TEST 17 website list updated, current to post #210 (this one)

Might do another showcase vid today at the SF Meetup for people, and in that case you guys will have a chance to see the newest sites too :slight_smile:


#215

Hey guys is TEST 17 working? I’m trying to demo it here at the SF Meetup

I keep getting “Unexpected Core error:: cannot connect to Network”

Me and hunter are trying to use it today, to show from our computers


#216

did you update your ip - its working for me @whiteoutmashups


#217

Update IP,

Like I have to tell them my IP somewhere?


#218

The invitation url that you used to retrieve your token has an update ip button.


#219

Ah OK I was just taking the token out of the URL and trying that. Thx makes sense


#220

safe://its-coming.savage

  • ps takes a few seconds to load.

#221

Just to let you guys know, we’ve updated the frontend binaries you’ve been using for the past few days (same location as where the originals were downloaded from). This is just for frontend apps and doesn’t impact accounts held in the network. So you should find your old accounts intact. These changes mainly include fixes based on the feedback from this thread.

Shona is currently working on the UI for the hosting example. I know we say that often and it is hard to not see them as apps when there aren’t many apps around just yet, but the purpose of these examples are to more highlight API features to devs rather than to end users, but that of course doesn’t mean devs cannot get a decent UX :slight_smile: , which is why we’re working on addressing those issues as well after the browser app itself is sorted.

Change Log:

SAFE Browser: (v0.2.2)

  • Resolved multiple unregistered clients being created
  • Auth pop-up typo fix in description
  • Allow and Deny option will now get pinned to the bottom of the window when text requires scrolling.
  • Minimum width and height set for the landing page
  • Removed safe-js dependency
  • Login page size reworked to fit to screen to prevent the create account link getting hidden in small screen sizes

Email Example: (v0.2.1)

  • Can switch between multiple email accounts
  • Minor UI updates with loaders

Hosting Example: (v0.1.1)

  • Typo fixes

safe_app_nodejs, beaker-plugin-safe-app and beaker-plugin-safe-authenticator updated to use the latest published safe_app and safe_authenticator native libraries

Known limitations:

  • History and bookmarks are not saved in the network right now
  • safe: scheme is not opened by safe browser from the hosting example.
  • Public Ids created via examples are not exchangeable between the apps.
    • This is the error reported with the Access Denied / Requested Entry not found error. This issue is related to the permissions of the service/mail mutable data. The root folder with the default folders are designed for easier sharing and collaboration between apps. Applications can request access to these while the authenticator manages the app access levels. In case of the public IDs, the public ID is added as a key into the _publicNames container. A corresponding MutableData is created by the app and the permissions for the same is set by the app. This MutableData is then added as the value to the public ID entry. Now when the second app tries to add a service to the MutableData created by the first app, it doesnt have the permissions to do so as this was not created by the authenticator. We’re currently discussing a few approaches to resolve this and also confirm if the paradigm we’ve got is what we need or potentially allow the authenticator to manage the public identities itself.

MaidSafe Dev Update - July 13, 2017 - Test 17
#222

That probably solves something else then I thought, because if I open
SAFE Browser and log in, then the ‘ConnectAuthorized’ fu call in safe://todo.draw succeeds 2 times: the first load and one Reload.
After that the ConnectAuthorized fu call is ‘rejected’, until I restart the SAFE Browser.
And If I’ve authenticated another app first (e.g. email), then this succeeds only 1 time.


#223

Nice update, will test now

Any news on this one:

Looks like websites can’t be updated at the moment due to the fact that the browser crashes when you replace old files in the www-root folder with new ones/keep it empty.


#224

Here are some screenshots from the updated email_app. As you can see there’s support for several IDs. My old address: polpolrene seems to be gone. It doesn’t show up in the menu. But feel free to send me some messages at: polpolrene2 and polpolrene3.

Option to pick your ID…