Feedback for Test 17 (internal testing)


#200

Okay looking forward to play with the binaries… UI also starts to mature I saw, nice…


#201

Better than that perhaps, is that there is as little UI necessarily attributed to the network as possible… everything else can spawn as many varieties as needed, to match the variety of user-base.

To which, perhaps need at an early stage to consider option on some route to skins for applications.


#202

You, @JPL, @davidpbrown, myself and I’m sure others feel very strongly about this. I think this stuff needs to be addressed asap. I’m just uncertain if the team is perhaps holding off on that a little until they hire more front end for when allocation of hard drive space etc, that will be critical in adoption.


#203

Internal testing is not something that is new tbh. Think anything and everything that is written in code goes through internal testing first, starts from the time someone writes some code before it gets committed to the point of CI, soak testing, getting different teams to try it and then normally concludes in starting with people from the forum keeping up with dev updates trying it and then more and more people ofc until some bug arises anywhere in that flow and it scales back and starts again :slight_smile:

This time the slight change has been the last but one leg where there is quite a lot of repetitive testing and exhaustive checks across the platforms required for quite considerable change set MD and other things, we just also got in few trusted members of the forum to help test and debug the same along with the internal team(only a few of us internally anyways so not like a large team). So far this has worked out great as you can see from this thread where some of the obvious hurdles are raised and hopefully addressed by the team and allows them to continue with their code too.

It is also by no means meant to be something exclusive as all this is expected to yield is when things scale up to say more forum members, people have a better user experience of the same with the opening obvious issues addressed.


#204

Having the UI reviewed by a team that has not spent 4 to16 years deep in the MaidSafe forest will serve everyone well. Putting ideologies and techno-preferences aside will give this long overdue project a fighting chance. You have the right idea @Stark here’s hoping more support it.


#206

I’m trying the safeApp API in a Vue.js ‘to do’ example: [safe://todo.draw]
(safe://todo.draw)

fu ‘initialise’ and ‘authorise’ work, but connectAutorised fails.
Instead of console.log(), I used windows.alert()…
Eventually I want to save the todo-list to the Safe network instead to the local system.
I’m just trying a bit, I’m no web developer: it could be that I made an obvious mistake.


#207

Seems to work for me. It worked before authorising too, although there was a security error in the console.


#208

I can’t test right now, but if you click on ‘OK’ in the popup showed in your screenshot, what popup do you get then (you have to wait a couple of seconds)?


#209

Happy Forum Anniversary to me!

My one true love, most serious relationship for the past few years, and soulmate :stuck_out_tongue: :smiley:

SAFE Network Forums <3 :heart_eyes: :heart:


#210

The popup says the app is registered, but the console shows an error:

events.js:160 Uncaught Error: Async reply came from main process for a nonwaiting requestonCbReply @ C:\Users\John\Documents\SAFEnetwork\TEST\safe-browser-v0.2.1-win-x64\resources\app\node_modules\pau…:170onIPCMessage @ C:\Users\John\Documents\SAFEnetwork\TEST\safe-browser-v0.2.1-win-x64\resources\app\node_modules\pau…:118emitMany @ events.js:127emit @ events.js:201

Clicking OK again brings up a popup saying ‘safeApp freed’ (or something, I didn’t write it down) but no further errors in the console.


#211

Ok, “Application is now registered in the network” I didn’t get yesterday on my Linux Mint 18.1.
I’ll try again this evening, also on Windows.


#212

I tried again (hard reload) and this time I got Application token received, Application authorised by user, and then Application connectAuthorised was rejected - obviously something not quite right.


#213

The browser should hold only one unregistered client. We identified that there was an additional unregistered client getting created. Only 4 clients are permitted per IP and this bug in browser was resulting in 3 or 4 clients on the browser.
The PR for fixing this issue is raised.

We will also have to integrate a feature to clear or free the handles created by the app automatically by the browser. Have added a task in JIRA for the same.


#214

safe://messing.southside
safe://test.joe
safe://memory.savage1
safe://memory.savage
safe://testing
safe://safeblues.jpl
safe://berespectful.upstate
safe://berespectful.upstate1
safe://polpolrene
safe://free.maidfaucet
safe://cheburashka
safe://hello
safe://yvette
safe://heaven
safe://testing
safe://polpolrene
safe://knot.prime
safe://play.davidvideo
safe://onepunch.draw
safe://plant.draw
safe://todo.draw
safe://rsports
safe://rust.southside
safe://davidspeaks

TEST 17 website list updated, current to post #210 (this one)

Might do another showcase vid today at the SF Meetup for people, and in that case you guys will have a chance to see the newest sites too :slight_smile:


#215

Hey guys is TEST 17 working? I’m trying to demo it here at the SF Meetup

I keep getting “Unexpected Core error:: cannot connect to Network”

Me and hunter are trying to use it today, to show from our computers


#216

did you update your ip - its working for me @whiteoutmashups


#217

Update IP,

Like I have to tell them my IP somewhere?


#218

The invitation url that you used to retrieve your token has an update ip button.


#219

Ah OK I was just taking the token out of the URL and trying that. Thx makes sense


#220

safe://its-coming.savage

  • ps takes a few seconds to load.