Err... demo-app can't reconnect with launcher

For reasons unknown to me my demo-app lost its connection to the launcher, and I can’t reconnect. I’ve tried logging out, closing down the launcher, restarting and logging right back in. But I can’t start the demo-app as it just gets stuck on not being able to authenticate with the launcher. It claims the launcher must be running - well, it is. Also, the launcher isn’t providing me with any options to authenticate the demo-app; it just sits there happily, claiming that there are “No authorized apps”. So there’s no communication between them. (Like a long-time married couple, if you get my meaning!) So I’ve tried, several times, stopping both, then restarting the launcher and the demo-app; no luck so far.

I’m running the most recent versions of both the launcher and demo-app on archlinux.

What’s a bloke to do?


My launcher app lets me approve the demo app but then the demo app has a message saying “Authorisation failed - failed to authorize with Launcher” Its Launcher 0.8.1 with the original demo app. OSX. Was working yesterday?

Same here. It’s not like they are completely divorced though. Occasionally they get it together again! Have you tried creating a new account? For some (possibly coincidental) reason that worked for me.

Obvious given your expertise, but did you try switching your machine off and on again!? :wink:

And welcome by the way :smile:

PS To all: please post which launcher version you are using with reports because there are now two “current” versions!

1 Like

Ahh - well I’m using launcher v0.8.0 and demo-app v0.6.0. I didn’t try switching the machine on and off again, but I might try restarting the network service. Can’t hurt, eh?

Where are Roy and Moss when you need them?

1 Like

Did you manage to load the demo app?

I still cant load it…

For this reason both the launcher and demo should have a matching name scheme relative to the compatible network. If for alpha then “alpha demo app” or “alpha launcher”. Forget minor impeding technicalities. The general public has been made aware (traction is building) and should therefore be handled appropriately. Doesn’t matter if it’s not the issue reported here. It alleviates confusion and adds a degree of clarity for the user however small. Mixing of binaries for the two TEST networks is otherwise more likely. Kill the headaches one shot at a time.


Was discussing exactly this yesterday. For semver though it’s probably easier to rename the “bleeding edge” code as bleeding edge or similar, to not interfere with general user expectations…


Agreed. The term bleeding edge is still a bit esoteric. How about “fragile” or something similar that conveys its instability. “unstable” isn’t too simplistic and obviously derived. Might help quell disappointment.

1 Like

Not sure it is for anyone on here.

I got launcher 0.8.1 working with the demo app after creating a new account. My old account would take about a minute to log in where the new one is under 10 seconds. :slight_smile:

Your thoughts welcomed here - I’ve been running the vault on osx on and off over the last few days. Is this worth doing with a shitty internet connection like mine (10mb down and 1mb up) or am I just slowing things down for other people.



Of course. It’s pretty evident a handful of people are struggling though. This number will likely grow soon. Better to simplify and use common terms. I try to bridge the gap whenever I can.

1 Like

I haven’t tried to reconnect since - but since this was only alpha software I was only interested as a proof of concept. I’ll probably sit back and wait for the beta releases, or at least the next iteration of the alpha releases. Would this have anything to do with my running on a laptop I wonder? Every now and then it goes into sleep/hibernate/whatever mode. (My laptop likes its 40 winks as much as I do!)