Downloaded Safe Browser : Two Problems

Hello :slight_smile:

Exciting and slightly confusing/frustrating times.

I downloaded the Windows 64 Bit version and installed into C:\Program Files

There are two folders:

safe-browser-mock-v0.10.2-win-x64
safe-browser-v0.10.2-win-x64

Thinking ‘mock’ was some kind of mock, I went into ‘not mock’ found the exe and ran it. Javascript error appeared.
Capture

Curiosity got the better of me and I went into the mock folder, double clicked that exe and the Safe Browser fired up! Tried some… url’s… like safe://tetris/ and safe://jamz.demo3/ and nothing… just an endless loading indication.

Am I doing something wrong?

I can’t help with the JavaScript error, but mock is “mock routing” so it’s pulling stuff off “fake vaults” on your computer. None of the testnet stuff will show up using that. It’s mostly for development.

1 Like

Ok thanks for that. At least I can rule out the mock version.

I know nothing about JS as well however I’m guessing the error is saying it can’t make a folder that it needs to make. This may be because I installed into C:\Program Files which needs Administrator permissions to do stuff inside. I’m guessing though.

That’s what I’m guessing too. Try putting it anywhere within your User directory (C:/Users/<your username>/).

I reinstalled as @bzee suggested and the Safe browser fires up.

I try to sign in and I’m told my account doesn’t exist!

Maybe I need to move the folders rather than reinstall them. Problem is that when I tried to move them, halfway through the cut/paste process I was told ‘something’ was accessing a folder and so the process couldn’t complete. So I decided to reinstall from scratch.

ah… I’m an idiot! I created my account using the mock version as so my account doesn’t exist.

Restarted and freed up the folder issue, moved the ‘not mock’ folder into a user directory, created a new account (using same details as before) and everything works. I have had a game of Tetris :slight_smile:

It’s not unusual to chose C:\Program Files to install programs into though and it would be good if the difference between mock and not mock was more explicit.

Happy bunny.

Thanks for the help chaps.

3 Likes

You are not, you are an early adopter, and that’s a totally different level. I’m happy you get it working, things will become easier and easier as we all want that here, but this process needs people like you to help us out.

10 Likes