Difficulty accessing safenetforum.org

I’ve been a long time reader of the forums but the last two days I have received the following error message accessing the maidsafe forums on my laptop with windows 10, chrome browser (also tried Mozilla unsuccessfully) :

“Your connection is not private
Attackers might be trying to steal your information from safenetforum.org. NET::ERR_CERT_COMMON_NAME_INVALID.”

I’m not a programmer and not sure what this means. I’ve never encountered this before and in addition I am able to access the forums on my cell phone (hence this message). I attempted to allow this website to trusted websites but am not able to add it to the exceptions. I also tried Mozilla but same error message. I would appreciate your input and expertise on how to resolve this error message. I don’t want to be missing any of the exciting upcoming updates :sunglasses:

1 Like

safenetforum.org has nothing to do with the Maidsafe forum, this was way back in the past, but that domain has nothing to do with the SAFE Network anymore. safenetforum.org is the current forum of the SAFE community.

Check for updates every thursday here:
https://safenetforum.org/c/development/updates

And welcome to the SAFE Network forum :stuck_out_tongue:

2 Likes

Oh my gosh. That was a complete noob mistake.

I had the safe network forums saved as a bookmark and i’ve always clicked that to access the forums, but these two days have given me that message (not sure how that .io got changed?). Irregardless, after I changed the .io to .org, it works normally on my laptop. I will just re-create that bookmark.

Thank you so much for your help!

4 Likes