Crust Test v2 (concluded)


#82

My firewall table rules do allow existing connections, but I guess this test client closes connections and reopens only when needed, so it was stymied and panicked.

maidsafe team – what is a good ip-tables rule or ruleset to use to allow this test and maybe the future network? Or will we in the future just set a general rule like I do for Tor? e.g. :

-A OUTPUT -m owner --uid-owner debian-tor -j ACCEPT

I wonder about this as I’ve never been able to get any torrent client to work with a decent firewall and I suspect the safe network will be more akin to a torrent client than Tor or I2P networks.


#83

I’ve been running the test on a third Mac with 10.13.6 installed (different to the two I tried yesterday) and it worked first time and I’ve left it running for a couple of hours so far, will keep it on. Results seem in line with the average but UDP HP is far more successful that the other methods for me:


#84

Hey @Vort
100% success means you have been succesful in connecting with every other person you have attempted to connect with. If you filter by your name and scroll down to the table you will see more detail for each connection :smiley:


#85

Crust will try to connect through all the protocols simultaneously


#86

That is strange, because I was expecting that incoming connections will have 100% success rate, not outgoing (not my PC trying to connect, but others).


#87

@neo - the Refresh Data button should retain the filter selection.

I just triple checked with a bow on top here and these settings are maintained.

Edit: I’m on Mac using Firefox on the office wifi.


#88

A little GIF for folk not taking part.
57


#89

Brilliant work @Savage - I’ll have to up my game for future posts!

To be fair, @Viv suggested I

“get my ******* finger out and use GIFs as it’s not 1998 anymore!”

for the last test and I took the fingers-in-ear-la-la-la approach.

David.


#90

I must be goin blind. Where did that orange refresh button come from?

I know the browser was not wide enough and it wasn’t showing one the screen. Damn these wide web pages :thinking:

Feature request: Put orange refresh button on left hand side for those of us who do not have their browser full screen, since they actually use their computers for computing rather than browsing :stuck_out_tongue_closed_eyes:


#91

I vote for a fixed position refresh BAR across the top so I don’t have to scroll up push, then scroll back down … am I being too lazy here or what?


#92

Successful connections: [“NSA (3bcaba…)”, “jpl-win-vpn (5d090b…)”,… I see US national agencies are big on Crust testing :smile: We should contact JPL guys to help launch SAFE Network mainstream once it’s ready


#93

Argh - I missed one (just one I hope). I’ll whip it out the OP.


#94

NAT with default firewall succeeded 76% of the time, while NAT + DMZ only failed to one peer.


#95

The filters are correct, it’s just that we haven’t seen any EDM NATs so far (which is a bit surprising to me personally – I expected to see more of them!)

We keep track of this data but it’s not displayed on the dashboard because there’s not much to display really – with random ports/IP addresses it’s virtually impossible to predict a next port number and thus connections with hole-punching are not possible. However, if IGD succeeds, the client will proceed with direct connections only.

Ah yes, the most important bug was fixed! :smiley:


#96

Ah no, it does not. We don’t use HTTP for this test: all communications are going through TCP/UDP sockets, so unless your HTTP proxy also provides a system-wide SOCKS5 proxy, it should be all fine. :+1:


#97

Were there EDM NAT’s with the previous Crust Test v1?


#98

Is it normal that the console closes automatically?


#99

Are you using Windows?

It’s possible if Symmetric NAT with randomised IPs/ports has been detected. You can confirm that by looking into the log file with a name like client-123xxxxxxx.log, if closer to the end of the file it says something along the lines of RendezvousFailed, then that’s the case.


#100

I’ve found using Windows that when my laptop goes into Suspend/sleep mode the process terminates


#101

Yes, I am using windows 10.

@JPL That is not the case because I am working on this PC during the process.