Crust Test - NAT Traversal (concluded)

Are you sure? It works for me.

2 Likes

Ah yes, I had NoScript on :blush:

1 Like

Looks like another case of

Oh I see! I didn’t look closely enough at what you were doing. You’re so close, man!

  • Okay, click on the 3x3 dot grid in the lower left hand corner of your screen.
  • Search for Terminal
  • Open it
  • Type: cd ./Downloads/crust, then press tab and terminal will auto-complete the rest of the directory name, press Enter.
  • Type: ./client to execute

Assuming the directory is in your Downloads, couldn’t quite tell from the image.

4 Likes

Running it from GUI might work if it is marked as executable (right click on file and look in properties).

2 Likes

i checked that before i answered to not forget to mention the easiest of options - but it was already marked as executable when i checked and still threw the error when double-clicking

3 Likes

Hello everyone,

I just tried to launch the test client and , as @tobbetj and @jlpell I get :

Symmetric NAT with non-uniformly changing port mapping detected. No logic for Tcp external address prediction for these circumstances!

This is on the technicolor TG788vn router by OVH in France, I hope this can be useful !

3 Likes

Hello everyone, as a non tech i have tried to run the test, on a macbook with High Sierra.
I just followed the tutorial and it works!
Thanks Maidsafe team for the irregular heartbeats, this is really cool!

Successful connections: [“Optimator (622fb3…)”, “aleks (b3e8e9…)”, “Sascha_PiaVPN (f8f330…)”, “Darius (ec1742…)”, “John (d39b76…)”, “mackrevinack (57cf1a…)”, “Chris (386212…)”, “Arcturus (88f264…)”, “More Salvorin (ba18b5…)”, “Hunter (39e31f…)”, “ILoveSAFE (ce6f8f…)”, “tobbetj (dc66bd…)”, “sergio (59f92c…)”, “digipl (8c1446…)”, “SuperNode (17fab8…)”, “sucksess (ca1a86…)”, “brad (a03cf0…)”, “krekc (315fa7…)”, “phideas (6de60f…)”, “702e45…”, “Attack of the Killer Cumnockians (45cf2d…)”, “btaylor (58f25e…)”, “oetyng (11aa02…)”, “8f513d…”, “bittog9 (b80ac9…)”, “Just Salvorin (c58b94…)”, “johnsnow (f6cd03…)”, “treslumen (b5e88f…)”, “Vort (746b54…)”, “mrmagpie (b0969b…)”, “mrmagpie (a327cc…)”]

13 Likes

I note that you seem to be connected to mrmagpie twice. Maybe that person actually does have two instances running, but I also seemed to connect to somebody twice (Toivo) and he said he only had a single instance running, but had restarted it a few times.

I wonder if there’s a bug here, as it seems to report dup connections that don’t actually exist.

1 Like

I’ve restarted it ones, so it is running for the second time now, maybe that makes sense as you have restarted it too?!

I read your text to fast, i see your point.

1 Like

Thanks that helped

@ dugcampbell was right in the video
“This is a friendly community that helps” :stuck_out_tongue:

Thnx @Southside, @drehb & @hunterlester and actually everybody else who’s making this network work. :+1: super ants

12 Likes

Is there any chance of getting a better vizualiser on the https://crusttest.maidsafe.net/ site? We are after all showing this to the world.

Some I like:

https://ethstats.net/

http://dailyblockchain.github.io/

And perhaps maybe even a chat screen on that page!?

The more we can show interested folks all around the world how many of us are out there, the more powerful this will be, we are the life blood of the network and we need to show the world we are here, there are many of us, come and party!

3 Likes

I do support this, especially making the page load faster, but no rush. It’s only been there up for a couple of days, and I’m sure there are more important things to do.

1 Like

Finally got to try this and using a win10 laptop.

I did the preliminary stuff and set the IP address.
Ran the application
It opens a cmd box and trys connecting etc. (maybe 30 to 100 seconds)
THEN the cmd box just disappears (program ended I guess)
It does connect to “southside” incidently early on

What am I doing wrong?

Log file last entry says “Failed to get our connection info”

Nope and after a number of times and WiFi is solid

EDIT:
Connected through VPN (with its own NAT) and it seems to be working.

EDIT2:
VPN only works for about 2-5 minutes then comes up with that error

2 Likes

mrmagpie here, I did not had two instances runnning. But I did restart one or two times.

3 Likes

Hi all - just to confirm, we’re now stopping v1 of the Crust NAT Traversal test - see Conclusion of Crust Test (v1) for further details.

Thanks to every single person who took part! We truly appreciate all of the time and enthusiasm that you all showed in helping us get this vital information back. Roll on the next test! :smile:

24 Likes

I’ve noticed that I would get some warnings just before the process would complete in the crust client and that would happen because of my IP address changing. So if the ISP is periodically changing IP addresses then will crust deal with this easily outside of these tests that are designed to prevent spamming? Does bootstrap cache just try to immediately reconnect you? Is there down time in connection interrupting any network services?

5 Likes

Dang I missed it! Next one!

4 Likes

Been busy, but it’s so great to see MAIDsafe maturing as a project! So proud of you guys. So exciting!!! :slight_smile:

Thanks @dirvine I appreciate your sacrifices. With this tech it will aid and assist honest & transparency the bed-work of all human virtues.

14 Likes