Could a Mod or high up help me?

Please check my credentials. I firmly believe I meet the criteria for a Trust Level 1 person. Anyway, by reading another thread, I got the link to get to the login part of TL1 to participate. It asked me to set my IP, which I did, and asked me to write down or remember some lengthy pw… and that was it.

There was no “next” button, no ‘pop up’ box after I set my IP. I couldn’t do anything. I shut down my chrome browser and tried again. Same result.

To be fair to your project, for other security reasons, I have 3rd party cookies disabled, WebGl disabled and WebRTc (or something) disabled. If I need to adjust this, please inform me. And please provide the link to me again. Thank you very much.


Yes, you are TL1. Have you downloaded and installed SAFE Browser yet? If so:

Step 1: log onto the forum using your usual web browser, e.g. Chrome
Step 2: go here and click on the icon
Step 3: select Alpha 2
Step 4: select update IP (if the two IP addresses shown are identical you can skip this step)
Step 5: click on the clipboard icon to copy the invite code
Step 6: start SAFE Browser and follow the steps to create an account. When asked, paste in the invite code

Doesn’t have to be in that order necessarily, but that should work.


Alright, thank you. That worked. I did not have the SAFE Browser.

I’m in. Is there any way I could talk to a mod in private? If so, how?

Just use the Private Message facility. Click on the avatar of the person you want to contact, then select Message.

Edit: I should probably add that it’s best to contact the mods rather than the developers as they are very busy and you could be a while waiting for a reply.

This topic was automatically closed after 60 days. New replies are no longer allowed.