CoreError::RequestTimeout when creating account

#1

Hey fellow SAFE’rs!

So after getting level 1 on the forum, I have downloaded and unzipped the SAFE browser,
safe-browser-v0.12.0-linux-x64
on Linux Mint 19.1 XFCE edition.

Browser runs beautifully. After getting my invite and inputting it into account creation, it accepted my secret and password (what’s the diff?) before hanging for several minutes. Finally, this error came up.

Account containers creation error: NFS error: NfsError::CoreError -> Request has timed out - CoreError::RequestTimeout. Login to attempt recovery.

This error is in small red text underneath the invite token on the second page of the SAFE Authenticator page.

Any suggestions? Could it be blocked by my ISP?
cheers,
Jordan

0 Likes

#2

Hi Jordan,

Quick question… are you running from the same IP as the one you registered at the time of invite?
If you have changed you just need to whip back on to the invite page and update the IP to the current one.

2 Likes

#3

Hi Jordan,

I’ve tried to reproduce your issue but it works OK for me - if you don’t set the IP address at the invite page there is an error when attempting to log in with the browser but it is not the one you have specified.

Just to confirm, these are the steps you need to go through:

  1. Claim invite token from invite.maidsafe.net and set IP address.
  2. Launch SAFE Browser and select “Create account”
  3. Paste invite token
  4. Create secret
  5. Create password

It’s after this point you’re getting the error, right?

Is it possible you were experiencing some connectivity issues? Have you tried again?

3 Likes

#4

I have a similar issue with my home connection using the ISP router, I’m not sure if I’ve ever got the timeout error exactly, but it does take a loooong time to log in or in general for any operation I do interacting with the alpha2 network. I usually have to switch to use my mobile as hotspot to be able to connect and operate normally. So there seems to be some problem with some routers, or ISP’s setup perhaps

2 Likes

#5

Hey everyone, thanks for the fast replies!
Yes, my IP address is matched and done correctly.

Unfortunately now I have a new problem – “Invitation already claimed”.
FYI @draw

1 Like

#6

I’ll PM you a new invite. Ps: should you need an invite a next time, please ask @ moderators.

0 Likes

#7

I also have this problem sometimes - but only with Linux not with Windows. I have other problems with Windows re the Web Hosting Manager not connecting (which @bochaco @hunterlester and I tried to get to the bottom of a while back) but only on one machine. So it looks like one (or more than one) of those strange bugs that only affect a few people. Hopefully it will fix itself as the codebase matures. @jorxster Do you have another machine you could try, or another OS?

0 Likes

#8

Just to clarify, this particular one is not related to connectivity with the network but between the apps through the system URI, right? that was my take from when we looked at it

0 Likes

#9

Just to clarify, this particular one is not related to connectivity with the network but between the apps through the system URI, right? that was my take from when we looked at it

Yes that’s right. I was just highlighting that some of the issues that exist are OS- and even machine-specific, so it’s always worth trying again with another machine or OS if you have one.

2 Likes

#10

ahh right, got you! thanks @JPL

1 Like

#11

Update

Almost there.
Using 4G and a new invitation from @draw I managed to create an account.
However no sites work that I can find–
trying
safe://listy
safe://2048.net

I just get
" Unable to navigate to site. Will automatically reload when network is connected..." message in browser.

Or
" No content found at requested address."
I tried some other sites I found here

No sites work.

0 Likes

#12

That was the old topic. They had to reset the network and their is a new topic with current sites.

2 Likes

#13

Try these ones List of Websites/Safesites & WebIDs (Community Resources)

3 Likes

#14

Thank you @upstate!

So, one site came up with a sort of default page describing index.html and other subpages.

But then after the rest of the sites (about 10 tried) including the first, give me

Unable to navigate to site. Will automatically reload when network is connected...

So, maybe it’s my company’s firewall, but it’s not at all usable here. (I’m in New Zealand working at a large IT company).

I will be keeping an eye on this new technology! Thank you for your help.

0 Likes

#15

Yeah, I’m fairly sure I’ve encountered something similar to the issue you described. One of those “lovely” intermittent ones which are a total pain to reproduce…!

2 Likes

#16

Are you showing any apps authorised? Eg:


(For clarity I don’t mean you need to have authorised these for the browser to navigate to sites - you can do so without signing in - but this would confirm whether or not you have successfully connected to the SAFE network.)

3 Likes

#17

Hey @Karamu,
That was actually part of the solution!
Because of a big orange header warning, I never saw a prompt that SAFE Browser was asking for permission.
I have authorised it, and it is working , on my home network! Sites load in a timely manner.

YUS!

3 Likes

#18

Ah, great, glad you could get it sorted! Yeah, the banner pop ups can “pile up” if there’s more than one being displayed.

Anyway, welcome to all things SAFE - there’s plenty of folk here in the forum ready and willing to help out with any questions / issues you may have.

2 Likes