Code error on Peruse; account doesn't exist on SAFE browser

Hello,

Here’s an issue I couldn’t resolve on my own (even reinstalling the apps didn’t help). When I try to log onto the network using the SAFE browser, I get the message “account doesn’t exist”. I know that my username and password are correct. The IP has also been updated.

When I try the Peruse browser instead, I’m able to log in, but if I try to visit an address, I get the following message: Core error: Routing interface error -> EventSenderError(EventSubset(“SendError(…)”))

Anybody knows what’s going on? Thanks in advance for your help.

Hey @Bogard, can you please double check and confirm you downloaded the SAFE Browser which connects to the Alpah2 network rather than the one which connects to the mock routing?
If you look at the latest release: Release SAFE Browser v0.9.0 · maidsafe/sn_browser · GitHub, you can see there are some of the binaries with -mock in their package names, please make sure you are using the one which doesn’t have -mock in the package name and let us know. We are already working on making this distinction visible in the UI for next versions of Peruse browser.

(cc: @joshuef ) I’ve seen that error only upon an internet disconnection event as the re-connection flow is still not fully functional on Peruse. Could you please let us know if this is the scenario when you are getting that error? can you please confirm that when your internet connection is up and you launch Peruse you can open any URL on safe network?

2 Likes

Thank you, Bochaco.

Re: mock SAFE browser, that was the problem. The pinned link in my dock (Mac) was opening the mock version of the browser since I have both downloaded. When I go to the application folder itself to open the right version, I’m able to login. Thank you.

Re:Peruse error, my internet connection is pretty consistent as in I can access all other links on traditional internet or SAFE browser yet I get that error on Peruse. I’ve actually never been able to open a safe URL using Peruse, including the previous version. I didn’t try to troubleshoot the issue previously because the SAFE browser was working great (i.e., my system hadn’t had a mock version to be confused by).
Even when I kill my VPN and try Peruse, I still get the same error code.

Hey @Bogard, so to summarise, you’re still not able to login in peruse, but are able to login in the latest Safe Browser (to alpha 2).

But on top of that, you cannot access safe sites at all in Peruse?

No, login has never been an issue with Peruse. I could always login with this version as well as the old. But I cannot access any url.
For this Peruse version, trying to access a url yields the code error that I reported above.
For the previous version of Peruse, trying to access a url leads to nothing–literally nothing happens when you type the url and press enter.
If helpful, I’m on Mac OS 10.13.3

1 Like