Change default editor - Filezilla

Pulling my hair out over the stupidest nonsense ever.
Can some please tell me what I am missing.

In Filezilla, remote site, right click view/edit opens the file in Firefox.
I want it to open in Brackets and have done the usual.

Edit, settings, filetype associations, inherit filetype associations. Brackets being my default.
Also tried setting custom editor ./Desktop/brackets.desktop

It keeps opening in Firefox… whyyyyyyyy :woozy_face:

linux mint

Guessing that you are a on Linux… not having used Filezilla or Brackets

but… surely it’s just the file association that needs updating?.. so, if it’s anything like Caja, find an instance of a file, the kind of file extension you want opened in Bracket … .txt perhaps… right-click properties [open-with].[Add]=Bracket

also Google suggests

For setting default editor in filezilla follow these steps.

From Edit => Settings , click on Settings . From Settings Pop up window, left side panel click on File Editing. After selecting File editing, right side options will be updated. Under Default Editor , select Use Custom Editor .

1 Like

Thanks for jumping in here, yes Linux

I have done this, it is Brackets.

I have also done this, no luck.

Solved by adding

html /usr/bin/brackets

to filetype associations in Filezilla.

3 Likes