Can't seem to get on the net

safe-browser

#1

I followed all the steps to get in and was able to get on the browser…sort of. It says I’m connected but it appears that I don’t have the latest version of the browser so I can’t actually use the net. I have the SAFEnet homepage and the SAFE authenticator but can’t seem to do anything with either. Do I need to update something or is it just like this because it’s currently in beta phase. The pictures of the pages I’m getting are shown below.



#2

Use this

SAFE Browser is no longer use Peruse.

:stuck_out_tongue:


#3

This topic was automatically closed after 60 days. New replies are no longer allowed.