Can't get TEST 18 & 17 to work

nothing
working

#1

so yeah, test 18 software keeps spinning for hours,

and test 17 defaults to the test 18 invite system which keeps hanging “please wait” forever,

really trying to test some things on a network,

has anyone had luck with anything? Only have windows right now. Thanks!


#2

Update: looks like I can still activate TEST 17 IP’s even though it says TEST 18 across the screen.

So test 17 seems to be working at the moment for now


#3

I have similar problems with one computer and is the windows Firewall who block the network. I don´t know why the firewall pop-up didn’t show.

In other computer in the same network all is Ok.

Windows mysteries…


#4

I just tried on my windows machine. Am able to connect with TEST-18 without any problem. As @digipl suggested just ensure that the firewall permissions were granted for this version. When you encounter this problem again, please do share the authenticator log file which can be found in the binary folder. The log file might help us in identifying the issue. Thanks @whiteoutmashups.


#5

I was able to connect to the network earlier today but now i keep getting requesttimeout, I tried with two different accounts and neither worked and made sure my ip was updated as well, as far as i can tell there have been no changes to my computer since i last successfully connected to the network, here are the errrors I got from the console

here is the authenticator log

T 17-08-05 23:12:29.112387 [safe_authenticator::ffi mod.rs:95] Authenticator - log in a registered client.
T 17-08-05 23:12:29.112387 [safe_core::client mod.rs:414] Attempting to log into an acc.
T 17-08-05 23:12:29.166266 [safe_core::client mod.rs:424] Creating throw-away routing getter for account packet.
T 17-08-05 23:12:30.174971 [safe_core::client mod.rs:1439] Waiting to get connected to the Network...
D 17-08-05 23:12:31.251303 [routing::states::bootstrapping bootstrapping.rs:265] Bootstrapping(4f200d..) Received BootstrapConnect from 08c2d9...
D 17-08-05 23:12:31.251303 [routing::states::bootstrapping bootstrapping.rs:331] Bootstrapping(4f200d..) Sending BootstrapRequest to 08c2d9...
D 17-08-05 23:12:31.318294 [routing::states::client client.rs:89] Client(4f200d..) State changed to client.
T 17-08-05 23:12:31.318294 [safe_core::client mod.rs:1457] Connected to the Network.
T 17-08-05 23:12:31.421412 [routing::states::client client.rs:256] Client(4f200d..) Got UserMessagePart 6add32.., 1/1 from NaeManager(name: 78fd21..) to Client { client_name: 4f200d.., proxy_node_name: 08c2d9.. }.
D 17-08-05 23:12:31.422413 [routing::state_machine state_machine.rs:403] State::Client(4f200d..) Terminating state machine
T 17-08-05 23:12:31.494402 [safe_core::client mod.rs:464] Creating an actual routing...
T 17-08-05 23:12:32.501652 [safe_core::client mod.rs:1439] Waiting to get connected to the Network...
I 17-08-05 23:12:33.586292 [crust::main::bootstrap mod.rs:213] Failed to Bootstrap with 139.59.190.50:5483: (ClientNotWhitelisted) Our Client is not whitelisted
D 17-08-05 23:12:33.588286 [routing::states::bootstrapping bootstrapping.rs:265] Bootstrapping(7c6674..) Received BootstrapConnect from 982a7c...
D 17-08-05 23:12:33.589292 [routing::states::bootstrapping bootstrapping.rs:331] Bootstrapping(7c6674..) Sending BootstrapRequest to 982a7c...
D 17-08-05 23:12:53.591293 [routing::states::bootstrapping bootstrapping.rs:247] Bootstrapping(7c6674..) Timeout when trying to bootstrap against PublicId(name: 982a7c..).
D 17-08-05 23:12:53.591293 [routing::states::bootstrapping bootstrapping.rs:364] Bootstrapping(7c6674..) Dropping bootstrap node PublicId(name: 982a7c..) and retrying.
I 17-08-05 23:12:53.591293 [routing::states::bootstrapping bootstrapping.rs:141] Bootstrapping(7c6674..) Lost connection to proxy PublicId(name: 982a7c..).
I 17-08-05 23:12:54.693190 [crust::main::bootstrap mod.rs:213] Failed to Bootstrap with 138.68.147.124:5483: (ClientNotWhitelisted) Our Client is not whitelisted
D 17-08-05 23:12:54.695191 [routing::states::bootstrapping bootstrapping.rs:265] Bootstrapping(7c6674..) Received BootstrapConnect from 313890...
D 17-08-05 23:12:54.695191 [routing::states::bootstrapping bootstrapping.rs:331] Bootstrapping(7c6674..) Sending BootstrapRequest to 313890...

#6

Are you on test 18, we did close down 17 as it was confusing people.


#7

yep on testnet 18 I got the invite from the weekly update and I am using safe browser 0.4.0

would it matter if the account secret and account password were the same ones used on testnet 18 as testnet 17


#8

No it should not, test 18 is a new network.


#9

Same problem here on Thursday. Tried again today, same problem. I don’t even think I have a firewall. I know a .PAC file was attempting to download multiple times. I have a bunch of those, but I don’t know if they’re needed. I have no idea about this stuff and can’t remember the technical details of some things in 2 weeks of inactivity let alone months. I have AVG antivirus.


#10

If it’s downloading PAC files it probably means you have a network proxy switched on. Dunno if it will make any difference but you could try (Windows) Settings / Network & internet /Proxy / turn off ‘Use setup script’. It will at least stop all those PAC files building up.:slightly_smiling_face:


#11

Just to note I’ve had a run of [Our Client is not whitelisted] and wondered if new IP is not being communicated.


#12

my accounts that weren’t working yesterday are working today, a bit strange,
also I was given a pair invites yesterday that both worked so I dont think it was my connection or computer


#13

The error logs certainly help, cheers for that. Think I might have an idea whats happening here and its certainly not to do with the tokens. Just from the logs

D 17-08-05 23:12:33.589292 [routing::states::bootstrapping bootstrapping.rs:331] Bootstrapping(7c6674..) Sending BootstrapRequest to 982a7c...
D 17-08-05 23:12:53.591293 [routing::states::bootstrapping bootstrapping.rs:247] Bootstrapping(7c6674..) Timeout when trying to bootstrap against PublicId(name: 982a7c..).

Looks like the proxy after having a client disconnect from an IP refuses to accept another client from the same IP for two hours after the client has gone offline. I mention two hours as thats time the time after which the entry in that check would expire and the proxy would allow the IP again.

Ideally that check should have occurred after checking if the incoming message is a BootstrapRequest from a peer who is a Boostrapper as then that peer would be purged from dropped_clients as expected on receipt of the BootstrapRequest message but here due to the check, the BootstrapRequest message is not handled and instead just ignored, which then causes the timeout client side on waiting for a BootstrapResponse …

Just running some tests locally with a simple patch if ok might be able to update the proxy nodes with the fix. Just need to do it quite slowly between the nodes to prevent wiping the network, will update in the Dev update thread when pushing the patch and hopefully that resolves the issue.


MaidSafe Dev Update - August 3, 2017 - Test 18
#14

guys what is this and why does it happen every time I try to visit any link in the SAFE Test 18 browser, and why does it always open a never ending recursive series of new tabs that never lead anywhere

completely prohibiting me to view any website on test 18


#15

ugh

we did it again, we took down a perfectly good stable TEST 17 when test 18 doesn’t work at all…

can we please stop this pattern, was very nice to have a working testnet and now it’s dead again…

can never progress with SAFE projects… no wonder we never see new apps coming out


#16

please give us back test 17,

I’ll literally pay you money MaidSafe, if you give us back the stable test 17 network!

have several projects going on, including creating the software for our Meetup on tuesday

sorry just have a few different pressures on me from several different people right now. Please


#17

It seems to be working well for most people, and this is of course the point of tests. When these bugs are ironed out it will become alpha2 and then be stable for development while development proceeds on testnet 21, 22 etc

The problem was that Alpha 1 could not be protected from sabotage and so could not be left up, and Test 17 didn’t make the grade to become Alpha 2.

You do though now have other options (mock and local networks), but the real benefit will be to help maidsafe fix the problems you are finding and get to Alpha 2 ASAP.


#18

does test 18 work for you.

if anyone has it working, could we jump in here so I can show you that new tab glitch part that’s preventing everything?

appear.in/bringtest17back :slight_smile:


#19

I was also having problems on 18 w/r/t timeouts. Setting up a local test net allows you to negate the checks there and that works great for me. Can dev happily against that.


As for: why does it always open a never ending recursive series of new tabs, what system are you on? And do you have any other versions of the SAFE Browser installed at the mo?


#20

win10, windows surface, my only working computer right now

and the browser doesn’t really install, I’ve just been downloading the folders from github and extracting to the desktop. so nothing should interfere,

only v0.4.0 by the way